Deploying an Image hangs at "Checking Queue"



  • I work for a small company which has been using FOG for its imaging purposes for a few years now. Recently we had to transfer our FOG installation to a VMWare ESXi host. The server is currently operating on a virtual machine running Ubuntu 11.10. We are using FOG 0.32 with the 3.6.9 Core kernel.

    After installing and configuring FOG I was able to successfully upload an image to the server. I am now testing this image by attempting to deploy it to another machine. Currently I am working with a Dell Latitude E5500. When I attempt to push the image to this client FOG appears to load correctly. This is what appears:
    [CODE]* Checking Operating System…Windows 7

    • Checking CPU Cores…2
    • Send method…NFS

    *Checking Queue…Done
    * (0 sec)
    * (5 sec)
    * (10 sec)[/CODE]
    The count then increases every five seconds and will run for an indeterminate amount of time. [S]Currently the longest it has continued to do this without interruption from troubleshooting is twenty minutes.[/S] As of this edit, the count has continued for over four hours.

    Nothing unusual has appeared within our logs when checking them from the web UI’s Log Viewer.

    During my research, I found [URL=‘http://fogproject.org/forum/threads/cannot-deploy-images-require-assistance-asap.3607/#post-8412’]this thread[/URL] which closely resembles the problem I am having. Unfortunately the problem was never fully resolved.

    Following the steps on that thread, I visited the [url]http://[server]/fog/service/Pre_Stage1.php?mac=[mac][/url] page for the client in question, and the following information is displayed:
    [CODE]##@10.10.10.10@10.10.10.10:/images/@RGVmYXVsdE1lbWJlcg==[/CODE]
    I looked through the .php file to try and find where this information was obtained, however I could not find the portion that generated this output.

    Any assistance with this problem would be greatly appreciated.



  • Coloumb - I had the same issue as you but I was able to get it to work. I had only 1 task in taskstate which was the one I was trying to deploy. I set the taskstate to 2 in the database which it removed it from my dashboard so I remade the task for the same computer and rebooted it and the deploy kicked off.



  • After further research I found [URL=‘http://fogproject.org/forum/threads/solved-deploy-task-wont-start-despite-0-in-queue.3635/’]another thread with a similar problem[/URL], which was marked as [SOLVED]. This user discovered that past imaging tasks were not being cleared from the [I]tasks[/I] table. However, after checking my installation’s [I]tasks[/I] table contents only one entry was found (the most recent deployment attempt, which was still hung up at “Checking Queue”). As a test, I killed the task from within the web UI then reloaded the [I]tasks[/I] table. It appears that my problem is not old tasks remaining within this table, as it they are removed after a task is cancelled.

    Additional information about the image:
    The OS I am attempting to push onto the client is Windows 7 Pro x64. I used the same method for preparing this image as I did for our previous FOG server, which was also running Ubuntu 11.10 and FOG 0.32 on an aging box. After formatting the OS as desired I ran the fogprep utility as well as Windows sysprep.


Log in to reply
 

436
Online

38996
Users

10715
Topics

101725
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.