No network interface found! Kernel might not have the correct driver! Lenovo T14 Gen 2.


  • @george1421 said in No network interface found! Kernel might not have the correct driver! Lenovo T14 Gen 2.:
    Okay so imaging with two different USBs did not change anything. still was imaging at 11-20 mb/min.

    This is what happened with the debugging task:
    Command:

    lspci -nn | grep -i net

    Results:

    00:1f.6 Ethernet controller [0200]: Intel Corporation Device [8086:15fc] (rev 20)
    09:00.0 Network controller [0280]: Intel Corporation Device [8086:2725] (rev 1a)

    Command:

    ip a s

    Results:

    1: lo: <LOOPBACK,UP ,LOWER _UP> mtu 65536 qdisc noqueue qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever

    2: emp0s31f6: (BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 84:a9:38:7a:3f:e6 brd ff:ff:ff:ff:ff:ff
    net xxx.xxx.xxx.xxx brdxxx.xxx.xxx.xxx scope global empOs31f6
    valid_lft forever preferred_lft forever

    Command:

    lsblk

    Results:

    NAME MAT:MIN RM SIZE RO TYPE MOUNTPOINT
    nume0n1 259:0 0 4776 0 disk
    |-nume0n1p1 259:1 0 100M 0 part
    |-nume0n1p2 259:2 0 16M 0 part
    |-nume0n1p3 259:3 0 476.3G 0 part
    `-nume0n1p4 259:4 0 508M 0 part

    and lastly Command:

    grep -i firmware /var/log/messages
    //when the path was /var/log/syslog, is said that there was no such file or directory.

    Results:

    Dec 28 12:54:37 fogclient user.notice kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
    Dec 28 12:54:37 fogclient user.info kernel: psmouse serio2: trackpoint: Elan TrackPoint firmuare: 0x12, buttons: 3/3

    Not sure what to take from that but that is what happened with those commands


  • @george1421

    I will try both of those and report back.

    Currently we have 1.5.9 installed for FOG. At least that it* what is says. Screenshot provided:
    fd454004-e334-4769-9a98-1fecd1c38e84-image.png

    I also suspected that the firmware was not up to date, so I checked and the firmware version was from 10-08-2021. I updated the firmware to the latest version and the issue still persisted. I imaged a Lenovo ThinkCentre and yesterday we could image a P14 just fine so it seems to be just the T14 Gen 2.

    Currently a Intel core i5 is installed. Standby for debug info. Thanks!

  • Moderator

    @itsecwalrus Well to debug this a bit more we will need a sample computer where we can overwrite the hard drive with stuff. But first as silly as it sounds, lets plug a usb memory device/flash drive into the computer then try to image again. Let see if that changes the speed issue. If it doesn’t don’t let it run to completion there is no need.

    If not then what we will do is boot into debug mode, where we need to run a few commands. For debug mode configure another deploy task, but before you hit the schedule task button, tick the debug checkbox, then schedule the task. Now pxe boot the computer. After a few screens of text that you need to clear with the enter key, you will be dropped to the fos linux command prompt.

    Key i the following commands and post the results.
    lspci -nn | grep -i net That will list out the hardware IDs of the network adapters built into the computer.
    ip a s gives us info on the network adapters
    lsblk gives us info on the drives

    This next one I can’t remember if its syslog or messages file. I should know this but after too much holiday cheers I can seem to remember.
    grep -i firmware /var/log/syslog see if that returns an error messages related to missing firmware. If its not syslog then its messages where the system log file is. Lets see what that info gives us. Stay in debug mode so we can do additional testing.

    One thing I didn’t see is what version of FOG are you using. You downloaded the latest kernel but what’s version of FOG?

    Also since this IS an lenovo, please make sure the firmware is up to date. We’ve seen some pretty flaky firmware in the past. Also just for completeness, what cpu is installed intel or amd?


  • @george1421 Sorry I haven’t responded. I left work literally minutes before you commented.

    I checked the BIOS and UEFI setup pages and could not find a setting referring to VMD. I tried looking on the internet to see if I maybe missing something and couldn’t find anything on that setting for thinkpads.

    Please advise on next steps when you can. Thanks!

  • Moderator

    @itsecwalrus We are seeing on the HP Gen8 models that they are imaging super slow too. In the HP bios there is a setting that says configure storage controlller for VMD. On the HPs if you turn that feature off, imaging returns to normal. I’m not saying that is the same on lenovo, but its something to look in the firmware for. In the HP case its not the network that is running slow, but the writing to the storage controller. The devs don’t have either lenovo or hp on thier campuses, and I only have Dell so we may need to dig into what is causing this issue if the problem expands beyond HP.

    If your system doesn’t have something that references VMD then we can debug this deeper if you want.


  • Ref: Kernel is missing the correct driver

    So I did the steps in this to manually download the Kernel updates and that fixed the Kernel version in the bzimage file.

    That said, now when I go to deploy the image to the T14 Gen 2, it goes incredibly slow. Use to, the rate would be about 10 gb/min (give or take), now it is going at 11-20 mb/min and says that it will take about 56 hours to finish.

    I checked the server’s nic to make sure it is set to 10gbs/second at full duplex. Ensured that the port it is connected to is allowing the same speeds. Is there anything that I am missing?

    I don’t have a different machine to try and see if it works. Let me know if you have any questions. Thanks!


  • I have also tried using a different managed switch between the machine and the box.

    I have made sure that the patch cable is good and functional, even trying several different ones to make sure that it is not the patch cable.

    I should notate the the CPU is an Intel Core i5
    the architecture is x65

    If any more information is needed please let me know. Thank you!

327
Online

9.1k
Users

15.7k
Topics

145.8k
Posts