Issues with USB Type C NIC Adaptors


  • Hello,

    I have 515 HP Probook 430 HP Laptops and they are not passing through the system MAC to FOG. I have the genuine HP dongles (part # 855474-001) and it passes the MAC through windows in a command prompt running an ipconfig /all but in FOG it pulls the MAC of the dongle. When I register the host, reboot it to image, it comes up saying that the host isn’t registered. Does anyone have experience with these units and the HP Dongles?

    My Dell 7420s pass the MAC addresses through the docks fine and work fantastic, it’s just these HP Units.

    Thank you,

    Michael


  • @michaeloberg said in Issues with USB Type C NIC Adaptors:

    @kghli @george1421 @Sebastian-Roth

    This could be a breakthrough. I just noticed that the system is passing the address through iPXE correctly and that FOG is what is recognizing the USB Type-C dongle’s MAC address - the exact scenario that @kghli is experiencing. I took a screen shot of the issue and here is the iPXE address (which is the correct system address):

    3e42e174-18f4-40d4-80a0-22714580ef00-image.png

    Then when I boot to FOG (now running Debian 10.11 and FOG 1.5.9, and choose “Client System Information” then choose “Display MAC Address” it show’s the USB Dongle’s MAC:

    e70169a5-6a1d-4983-be3c-9d9a7dea4c9e-image.png

    Hopefully this is going to help troubleshoot our issues as we have narrowed it down to FOG alone, not the manufacture of the system, the BIOS configuration or the version of FOG.

    Thanks in advanced!

    Mike

    I also recompiled iPXE from (g4bd0) to (g1844a) and verified the date (ls -la /tftpboot/*.efi) was today and it still is not working.


  • @kghli @george1421 @Sebastian-Roth

    This could be a breakthrough. I just noticed that the system is passing the address through iPXE correctly and that FOG is what is recognizing the USB Type-C dongle’s MAC address - the exact scenario that @kghli is experiencing. I took a screen shot of the issue and here is the iPXE address (which is the correct system address):

    3e42e174-18f4-40d4-80a0-22714580ef00-image.png

    Then when I boot to FOG (now running Debian 10.11 and FOG 1.5.9, and choose “Client System Information” then choose “Display MAC Address” it show’s the USB Dongle’s MAC:

    e70169a5-6a1d-4983-be3c-9d9a7dea4c9e-image.png

    Hopefully this is going to help troubleshoot our issues as we have narrowed it down to FOG alone, not the manufacture of the system, the BIOS configuration or the version of FOG.

    Thanks in advanced!

    Mike


  • Hello everyone.

    I have the opposite problem.

    If I enable the BIOS option “MAC Address Pass Through” iPXE sees that, FOG does not, it sees the USB-C dongle MAC address.

    I even tried to recompile iPXE, still the same (I guess it’s not the fault of iPXE?).
    The FOG server is version 1.5.9

    Anything else I can try?

    Machines I tested this on: Lenovo L14 and Dynabook X30W

  • Moderator

    @michaeloberg OK first of all well done updating your fog server to a supported OS build. You probably should take the installation up to the current dev branch to address a disk resizing issue with Windows 20h1 and later. BUT for right now yo have the current build to do what was originally suggested. The version of iPXE that comes with FOG 1.5.9 may need to be updated to support this mac passthrough function.

    I don’t know if I posted this link before, but just recently I created a tutorial on how to (re)compile the latest version of iPXE with your FOG server. I think this is where you got stuck before: https://forums.fogproject.org/topic/15826/updating-compiling-the-latest-version-of-ipxe

    Before you go through this process, pxe boot a computer and on the iPXE banner screen quickly note the hex values in the square brackets right after the version number. That is the build number. Now rebuild and install the latest version of iPXE. The pxe boot the computer once again and pay attention that the build number changes.

    I do have to give you the caveat here that even the latest version of iPXE might not address the issue with this network adapter. I know it seems like you went through a lot of pain to get to this point and maybe it still doesn’t work. Your efforts have not gone to waste even if this IS the conclusion of this issue. You understand the FOG system a bit more and are now running on a supported OS for many years to come.


  • @george1421 @Sebastian-Roth

    OK - Update with the USB Type C NIC Adaptors:

    Last night I built a new Fog Server running Debian 10.11 and FOG 1.5.9

    That said I should be up to date with the OS and Fog software.

    The problems continue with the HP Probook 430 Laptops, the MAC Address of the host registered in fog is the dongle and not the system address.

    I made sure the MAC-Address Passthrough option is set to “system” in the BIOS. And in windows it works properly - it is only in the preboot environment that the MAC address doesn’t work correctly.

    I also have 134 Dell 7420 laptops and they work fine, so I tried the USB Type C dock that I imaged all of the devices with and same thing, the host registers the Dock and not the system address.

    Any ideas on this? HP support only provides the MAC-Passthrough to the native OS and not the preboot environment, it is beyond their scope of support.

    Thank you,

    Michael

  • Moderator

    @michaeloberg said in Issues with USB Type C NIC Adaptors:

    @george1421 @Sebastian-Roth

    Gentleman, with my OS - Ubuntu 16.04 having an End Of Life in April 2021, it may be best to build a new VM. My question to you is what is the best version to use when starting fresh? Debian 8? I want to start with the best foundation and also give me the best possible futureproofing of the OS as possible.

    Future proofing, not possible. I would stick with Debian 10, or Ubuntu 20.04. CentOS at the moment is not really an option.
    I would also recommend that you when creating a new VM create a VMDK about 35GB to install the OS on. Once you get the OS installed then add a new VMDK (disk) to the FOG server. This disk should be sized according to the size of files you have in the /images directory on your current FOG server. When you add this drive, just create a standard partition and then make a /images directory on your new fog server and mount that second vmdk (probably /dev/sdb1) over that /images directory. This is an extra step that is not documented in the official install instructions. So when you get done here you will have the OS installed on a 35GB disk, and a place to store your image files on what ever size disk. This configuration will allow you to extend that second vmdk file without foobaring your OS install. Also with this configuration if you fill up your images disk it will not take down your FOG server since the OS disk will have plenty of room.

    My second question is - After I build the new server, how do I export my old Hosts, Images and other information from the old FOG server onto the new one?

    There is a wiki page for that: https://wiki.fogproject.org/wiki/index.php?title=Migrate_FOG The short version is to back up your database and restore it on the new fog server, then copy all of the files from the /images on your old fog server and put them on the new fog server in the /images directory.

    When I build the new server, should I give it a new IP Address and change it after I power the old VM off or just point my 066 Boot Server Host Name to the new IP of the New Server?

    The quick answer here is Yes. You have it right.


  • @george1421 @Sebastian-Roth

    Gentleman, with my OS - Ubuntu 16.04 having an End Of Life in April 2021, it may be best to build a new VM. My question to you is what is the best version to use when starting fresh? Debian 8? I want to start with the best foundation and also give me the best possible futureproofing of the OS as possible.

    My second question is - After I build the new server, how do I export my old Hosts, Images and other information from the old FOG server onto the new one? When I build the new server, should I give it a new IP Address and change it after I power the old VM off or just point my 066 Boot Server Host Name to the new IP of the New Server?

    Looking for best practices and to prevent leasons learned the hard way.

    TIA,

    Michael


  • @george1421 So not knowing much about Linux, can you update the current version of the OS, or is it a new server installation? This is a very large VM, 500 GB repository for image files. I am not against building a new one, but must admit it would be like walking a passenger through landing an airplane 😐

    TIA,

    Michael

  • Moderator

    @michaeloberg said in Issues with USB Type C NIC Adaptors:

    the version of the OS on my FOG server is Ubuntu 16.04.6 LTS

    I don’t want to be quick to judge but ubuntu 16.04 was marked end of life Apr 2021. The error in your previous post is staying the certificate for the http request failed verification. I don’t know if that means your ubuntu version is to old to with with current certificates, or the protocol used by the web site is not understood by ubuntu 16.04. (i.e. TLS 1.0 vs 1.2 [guess])


  • @sebastian-roth @george1421 I am sending the same reply to both, the version of the OS on my FOG server is Ubuntu 16.04.6 LTS

    Sebastian - You mentioned “Something seems to be wrong with your git stuff on this FOG server” and I truly don’t know what that means. Is there something I can try to fix this, something to test this theory?

    George - You asked about the version, which I provided above, regarding the debian variant, I am not sure what that means and building a command - don’t know how to do that either.

    I apologize, I simply don’t know Linux well enough to intelligently respond to your questions. If you give me an exact command I can do that much to report the information back, that is about the extent of my abilities.

    Thank you in advance!

    Michael

  • Moderator

    @michaeloberg said in Issues with USB Type C NIC Adaptors:

    fatal: unable to access ‘https://git.ipxe.org/ipxe.git/’: server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt

    Something seems to be wrong with your git stuff on this FOG server.

  • Moderator

    @michaeloberg what OS are you running on the FOG server?

    If its a debian variant you may need to use sudo and the build command. I ran through the recompile process this morning on centos as the root user and it works fine.


  • @george1421 When I tried doing that, here is the error message that I get:

    root@fog-server:~# ls
    fogproject
    root@fog-server:~# cd fogproject
    root@fog-server:~/fogproject# ls
    authors.txt lib packages rpttmp src utils
    bin LICENSE README.md SELinux tmp
    root@fog-server:~/fogproject# cd utils
    root@fog-server:~/fogproject/utils# ls
    FOGBackup FOGiPXE FOGUpdater
    root@fog-server:~/fogproject/utils# cd FOGiPXE
    root@fog-server:~/fogproject/utils/FOGiPXE# ls
    buildipxe.sh ipxescript ipxescript10sec
    root@fog-server:~/fogproject/utils/FOGiPXE# ./buildipxe.sh
    Cloning into ‘/root/ipxe’…
    fatal: unable to access ‘https://git.ipxe.org/ipxe.git/’: server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
    ./buildipxe.sh: line 22: cd: /root/ipxe/src/: No such file or directory
    Copy (overwrite) iPXE headers and scripts…
    cp: cannot create regular file ‘config/’: Not a directory
    cp: cannot create regular file ‘config/’: Not a directory
    cp: cannot create regular file ‘config/’: Not a directory
    make: *** No rule to make target ‘bin/ipxe.iso’. Stop.
    cp: cannot stat ‘bin/ipxe.iso’: No such file or directory
    cp: cannot stat ‘bin/undionly.pxe’: No such file or directory
    cp: cannot stat ‘bin/undionly.kpxe’: No such file or directory
    cp: cannot stat ‘bin/undionly.kkpxe’: No such file or directory
    cp: cannot stat ‘bin/ipxe.pxe’: No such file or directory
    cp: cannot stat ‘bin/ipxe.kpxe’: No such file or directory
    cp: cannot stat ‘bin/ipxe.kkpxe’: No such file or directory
    cp: cannot stat ‘bin/intel.pxe’: No such file or directory
    cp: cannot stat ‘bin/intel.kpxe’: No such file or directory
    cp: cannot stat ‘bin/intel.kkpxe’: No such file or directory
    cp: cannot stat ‘bin/realtek.pxe’: No such file or directory
    cp: cannot stat ‘bin/realtek.kpxe’: No such file or directory
    cp: cannot stat ‘bin/realtek.kkpxe’: No such file or directory
    cp: cannot stat ‘bin/ipxe.lkrn’: No such file or directory
    cp: cannot stat ‘bin/ipxe.usb’: No such file or directory
    cp: cannot stat ‘bin/ipxe.lkrn’: No such file or directory
    make: *** No rule to make target ‘bin/ipxe.iso’. Stop.
    cp: cannot stat ‘bin/ipxe.iso’: No such file or directory
    cp: cannot stat ‘bin/undionly.pxe’: No such file or directory
    cp: cannot stat ‘bin/undionly.kpxe’: No such file or directory
    cp: cannot stat ‘bin/undionly.kkpxe’: No such file or directory
    cp: cannot stat ‘bin/ipxe.pxe’: No such file or directory
    cp: cannot stat ‘bin/ipxe.kpxe’: No such file or directory
    cp: cannot stat ‘bin/ipxe.kkpxe’: No such file or directory
    cp: cannot stat ‘bin/intel.pxe’: No such file or directory
    cp: cannot stat ‘bin/intel.kpxe’: No such file or directory
    cp: cannot stat ‘bin/intel.kkpxe’: No such file or directory
    cp: cannot stat ‘bin/realtek.pxe’: No such file or directory
    cp: cannot stat ‘bin/realtek.kpxe’: No such file or directory
    cp: cannot stat ‘bin/realtek.kkpxe’: No such file or directory
    cp: cannot stat ‘bin/ipxe.lkrn’: No such file or directory
    cp: cannot stat ‘bin/ipxe.usb’: No such file or directory
    cp: cannot stat ‘bin/ipxe.lkrn’: No such file or directory
    Cloning into ‘/root/ipxe-efi’…
    fatal: unable to access ‘https://git.ipxe.org/ipxe.git/’: server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
    ./buildipxe.sh: line 59: cd: /root/ipxe-efi/src/: No such file or directory
    Copy (overwrite) iPXE headers and scripts…
    cp: cannot create regular file ‘config/’: Not a directory
    cp: cannot create regular file ‘config/’: Not a directory
    cp: cannot create regular file ‘config/’: Not a directory
    make: *** No rule to make target ‘bin-i386-efi/snp.efi’. Stop.
    cp: cannot stat ‘bin-i386-efi/snp.efi’: No such file or directory
    cp: cannot stat ‘bin-i386-efi/snponly.efi’: No such file or directory
    cp: cannot stat ‘bin-i386-efi/ipxe.efi’: No such file or directory
    cp: cannot stat ‘bin-i386-efi/intel.efi’: No such file or directory
    cp: cannot stat ‘bin-i386-efi/realtek.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/snp.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/snponly.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/ipxe.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/intel.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/realtek.efi’: No such file or directory
    make: *** No rule to make target ‘bin-i386-efi/snp.efi’. Stop.
    cp: cannot stat ‘bin-i386-efi/snp.efi’: No such file or directory
    cp: cannot stat ‘bin-i386-efi/snponly.efi’: No such file or directory
    cp: cannot stat ‘bin-i386-efi/ipxe.efi’: No such file or directory
    cp: cannot stat ‘bin-i386-efi/intel.efi’: No such file or directory
    cp: cannot stat ‘bin-i386-efi/realtek.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/snp.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/snponly.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/ipxe.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/intel.efi’: No such file or directory
    cp: cannot stat ‘bin-x86_64-efi/realtek.efi’: No such file or directory
    root@fog-server:~/fogproject/utils/FOGiPXE#

  • Moderator

    @michaeloberg Lets try it once you update iPXE with the latest build (that you will make). Please follow this tutorial to recompile ipxe. https://forums.fogproject.org/topic/15826/updating-compiling-the-latest-version-of-ipxe


  • @sebastian-roth Missed that - my bad…

  • Moderator

    @michaeloberg Not sure if you noticed yet but that part about GUI and Apache logs is just my forum signature…


  • @sebastian-roth I I missed the reference to the GUI interface, I can tell you this works on our new Dell 7420s, I don’t know if that helps but can tell you I am not sure how to do what you asked? - Check apache error???


  • @sebastian-roth Yes and I have that option enabled in the BIOS. The passthrough option is working in Windows as an Ipconfig /all show the system MAC and not the dongle MAC. The issue is only happening in the pre-boot environment.

  • Moderator

    @michaeloberg Did you check UEFI/BIOS settings to see if there is an option on MAC passthrough?

343
Online

9.0k
Users

15.6k
Topics

145.1k
Posts