Apache problems



  • I am currently trying to install fog to run on through a separate DHCP server and i get to this point and can not find anyone on the internet that has had this same problem, please help

    " Configuring services.

    • Setting up fog user…Exists
    • Setting up and starting MySql…OK
    • Backing up user reports…OK
    • Setting up and starting Apache Web ServerCan’t open /var/lib/sysv-rc-conf/services for rw access : Permission denied at /usr/sbin/sysv-rc-conf line 479.
      …Failed! "

  • group:cid:13:privileges:mods:members

    Glad to hear you got it working.



  • Restarting the service worked perfect! Thanks for all the help


  • group:cid:13:privileges:mods:members

    Glad to see you got the imaging working. Did restarting the service solve this issue, or did you need to change something else?



  • WOAH!!! LOOK!!!2013-02-15 16.27.16.jpg


  • group:cid:13:privileges:mods:members

    That all looks to be right. Try restarting the TFTP service on FOG [B]sudo service tftpd-hpa restart [/B]



  • I thought I set it up correctly :/

    Here are some pictures2013-02-15 16.09.30.jpg2013-02-15 16.03.37.jpg


  • group:cid:13:privileges:mods:members

    It looks like you pointed FOG to use another DHCP server other than itself, at least from the config above. Is that correct? If you did, you need to specify options 66 and 67 in the DHCP scope of a Windows server. If you use a Linux server, you need to specify the next-server. If you receive a PXE-E32, it’s usually due to your machine not being able to contact the TFTP server due to it not being specified correctly on the DHCP server.



  • Well we ran into a problem!

    It worked when I was in my office, then we moved to the LMC and attempted to grab an image from a computer and this is what we get:

    2013-02-15 15.37.11.jpg


  • group:cid:13:privileges:mods:members

    Glad to hear you got it working.



  • THANKS for all of the help, you people are life savers!!!



  • We are up and running, it seems i’m a little lack on reading directions… I ran it in “root” like it says to and it ran perfectly


  • group:cid:13:privileges:mods:members

    it still looks like it’s not liking the user account that you are running, that you don’t have elevated privileges. Also, are you installing/upgrading software when trying to install FOG?

    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)

    That makes me think that something in Ubuntu is trying to update files as well at the same time, and Ubuntu definitely does not like that. But that could also point to a permission issue.

    Do you receive the exact same errors from above when you run the command [B]sudo ./installfog.sh[/B]? Or do you still receive the same errors? i.e.

    (
    This installation script should be run as
    user “root”. You are currenly running
    as fogclone.

    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

    • Checking package: apache2…Failed!
      )

    If any of those are different if the command is running as sudo, it may give me a better idea of what’s breaking. If you are running it as sudo, then we may have to change the root password, just to try and see if something got messed up with that account.



  • Well I did what you said and here was the result:

    fogclone@fogclone-OptiPlex-GX520:~$ md5deep /home/fogclone/Desktop/fog_0.32.tar.gz
    45b323d4150690b9c1aa8288c33830c9 /home/fogclone/Desktop/fog_0.32.tar.gz

    Then I tried installing FOG and this is what it shows:
    Version: 0.32 Installer/Updater

    This installation script should be run as
    user “root”. You are currenly running
    as fogclone.

    Do you wish to continue? http://www.fogproject.org/wiki/index.php?title=InstallationModes

    What type of installation would you like to do? [N] n

    What is the IP address to be used by this FOG Server? [10.0.179.207]10.0.175.162

    Would you like to setup a router address for the DHCP server? [Y/n] y
    What is the IP address to be used for the router on the DHCP server? [10.0.0.2]10.0.175.1

    Would you like to setup a DNS address for the DHCP server and client boot image? [Y/n] n

    Would you like to change the default network interface from eth0?
    If you are not sure, select No. [y/N]n

    Would you like to use the FOG server for dhcp service? [Y/n] n

    DHCP will not be setup but you must setup your
    current DHCP server to use FOG for pxe services.

    On a Linux DHCP server you must set:
    next-server

    On a Windows DHCP server you must set:
    option 066 & 067

    This version of FOG has internationalization support, would
    you like to install the additional language packs? [Y/n] n

    #####################################################################

    FOG now has everything it needs to setup your server, but please
    understand that this script will overwrite any setting you may
    have setup for services like DHCP, apache, pxe, tftp, and NFS.

    It is not recommended that you install this on a production system
    as this script modifies many of your system settings.

    This script should be run by the root user on Fedora, or with sudo on Ubuntu.

    Here are the settings FOG will use:
    Distro: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 10.0.175.162
    DHCP router Address: 10.0.175.1
    DHCP DNS Address:
    Interface: eth0
    Using FOG DHCP: 0
    Internationalization: 0

    Are you sure you wish to continue (Y/N) y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Preparing apt-get

    • Installing package: apache2

    • Installing package: php5

    • Installing package: php5-gd

    • Installing package: php5-cli

    • Installing package: php5-mysql

    • Installing package: php5-curl

    • Installing package: mysql-server

      We are about to install MySQL Server on
      this server, if MySQL isn’t installed already
      you will be prompted for a root password. If
      you don’t leave it blank you will need to change
      it in the config.php file located at:

      /var/www/fog/commons/config.php

      Press enter to acknowledge this message.

    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

    • Installing package: mysql-client
    • Installing package: tftpd-hpa
    • Installing package: tftp-hpa
    • Installing package: nfs-kernel-server
    • Installing package: vsftpd
    • Installing package: net-tools
    • Installing package: wget
    • Installing package: xinetd
    • Installing package: sysv-rc-conf
    • Installing package: tar
    • Installing package: gzip
    • Installing package: build-essential
    • Installing package: cpp
    • Installing package: gcc
    • Installing package: g++
    • Installing package: m4
    • Installing package: htmldoc
    • Installing package: perl
    • Installing package: libcrypt-passwdmd5-perl
    • Installing package: lftp
    • Installing package: openssh-server
    • Installing package: php-gettext
    • Installing package: clamav-freshclam

    Confirming package installation.

    • Checking package: apache2…Failed!
      fogclone@fogclone-OptiPlex-GX520:~/Desktop/fog_0.32/bin$

  • group:cid:13:privileges:mods:members

    Can you run an MD5 check on the fog_0.32.tar.gz file? This will tell you instantly if you have a bad copy of FOG.

    The MD5 should be: 45b323d4150690b9c1aa8288c33830c9

    to do this type: [B]sudo apt-get install md5deep[/B]

    Then just enter: [B]md5deep /path to your fog_0.32.tar.gz file [/B]If even off by 1 byte, that number will be completely different.



  • Here is what we did:

    Reformatted our computer with Ubuntu 11.04 and downloaded FOG 0.32
    Then
    Attemped to install FOG, and ran into several “fails”. Such as apache errors, php2 errors and several others.

    Then:
    Formatted the computer with 12.04 and downloaded FOG 0.32
    Then
    Attempted to install FOG, and still ran into several “fails”. All of which were the same errors as before.

    Could it be possible that the version of FOG that we have been downloading is bad or missing files? We did have it working at one time, but we ran into some errors with DHCP. We now have a computer just for DHCP, meaning that the only thing on it is Windows Server 2008 and a separate computer just for FOG.

    Any help at this point would be greatly appreciated.

    Thank You

    Adam & Kyle



  • it Bash’s with the sudo,



  • I installed FOG 0.32 on Ubuntu Server 10.04 LTS and it worked at the first try without any problems. You may try that one.


  • group:cid:13:privileges:mods:members

    you shouldn’t have to install anything when you’re installing FOG. It should install everything it needs. Just to verify, are you running the installfog.sh with the sudo command?



  • I completely wiped out my computer, installed ubuntu 12.04, installed updates, ran the fog install, and I get to the point where I have to manually install every package by running sudo apt-get php5 and so on down the list for every package, I have never experienced this before and don’t know what the problem could be at this point


Log in to reply
 

349
Online

38746
Users

10569
Topics

100052
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.