Acer Veriton N2620G PC flashing like it's on an acid trip!



  • I’m testing out an Acer Veriton N2625G PC with Linpus Linux on it (stock) as a test for Linux alternatives. Normally we use N281G PC’s with Windows 7 Pro, and these work like a champ with FOG. I have another Linux image on my FOG Server I was planning to throw on this machine. I was also planning to upload this image as a “just-in-case” measure.

    I choose to boot from LAN like normal, and choose to register the PC. I see the typical readouts “loading yadda yadda this, loading yadda yadda that”, but then things get interesting. The monitor starts flashing all the colors of the spectrum! Reds, blues, greens, whites, purples! It’s like the machine is on an acid trip!

    My version of FOG is 0.32

    I think my kernel is 3.3.3.



  • OK, mess up on my part. I reread Art’s post. It appears to be working now.

    Thank You.



  • When I do:
    [CODE]lsmod[/CODE]
    under the video result is:
    [CODE]video 9463 1 i915[/CODE]
    I’m guessing that in the kernel config this would be included in the intel 8xx/9xx line.
    One interesting notion, when I tried to compile the kernel the first time (using the kitchensink.config), the resulting bzimage was about 6MB less than the “official” 3.6.9 Core.

    [url="/_imported_xf_attachments/0/259_Kernel_Help.PNG?:"]Kernel_Help.PNG[/url]



  • So far, trying what Art Mendoza suggested hasn’t helped. But maybe I didn’t do it right… Back to the drawing board.


  • Moderator

    the package is called g++ and gcc are both meta packages in Ubuntu that download all the parts…



  • What are the G++ tools I need?


  • Moderator

    something else.



  • This is the kernel “bzimage” from the update kernel page, yes? Or is that something else?


  • Moderator

    [url]http://fogproject.org/wiki/index.php/Building_a_Custom_Kernel[/url]

    Article assumes you have make, wget, and g++ tools already installed.

    This is step by step pretty much. You can look at [url=“http://www.kernel.org”]www.kernel.org[/url] to find the latest stable kernel, and get the path you need for the wget command.

    I copied the core.config file from the /opt/fog-setup/fog_0.32/fog/kernel directory instead of the kitchensink.config because I know from experience it works better for my environment. But you can try the kitchensink.config first if you want.



  • Can I grab the kernel from the fog machine itself? Where do I get it from?


  • Moderator

    Yes. You need to compile a custom kernel.

    Follow the wiki article and grab the latest stable kernel source, which I think is 3.7.8, or if you are already know the 3.3.3 kernel works with most of your devices, grab the 3.3.3 kernel source.

    It’s pretty easy from that point on to compile the kernel, just substitute 3.3.3 for the kernel version anywhere the article says a different one.

    You may have to install a few pre-reqs before you can compile: gcc, make, git, libqt3-dev, etc that are listed on the wiki or help site about compiling kernels for your distribution.



  • To be honest, I don’t quite understand it. Do I mod the FOG kernel to do that?


  • Moderator

    Did you try the suggestion in Art Mendoza’s post?



  • [FONT=Times New Roman][COLOR=#000000]So. Here’s what Acer said the working system has. This leads me to think, perhaps it is a graphics driver problem. [/COLOR][/FONT]

    [FONT=Times New Roman][COLOR=#000000]VN262G System Information
    System Chipset: Intel NM10
    Video Chipset: Intel Atom D400/D500 series on die graphic solution
    LAN: Realtek RTL8111E
    Audio: Realtek ALC662-VD [/COLOR][/FONT]

    [FONT=Times New Roman][COLOR=#000000]Unfortuntately, it does not appear that Intel has released a linux driver for either chipset or graphics card.[/COLOR][/FONT]



  • Finally got what appears to be a definative answer from Acer regarding drivers:

    [FONT=Arial][COLOR=#000000]VN2620G System Information[/COLOR][/FONT][COLOR=#000000][FONT=Times New Roman] [/FONT][FONT=Arial]System Chipset: Intel HM70[/FONT][/COLOR][COLOR=#000000][FONT=Times New Roman] [/FONT][FONT=Arial]Video Chipset: Intel HD 4000[/FONT][/COLOR][FONT=Times New Roman][COLOR=#000000] [/COLOR][/FONT][FONT=Arial][URL=‘http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Laptop+graphics+drivers&ProductProduct=3rd+Generation+Intel®+Core™+Processors+with+Intel®+HD+Graphics+4000%2F2500&ProdId=3498&LineId=1101&FamilyId=39’][U][COLOR=#0000ff]http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Laptop+graphics+drivers&ProductProduct=3rd+Generation+Intel®+Core™+Processors+with+Intel®+HD+Graphics+4000%2F2500&ProdId=3498&LineId=1101&FamilyId=39[/COLOR][/U][/URL][/FONT][COLOR=#000000][FONT=Times New Roman] [/FONT][FONT=Arial]LAN: Intel 82579V[/FONT][/COLOR][COLOR=#000000][FONT=Times New Roman] [/FONT][FONT=Arial]Audio: Realtek ALC662-VD[/FONT][/COLOR]



  • Hi, I got the same problem with Acer Veriton N2620G, though what I tried to install is Ubuntu 12.10, like Hunter had mentioned above, the same symptom was encountered. Some modification were made that made the installation successful with Ubuntu but without the optimal performance. The unit is okay with Debian, no problem at all.

    Acer Philippines relayed to us Acer HQ’s (Taiwan) advice:

    [SIZE=2][FONT=sans-serif]"The below details are the best recommendation from our HQ side. Btw, have they tried to compile their linux base on kernel 3.6.6-lp.1? Because as per discussion with our HQ team, this is the initial solution.[/FONT][/SIZE]

    [SIZE=3][FONT=Calibri]Please rebuild kernel to disable below feature:[/FONT][/SIZE]
    [SIZE=3][FONT=Calibri]-Device Drivers–>[/FONT][/SIZE][SIZE=3][FONT=Calibri]
    -Graphics support–>[/FONT][/SIZE][SIZE=3][FONT=Calibri]
    -Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)–> Enable modesetting on intel by default[/FONT][/SIZE][SIZE=3][FONT=Calibri][/FONT][/SIZE][SIZE=3][FONT=Calibri]Or add kernel parameter “i915.modeset=0” in the booting.[/FONT][/SIZE][SIZE=3] "[/SIZE]

    As of this moment, only Debian Linux is tested to run with this Veriton model.

    [SIZE=3][/SIZE]


  • Moderator

    If you’ve got one already running some flavor of linux, we can use that to figure out what driver we need to compile into the FOG kernel.

    try:
    [CODE]lspci -k[/CODE]
    or
    [CODE]lsmod[/CODE]

    and look for your graphics card info.



  • Still trying to figure this out. With no help from Acer. If both working and non-working models use the same graphics controller (still don’t know for sure due to Acer’s lousy documentation.) could the weird display problem be due to the general chipset on the motherboard?



  • So I’ve done some hunting. The integrated driver for the Acer Veriton 2620G is, according to my research, an Intel GMA 3150. Of course Acer doesn’t state this on their data sheet of the product. I had to go hunt down, comparing the Windows 7 driver file to a snippet I found on the internet. And of course, Acer doesn’t acknowledge that this particular specimen, came with Linux Linpus (not a good flavor of Linux, IMHO), only showing me the Windows 7/8 drivers.

    Yet, hold on. The Veriton N281G, which DOES work on my FOG setup also, according to the Acer Datasheet – which is filled out more completely – also uses the Intel GMA 3150. The only differences as far as that goes, is one machine, the N2620G uses an HM70 Express model chipset, while the N281G uses an NM10 model chipset.

    Veriton N2620G datasheet: [url]http://us.acer.com/ac/en/US/content/model-datasheet/DT.VFGAA.001[/url]
    Veriton N281G datasheet: [url]http://support.acer.com/acerpanam/desktop/2011/acer/veriton/VeritonN281G/VeritonN281Gsp2.shtml[/url]


  • Moderator

    I just tested the 3.7.7 kernel I compiled using Ubuntu Desktop 11.10. The only changes I made to the kitchensink.config was to add the config and /proc/config.gz options. It works for most of my machines except my problem child acer tablets that use a ASIX88772B usb network adapter and SSD drive. It finds neither the drive nor the network adapter. I’m going to recompile tonight adding in more drivers I need.

    The 3.7.7 kernel boots significantly faster than my old kernel that was based on 2.6.38 I believe, but doesn’t support all my workstation and laptop configurations yet.

    The whole point of this is to let you know that following the basic steps in the wiki with the few modifications in the posts above, I was able to compile a “mostly” working kernel.


Log in to reply
 

473
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.