[SOLVED] Problem tftp, Fedora 18



  • hello

    i have a problem on Fedora 18 : in task management
    [B]unable to start task : unable to connect to tftp server :[/B]

    i try to do this : [url]http://fogproject.org/wiki/index.php?title=Unable_to_connect_to_TFTP[/url]
    same problem

    i do an installation on kubuntu 12.10 and don’t have this problem …

    help me please , sorry for my english…



  • I’m an idiot, I found
    I have not stopped the service Selinux
    sorry and thank you for your help



  • OK, so you’ve changed the default password, and i’m assuming you updated the new password in the TFTP spot and storage spot. Can you verify that your new password is also in the web interface under Storage Management > All Storage nodes > Management Password AND Other Information > FOG settings > FOG_TFTP_FTP_PASSWORD. Also on this portion of the web server, Other Informatiom > FOG Settings > TFTP Server, have you verified that all your IP’s are setup correctly for your setup?



  • [URL=‘http://fogproject.org/wiki/index.php?title=Unable_to_connect_to_TFTP’]yes i do this :[/URL]
    [url]http://fogproject.org/wiki/index.php?title=Unable_to_connect_to_TFTP[/url]

    and i change the password “defauftl” manager

    sudo password fog



  • OK, did you happen to change the default password of the default fog user?



  • i find the service xinetd and i restart this service
    always the problem …



  • Did you start xinetd? From what I found, the tftp service is controlled by xinetd. Check /etc/xinetd.d/tftp and verify that the “disable =yes” is set to no. Once this is done, type [I]service xinetd start[/I]. If this is already set to no, you can try [I]service xinetd restart[/I] and see if you can boot to FOG from a client.

    But again, this could be old information, and I don’t work much with Fedora. But it’s something to check unless one of the Fedora guru’s knows about this problem.



    1. not a the same time
    2. i think Fog is installed correctly (where check errors ?)
      3 in fedora 18 i don’t hnow the service is not clear
      4 in vbox in internal network

    thank for help



  • Cruzy,

    I had this problem with my VM’s a couple times. There are a few things you can check.

    1. You say that you have had this work on Kubutnu 12.10, that’s not running at the same time that your Fedora server is running is it?

    2. Are you sure that FOG installed correctly when you installed it? Did you verify that there were no errors?

    3. Have you just tried restarting the TFTP service? Ubuntu originally had a problem where you needed to restart the TFTP service at startup because it would start the service before it registered with FOG. After the service was restarted, it worked fine. This, however, has now been fixed.

    4. Is your FOG server on Fedora on a private network, or on an existing network with another DHCP server?

    Any additional information you can provide would be appreciated. I normally only work with Ubuntu with my server installs, so commands and locations of specific files might be slightly different for your setup compared to mine.


 

383
Online

41.7k
Users

12.2k
Topics

115.1k
Posts