"Enabling apache and fpm services on boot" failed


  • Hello,
    To help you to understand I am trying to install docker in a docker container.
    I encounter many issues, had to read the script to understand how it worked so i can install missing package but there is something here I do not understand.

    Here are the error :

    * Enabling apache and fpm services on boot....................Failed!
    
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !! The installer was not able to run all the way to the end as   !!
    !! something has caused it to fail. The following few lines are  !!
    !! from the error log file which might help us figure out what's !!
    !! wrong. Please add this information when reporting an error.   !!
    !! As well you might want to take a look at the full error log   !!
    !! in /root/fogproject/bin/error_logs/fog_error_1.5.9.log !!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    
    'FOGService.msi' -> '/var/www/html/fog//client/FOGService.msi'
    'SmartInstaller.exe' -> '/var/www/html/fog//client/SmartInstaller.exe'
    mysqlnd
    ../lib/common/functions.sh: line 2335: sysv-rc-conf: command not found
    ../lib/common/functions.sh: line 2336: sysv-rc-conf: command not found
    

    I did installed package sysv-rc-conf but when I tried “sysv-rc-conf apache2” it says :

    root@dockerfog:~/fogproject/lib/common# sysv-rc-conf apache2
    bash: sysv-rc-conf: command not found
    

    Line in script are :

        if [[ $osid -eq 2 ]]; then
            if [[ $systemctl == yes ]]; then
                systemctl enable apache2 >>$workingdir/error_logs/fog_error_${version}.log 2>&1
                systemctl enable $phpfpm >>$workingdir/error_logs/fog_error_${version}.log 2>&1
            else
                sysv-rc-conf apache2 on >>$workingdir/error_logs/fog_error_${version}.log 2>&1
                sysv-rc-conf $phpfpm on >>$workingdir/error_logs/fog_error_${version}.log 2>&1
            fi
        elif [[ $systemctl == yes ]]; then
            systemctl enable httpd php-fpm >>$workingdir/error_logs/fog_error_${version}.log 2>&1
        else
            chkconfig php-fpm on >>$workingdir/error_logs/fog_error_${version}.log 2>&1
            chkconfig httpd on >>$workingdir/error_logs/fog_error_${version}.log 2>&1
        fi
    

    Next step is to validate those both lines :

    sysv-rc-conf apache2 on >>$workingdir/error_logs/fog_error_${version}.log 2>&1
    sysv-rc-conf $phpfpm on >>$workingdir/error_logs/fog_error_${version}.log 2>&1
    

    But now I fear that I may need systemctl to work …

    Environement : Docker (Ubuntu 20.04)

    Thanks for your help !


  • @aheerds said in "Enabling apache and fpm services on boot" failed:

    I got much further in the installation by changing to debian:latest and not ubuntu:20.04.

    Now I am stuck at this :

    insserv: FATAL: service mountdevsubfs has to exists for service hwclock
    insserv: FATAL: service mountkernfs has to exists for service procps
    insserv: exiting now!
    

    Currently working on it, but FOG has started and it’s running. But there is still something wrong …

326
Online

9.7k
Users

16.1k
Topics

148.5k
Posts