Slow Imaging for New Dell OptiPlex 7090 Ultra


  • Hello,
    Currently we are in the process of refreshing some of our classroom labs and plan to deploy the new OptiPlex 7090 Ultras from Dell. We set one up in the office to test with and found that it takes about seven(7) hours to push a 16.22GB image. We tested the network port we were using for imaging by setting up a Dell laptop and imaging it and it went fine, took about ten(10) minutes. We have also tried the 7090 Ultra on a different network port and got the same results. I did let the 7090 image over night and when I came in in the morning there was a http(s) error screen up, however clicking enter fixed that and I was able to log into the PC without issue.

    It is initially getting stuck on the step “Restoring Partition Tables (GPT)…” After about half an hour, it will then start the cloning process, however as I stated this can take anywhere from seven(7) to thirty-four(34) hours.

    Our FOG server is running version 1.5.9 and our Kernal versions are both 5.10.34. It is also installed on a CentOS server.

    The processor is an 11th Gen Intel i7 4-core 4.8GHz
    16GB DDR4 RAM
    256GB M.2
    Intel Ethernet Connection (13) I219-LM

    Any help or guidance would be greatly appreciated! I am new to managing a FOG server and know next to nothing about CentOS.
    Thank you again!


  • Did you ever find a fix for this issue? I have the same problem. I have a work around but its not really a fix for sure. If I use an external usb-c nic dongle it images fine, but this for sure is not a long term solution. If you ever figured this out i would be glad to hear how.

    Thanks


  • @wuenschz Update: I have launched the task in debug mode and entered nvme set-feature -f 0x0c -v=0 /dev/nvme0. I am now able to get past the “Restoring partition Tables (GPT)” portion of the cloning, however it still gets hung up at the partclone screen. I did look at the partition information and it said that “Disk /dev/nvme0n1: 256GB” Do I have to change the command to reflect nvme0n1 instead of the /dev/nvme0?

    Also, I saw that it says “Write caching not supported” but does support the drive and sees the drive.

    I have also tried adding the nvme_core.default_ps_max_latency_us=0 kernal arguments to to the host in FOG and that did not fix anything.

370
Online

9.1k
Users

15.7k
Topics

145.8k
Posts