Fog Migration from Ubuntu 14.04 to 20.04 for update to 1.5.9


  • Had a successful migration, DB, images, and install of 1.5.9 to the new Ubuntu 20.04 server, however it seems FOG’s rights to delete images was lost. There is an error that comes up on delete:
    a2b6b0da-b3fd-437f-9f4b-96733c7cde84-image.png

    Seems imaging, or capturing images all seem to work fine. PXE works fine… just seems to be the delete, as of right now. Any idea on what I need to do to ensure a user can delete the images? I suspect the old setup storage account from the DB that was transferred, then updated may not be correct now… though it seems to be reading from storage fine, location didn’t change, and rights were copied with images.

    Any idea’s on resolving this 1, and 2 is there anything else I should do to ensure the rest of the configuration is good? We have 2 more site servers to convert over the same way, want to get the process down to keep downtime low. Thank you!

    Some background:
    Each install is there own storage and site server, we manually replication to other sites with rsync for network throttling reasons, and script out the DB image list for the other sites so each site DB stays updated at the other sites. Think of it as 3 Master Sites, with a sync from Master 1, to Master 2 and 3. Each with thier own single data storage node.


  • Update:
    Finally had some time to sit and putz with it. Seems it was a carry over issue between what the password was in /opt/fog/.fogsettings for "fogproject’ versus what the UI had for the TFTP settings for the ftp user account, and for the storage node. Interesting that it was able to Image, and pull images though.

    For those that may be interested, or have the same issue:
    FTP to the FOG server from another box, and test FTP user and password that is shown in the storage management UI. This password should ALSO match what is in the FOG Settings in the UI for TFTP server. In my case… the password in the GUI would not allow me to connect to the FTP. Started searching for the proper way to change the FTP password for FOG… but ended up finding that the password was different in the .fogsettings file. I tried the password in the settings file and it worked to connect to the ftp.

    At this point, I took the password shown for fogproject in /opt/fog/.fogsettings and placed it in the UI for the Storage, and TFTP server settings. Attempted to delete from the UI… and bingo, all good.

    A good ref that helped to figure this out:
    Troubleshoot_FTP


  • Update:
    Ran chown -R fogproject:root /images against the directory, so permissions seem right on the images directory as far as ownership, and it still gives the same error. Seems maybe in the carry over the “fogproject” user may not be known to the system, and only configured inside of FOG because of the DB copy over? Not sure… if anyone has some pointers to try, my ears are open.

    Currently deleting manually… remove image pointer from DB on the GUI, then going to the images directory and running rm -r images/sysprepxxxxx to remove the directory and contents… so we are not down by any means, would just like to have the GUI delete working from within the image screen.

349
Online

8.6k
Users

15.3k
Topics

143.5k
Posts