FOG installation problem - MYSQL password



  • Hi,

    I installed FOG on an ubuntu 12.04 server. At the FOG installation, i have set a mysql “root” password (not blank), that i put into the
    [FONT=monospace][COLOR=#000000]/var/www/fog/commons/config.php[/COLOR][/FONT]
    [FONT=monospace][COLOR=#000000]/opt/fog/service/etc/config.php[/COLOR][/FONT]
    [FONT=monospace][COLOR=#000000]files. When i go to the [url]http://myserver/fog[/url] page to install fog, i got a HTTP 500 error…[/COLOR][/FONT]

    [FONT=monospace][COLOR=#000000]Any ideas?[/COLOR][/FONT]
    [FONT=monospace][COLOR=#000000][/COLOR][/FONT]



  • I would check the etc/dhcp/dhcpd.conf file and make sure everything is set correctly in there. That’s the DHCP config file. I’m not by my FOG server to check, but i’m pretty sure that’s where it’s located.



  • When installing the fog application, i specify the ip to be 192.168.1.1, as the tutorial instructs me to do. Once the fog software is installed, i connect the server to a switch, so there is no dhcp server taking up that ip address. I’m expecting the fog server to act as the dhcp. It is being installed on ubuntu 12.04. I checked the link and i do have a /var/www/fog folder and the config.php file in the commons directory seems to be configured with the settings that i specified when i installed.



  • Also, I just found this thread, it could answer some questions, [url]http://fogproject.org/forum/threads/unable-to-reach-default-fog-web-page.104/[/url]



  • Well, it should probably be asked as to what OS you are running this on. I’ve learned, personally, after all my FOG re-installs, I just leave the MySQL password alone. This could be different for you, but i’m the only person with any credentials on the server itself, so I don’t worry much about the password. But depending on what OS you’re using, it could make a difference. Also @at808, are you sure 192.168.1.1 is your FOG server? I guess i’m just used to that being the router on a home network.



  • I have this same exact problem. I followed the tutorial and the only things i changed was the ethernet port. (changed from eth0 to eth2, because that’s what it says when i do an ifconfig) and i entered an sql root password as the OP did. Entered them in the 2 config files as he did. When i try to go to [url]http://192.168.1.1/fog/management[/url], the page times out. Is reinstall the only option?



  • you need to go to [url]http://yourserver/fog/management[/url]. if that doesn’t work, since it’s a new install, I would try to install it again since that would probably be a bad apache install.


 

465
Online

41.8k
Users

12.3k
Topics

116.1k
Posts