HP EliteBook 840 G7 stuck at "rEFInd - Initializing..."


  • We recently got in a batch of HP Elitebook 840 G7 laptops. I discovered these did not have BIOS, only UEFI.

    I configured:

    • Option 67 to ‘ipxe.efi’

    • Disabled secure boot

    Began imaging process and device appeared to reimage successfully and quickly, but upon reboot it got stuck on a “rEFInd - Initializing…” screen.

    Researched this on the forum. Tested adding alternate versions of ‘refind_x64.efi’ file manually to /var/www/html/fog/service/ipxe.

    Results:
    v12.0 - stuck at same screen
    v11.5 - stuck at the same screen
    v10.9 - loaded an ‘rEFInd - About’ screen, but the Main Menu had no option to boot to OS

    Current FOG Setup is running Version 1.5.9.

    How can I resolve this issue?

  • Senior Developer

    @rankinc We might have a hint for you which @RobertD posted just an hour ago: https://forums.fogproject.org/post/141591


  • @sebastian-roth Well I tried a few versions and ultimately I copied the original refind.efi to be refind_x64.efi and it is working…? the v12, v12 _x64.efis were not working so I just threw something at the wall. going to test some other models that previously worked to see if I broke them.

  • Senior Developer

    @rankinc Seems like HP systems are a pain when it comes to chainloading the OS from disk. Can you try different versions of rEFInd to see if maybe the newest one works with your device.


  • @tech04 Were you able to figure this out?

    I’m having the same issue with an HP 450 G7. Tried all the exit types.

    I can pxe and image fine but it will not boot to Windows unless I have HD set as first boot.


  • @tom-elliott Interesting…enabling Secure Boot did in fact cause the computer to boot to the Windows OS. But it bypassed the FOG menu. It downloaded the NBP successfully, but then loaded Windows.

    Disabling Secure Boot caused it to once again boot to the FOG menu, which then timed out, and then hit the rEFInd snag.

    Is this model of hardware unable to boot to the FOG server, timeout, and then load Windows?

    At this point, it seems it can do either Windows or FOG, but not both together.

  • Senior Developer

    @tech04 If secure boot is disabled on the machine, maybe re-enable it now that imaging is done?


  • @tom-elliott Some further testing:

    • Changed to rEFInd Version 10.9. The rEFInd - Initializing screen came up, but then said Scanning for boot loaders; please wait… LT stayed at this screen.

    • Changed Host EFI Exit Type for this host to EXIT. Got message
      Chainloading failed, hit ‘s’ for the iPXE shell; reboot in 10 seconds.
      Device would reboot, then do it all over again.

    • Changed to rEFInd Version 11.0. Still got the ‘Chainloading…’ message.

    • Turned off EXIT for the host. The rEFInd - Initializing screen came up and went to a ‘Scanning for boot loaders; please wait…’ message. It stayed there.

    rEFInd just does not want to load Windows for some reason. I saw this thread which referenced a comment on Reddit that non-signed kernels have trouble chainloading to a signed Windows kernel.

    Could this be the issue I am dealing with? If so, what can I do to resolve this?

  • Senior Developer

    @tech04 Okay,

    So there’s 2 main efforts for EFI booting that you could attempt:

    1. rEFInd - which isn’t working. Maybe you can try v10.9, not sure if you tried all three versions?
    2. Try setting the machine’s Host exit type to Exit? Specifically the EFI exit type?

  • @tom-elliott Yes, I have the scan_delay set to 5. Timeout is also set to 5.

  • Senior Developer

    @tech04 Have you tried adjusting the scan_delay?

    It really feels like refind cannot find the drives. So if it’s set to 0 the and doesn’t find anything, how would it get past initializing?

    I could be wrong of course. I’m not seeing all the differences.


    • Started today with rEFInd Version 0.11.04, scanfor set to manual, menuentry for Windows. LT would get to a rEFInd menu, but would fail to load Windows.
      Error: Not Found while loading bootmgfw.efi.

    • Changed to rEFInd Version 0.12.0. LT got stuck at rEFInd - Initializing…

    • Edited refind.conf to scanfor netboot, internal and disabled manual menu entry. LT got stuck at rEFInd - Initializing…

    • Edited boot order of LT to boot to disk first and it loaded the OS.

    There seems to be an issue going from pxe boot to hard disk. Once the network boot times out and tries to boot to the hard disk it encounters difficulty at the rEFInd stage.


  • @sebastian-roth Here’s the menu entry. It’s a Windows 10 image - I just didn’t update the entry name.

    6ce1a096-f01c-4268-aefa-be11bb32d905-image.png

    Using rEFInd Version 0.11.4.

  • Senior Developer

    @tech04 said in HP EliteBook 840 G7 stuck at "rEFInd - Initializing...":

    I edited the scanfor to manual and added a menu entry for Windows.

    What does the menu entry look like exactly?

    By the way, which version of rEFInd do you use now?


  • @sebastian-roth It occurred to me that I was imaging with a golden image that had been created with a vm that used BIOS. I created a new vm using EFI and created a new base image. Reimaged with this image, but it still seemed to get hung up at a rEFInd screen. Later, I saw the OS did end up loading.

    Tinkered around with this some as it still seems to get hung up at rEFInd. I edited the scanfor to manual and added a menu entry for Windows. Got this:
    FOGImaging_rEFInd-BootingOS.jpg

  • Senior Developer

    @tech04 You can look up all the available parameters for this scanfor option on the rEFInd website. Try different combinations and maybe even try the parameter manual and add so called “Manual Boot Stanzas” (see in the link posted).


  • @sebastian-roth I updated the firmware on the device, but am still getting the same screen as the previously-posted screenshot.


  • I spend most of my day yesterday on another matter. Back to work on this issue today.

    @tom-elliott I made the suggested changes and ended up with this screen:
    FOGImaging_rEFInd-Initializing.jpg

    Hitting different keys did nothing. It remained stuck on this screen.

  • Senior Developer

    @tech04

    I’d recommend looking at the configuration file for refind and seeing if making changes within the file helps out even with newer refind versions.

    I think this only because I believe “new” versions of refind add functionality that did not exist with the older versions.

    https://forums.fogproject.org/topic/11146/refind-initializing-after-disable-secure-boot/8

    This post kind of describes what things to look for.

    Particularly of interest, I believe you would want to change scanfor line from:
    scanfor netboot,internal to possibly scanfor netboot,hdbios,internal.

    The next change will likely be the scan_delay option. It currently defaults to 0. I would recommend adding a 5 second delay here as this is likely what’s hanging the initialization. 0 means don’t wait for any time to start looking for boot devices. So while it’s initializing, it’s also expecting to find the drives (which may not be ready yet).

    I would recommend setting the timeout from -1 to 5 as well just so you can ensure all is working. If it works with either (or or and) scan_delay and scanfor, then reset the timeout to -1 to automatically and immediately boot to the first found item.

  • Senior Developer

    @george1421 As initially posted the OP already tried different versions but only the really old one worked.

    @tech04 Make sure your UEFI firmware is the latest available! Using that old version is one option you have. The other one is compiling rEFInd from source and adding debug statements to find out where exactly it stucks and talk to the developer. We can help you with that but it’s in your hand. We don’t have the hardware.

295
Online

8.6k
Users

15.3k
Topics

143.4k
Posts