Problem with TFTP



  • Hi,
    I’m runnig fog 0.32 on a debian 6.0.6.

    Fog already worked, but these days I get when booting a client (eg. 192.168.1.5) the message

    CLIENT IP: 192.168.1.5 MASK 255.255.255.0 DHCP 192.168.1.1
    GATEWAY IP: 192.168.1.8
    TFTP …
    and nothing happens.

    root@homeserver:~# netstat -an |grep :69
    udp 0 0 0.0.0.0:69 0.0.0.0:*

    I don’t know, what I have done.

    When I do a
    tfp 127.0.0.1 -c get pxelinux.0 on the server it works. When I do the same command with 192.168.1.1 (the IP of the server) nothing happens (timeout).

    I have done /etc/init.d/tfpd-hpa restart. The problem stays the same.

    When I restart the server it will work (!!!), but after a couple of days I get the TFTP timeout.

    What can this be?

    Bye,
    Markus

    root@homeserver:~# more /etc/xinetd.d/tftp

    default: off

    description: The tftp server serves files using the trivial file transfer

    protocol. The tftp protocol is often used to boot diskless # workstations, do
    wnload configuration files to network-aware printers, # and to start the install
    ation process for some operating systems.
    service tftp
    {
    socket_type = dgram
    protocol = udp
    wait = yes
    user = root
    server = /usr/sbin/in.tftpd
    server_args = -s /tftpboot
    disable = no
    per_source = 11
    cps = 100 2
    flags = IPv4
    }

    more /etc/inetd.conf

    #:BOOT: TFTP service is provided primarily for booting. Most sites

    run this only on machines acting as “boot servers.”

    #tftp dgram udp wait root /usr/sbin/in.tftpd /usr/sbin/in.tf
    tpd -s /var/lib/tftpboot

    root@homeserver:~# more /etc/default/tftpd-hpa

    /etc/default/tftpd-hpa

    TFTP_USERNAME=“tftp"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“0.0.0.0:69"
    TFTP_OPTIONS=”–secure"
    #RUN_DAEMON=“no”
    #OPTIONS="-l -s /var/lib/tftpboot"


Log in to reply
 

436
Online

38946
Users

10698
Topics

101511
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.