Can't have partition outside the disk

  • Hello,
    I get this problem when i am deploying machine: “can’t have partition outside the disk”

    sda1: WIN7
    extended: sda5:WINXP, sda6:ubuntu
    i uploaded the image as ubuntu, single disk, multiple partition.

    I tried to make new partition table in gparted but it doesnt work. also i run chdsk, and repare ext3 partition in gparted but it didnt work. I have the newest version of fog.

    i noticed that when i make a partition table in gparted and then try uploading and then checking in gparted, it always delete partition table.

    Any idead? i am using 2 same computers and disks(Fujitsu esprimo gold)


  • As i said, i am using identical computer and disks

  • Is this still an issue for you? The problem is the image was taken from a larger harddrive than what you have in the computer you are trying to image. When you created the image you may have selected multiple partition image which is not resizeable so it won’t shrink to a smaller drive.