FOG Could not start download: Invalid Argument



  • I have been using this particular FOG server for about 6 months now and had no issue with any other Dell workstation that i have. We received some Dell laptops to image today and for some reason the FOG server does not seem to like these new Dells. The only thing I notice with these new Dells is that they are AMD base and not Intel. I am not sure if that has anything to do with it but the link that is in the error says it might be AMD related. I tried looking on the forms to see if anyone has encountered a similar issue but it does not seem like it. Please link below if that is not the case.

    I am receiving the following error.

    Could not start download: Invalid argument (http://ipxe.org/1c25e082)
    Could not boot: Invalid argument (http://ipxe.org/1c25e082)

    FOG Server Info:

    • Dell Optiplex 790
    • Debian 10
    • FOG version 1.5.8
    • bzImage version 4.9.123

    Computer that is giving me this problem:

    • Dell Inspiron 11 3000
    • USB-A to ethernet adapter (no built-in NIC on the computer, i have worked with this adapter before and there has not been any issue in the past)
    • AMD A9-9420e (Link from error states that it might be an AMD related issue)

    BIOS settings

    • Boot mode UEFI
    • Secure boot off
    • Secure Mode Audit Mode
    • SATA operation AHCI (Only option available)
    • Fast Boot Auto

    Please let me know if more info is needed.



  • @george1421 Ubuntu 20.04


  • Moderator

    @HowToGravity It might be your build envrionment. When I created the instructions they were for ubuntu 14.04 based computers. My current build environment is based on linux mint 19.2 and it still works.

    What linux host did you try to build this under? I may need to update my instructions.



  • @george1421 So I ran sudo apt-get install grub-efi-amd64 parted kpartx & sudo apt-get install grub-efi-ia32 parted kpartx separately and I am still getting the same error.

    I also tried using Method #2 (windows path / BIOS boot) but the i am not able to get the file ldlinux.sys generated. I am running the unetbootin-shortcut as Admin, i even tried 2 sperate ways of running it as admin. First way was right click the shortcut and run as admin, second way was running CMD as admin and launching unetbootin with the parameter showcustom=y.

    Not sure what I am doing wrong or what I am missing.


  • Moderator

    @HowToGravity said in FOG Could not start download: Invalid Argument:

    Grub-install error: cannot find EFI directory

    In part 2a or 2b you missed the bit about installing the additional grub libraries it sounds like: sudo apt-get install grub-efi-amd64 grub-efi-ia32 parted kpartx I think you might have an issue with the ia32 and amd64 being installed at the same time. I seem to recall an issue with that.



  • @george1421 So i am following the instructions listed on this form https://forums.fogproject.org/topic/6532/usb-boot-target-device-into-fog-os-live-fosl-for-debugging to create a FOS linux USB and I am getting on step #12 sudo grub-install --force --no-floppy --boot-directory=/mnt/boot /dev/sdX. Every time i run the command i get the following error Grub-install error: cannot find EFI directory.

    Hopefully i am following the right instructions.


  • Moderator

    @HowToGravity So lets assume that iPXE is incompatible with this workstation for some reason. We have an alternate method to boot into FOS Linux (the custom linux OS that captures and deploys images).

    I have a tutorial on how to build a fos linux usb boot drive. Read the article and understand the caveats of going this route. The tutorial is a bit out of sequence because of the way the forum works. So read the first post and then scroll all the way to the bottom for the second posts. Also look at the FOG Forum chat bubble for some additional tips.

    https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image



  • @george1421
    Just finished updating the BIOS and still no luck. Everything else looks to be up to date.

    Do you know if anyone has had an luck with imaging eMMC flash storage before?

    Exact model is Dell Inspiron 11 3195.


  • Moderator

    @HowToGravity This is the only thing that is being downloaded

    console --picture https://192.168.20.2/fog/service/ipxe/bg.png --left 100 --right 80

    But again the only model throwing this error is this inspiron?? The true table is tell me its the computer and not the fog server. I simply don’t understand the error.

    Can you confirm the firmware is up to date on this target computer?

    Is this an AMD processor? I have seen some references to an AMD processor creating this error too. But I’m not really believing that either.



  • @george1421
    I only get the error:
    Could not start download: Invalid argument (http://ipxe.org/1c25e082)


  • Moderator

    @HowToGravity said in FOG Could not start download: Invalid Argument:

    chain https://192.168.20.2/fog/service/ipxe/boot.php

    If you key in the above do you still get an error? I’m going to say yes, but I’m wondering if there are any more helpful error messages.



  • @george1421
    So i deleted the host LIB1723561 and i am still getting the same error as before.

    This is the contents of /tftpboot/default.ipxe

    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch ${buildarch}
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param product ${product}
    param manufacturer ${product}
    param ipxever ${version}
    param filename ${filename}
    param sysuuid ${uuid}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain https://192.168.20.2/fog/service/ipxe/boot.php##params
    

    Any specific commands I should enter in the iPXE shell after hitting s


  • Moderator

    @HowToGravity Well I didn’t get s solid answer from the web site or the manual.

    Here is what I’m thinking

    1. Delete the host LIB1723561 (what the nic is registered already as).

    2. It might be a spanning tree protocol issue, where one of the fast spanning tree protocols are not being used.

    Searching the manual I could only find 1 reference to spanning tree but not a way to adjust it. If the network port where this computer is being imaged from works with other computer hardware its probably not a spanning tree issue.

    This one has me a bit stumped at the moment.

    What is the content of the default.ipxe file on the fog server it will be in /tftpboot/default.ipxe. That is the last file it downloads from the fog server’s disk. After that things go sideways.

    If you get that message about hitting s for the iPXE shell lets do that. There has to be something I’m missing here because other computers can get into the FOG menu just not this computer



  • @george1421

    Just to be clear here, this problem only happens on this specific model of computer? All other computes work correct, right?
    Yes, since updating the bzImage this morning I was successful at capturing and deploying an Optiplex 5040 image.

    If that assumption is correct, do you have a cheap/dumb/unmanaged network switch?
    Yes, exact model is D-link DGS-1008G


  • Moderator

    @HowToGravity Ok you surely have https configured on your server. So that is not it.

    Just to be clear here, this problem only happens on this specific model of computer? All other computes work correct, right?

    If that assumption is correct, do you have a cheap/dumb/unmanaged network switch?



  • @george1421
    netstat -an | grep :80
    tcp6 0 0 :::80 :::* LISTEN

    netstat -an | grep :443
    tcp6 0 0 :::443 :::* LISTEN
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56931 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56922 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56923 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56910 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56921 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56933 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56932 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56920 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56930 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56935 ESTABLISHED
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56928 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56929 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56912 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56919 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56918 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56908 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56917 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56927 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56909 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56911 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56913 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56916 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56926 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56934 TIME_WAIT
    tcp6 0 0 192.168.20.2:443 192.168.20.3:56925 TIME_WAIT


  • Moderator

    @HowToGravity Setting up https would have been a boot time questions I think.

    On the fog server linux console lets see this commands.

    netstat -an | grep :80

    and

    netstat -an | grep :443

    What that will tell us if something is listening on http (port 80) or https (port 443). I’m trying to understand this error. The ipxe menu should NOT be throwing this error at this point. I just want to make sure I’m chasing the correct ghost.



  • @george1421 Not to my knowledge I do not have HTTPS setup, I am the only person who access the FOG server. I followed the link and it does lead me to the background image for FOG, but it is unsecured.

    *edit: Interesting HTTPS port is active. I don’t believe I opened it, FOG is the only thing i am using this server for.


  • Moderator

    @HowToGravity OK I think we are narrowing in on something.

    I’m seeing https in the menu file. Do you have this fog server configured for https services?

    This is in the menu

    https://192.168.20.2/fog/service/ipxe/bg.png

    If you do that from a windows browser it should download the background image for fog.



  • @george1421 Is this computer currently in an imaging mode? Like it was registered then you picked deploy or capture. When you are booting after scheduling the task this is the error you get?
    The computer it self is not registered yet with FOG, i still have to get it registered. But from looking at the log, I believe the USB to Ethernet adapter MAC address is registered but under a different computer. So no task has been schedule yet for this computer. My intentions were to boot to FOG then perform a full host inventory and registration.

    I am not sure if adding the “-” (hyphen) in the MAC address into the URL makes any difference but I will add both of the outputs below.

    without hyphen.txt
    with hyphen.txt

    *Edit: There are no task queued on the server


Log in to reply
 

277
Online

7.4k
Users

14.5k
Topics

136.5k
Posts