1.5.9 RC2 - snapin hash not match on new computers



  • Hi,

    • new fog installation with 1.5.9 RC2 version.
    • fog is on centos 7
    • computers with win10 ver.2004

    I noticed that newly imaged computers cannot install snapins because of error with hash do not match

    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     27.07.2020 12:05:20 Client-Info Client Version: 0.12.0
     27.07.2020 12:05:20 Client-Info Client OS:      Windows
     27.07.2020 12:05:20 Client-Info Server Version: 1.5.9-RC2
     27.07.2020 12:05:20 Middleware::Response Success
     27.07.2020 12:05:20 SnapinClient Running snapin WPKG
     27.07.2020 12:05:20 Middleware::Communication Download: http://10.180.8.90//fog/service/snapins.file.php?mac=E8:D8:D1:B8:1D:EA|F8:E4:E3:27:6A:91|F8:E4:E3:27:6A:92|F8:E4:E3:27:6A:95&taskid=9
     27.07.2020 12:05:20 SnapinClient C:\Program Files (x86)\FOG\tmp\Wpkg-GP-0.17.16_x64.exe
     27.07.2020 12:05:20 SnapinClient ERROR: Hash does not match
     27.07.2020 12:05:20 SnapinClient ERROR: --> Ideal: 22E59FC417DFDC2553266381F3C478E4CC35FBAFE739CD68D553A53CC8A459D79DDB66698ADFA3C30099E302489C4E4951E2992B3773DE6A6E7AD8B5A50646AE
     27.07.2020 12:05:20 SnapinClient ERROR: --> Actual: 94C85322BD7EC5FE201F52064A78C58BFA99C10AC316EC557BE010FF88D3AD5F3F3BF220FFCB07CAF77F89A9E0F4A44CE1CF9343DBFD0C7E582C5DC0C7AF42B5
     27.07.2020 12:05:21 Middleware::Communication URL: https://10.180.8.90/fog/service/snapins.checkin.php?taskid=9&exitcode=-1&mac=E8:D8:D1:B8:1D:EA|F8:E4:E3:27:6A:91|F8:E4:E3:27:6A:92|F8:E4:E3:27:6A:95&newService&json
    ------------------------------------------------------------------------------
    
    

    First I thought it was issue with sysprep and new windows version, but image with snapin works fine with computers already in hosts list, only new one have a problem. How can I fix this? After checking the forum I saw that issue might be on Fog ver. 1.5.9. RC2 can I degrade it safely to stable 1.5.8 ?



  • More info - from old fog I exported only hosts via web browser - old hosts when reinstalling have correct hash and snapins works smoothly. Issue is only with machines which I register.
    No errors in fogsnapinhash.log


Log in to reply
 

321
Online

7.2k
Users

14.4k
Topics

135.6k
Posts