Dell Latitude 5510 No network interface found! Kernel might not have the correct driver!

  • Im getting this message when im trying to upload.

    “No Network Interface found, your kernel is most probably missing the correct driver! Please check your network setup and try again!”

    I’ve already changed patch cord and upgraded to the latest fog which is the 1.5.9-RC2.9. Can anybody help with this issue i’ve been cloning and capturing with no issue but since this is a new model of laptop i think it might have a newer card. The card that i has its an Intel Ehternet Connection l219-LM. Any help will be greatly appreciated!

  • @george1421
    Thank you!
    That fixed our issue. Much appreciated.

  • @george1421 ok once im done imaging ill change it. Thanks a lot for your help!

  • Moderator

    Just an update on this thread. There is no need to use this one-off kernel to get new hardware support. The FOG Developers have released an officially supported version of the 5.x kernel to the normal kernel repository. This officially released kernel can be updated from within the FOG Ui as all other kernels are released.

    @asbenavides Ok you have a few options then.

    1. Go into the FOG settings and change the default kernel from bzImage to bzImage553
    2. For every 5510 set the host kernel value to bzImage553.

    The one-off kernels are built for specific purposes and are not part of the main FOG distribution. There these kernels may support additional hardware not found in the default FOG distribution, otherwise they are functionally equivalent. If I remember right the FOG 1.6.x series of FOG will include the 5.x line of linux kernels.

    You may continue to use this kernel as I’ve outlined in steps 1 or 2 without any problems.

  • @george1421 the steps you provided worked great!

  • Moderator

    @asbenavides I forgot to mention that you will still get the error but debug mode will give us a chance to try to understand why its not working.

    Intel Wireless-AC 9462 [8086:02f0] first available in linux kernel 5.0
    Intel Ethernet Connection (10) I219-LM [8086:0d4e] first available in linux kernel 5.5

    So in short the version of bzImage supplied with the current release of FOG does not support the built in ethernet adapter.

    I have a one off kernel for FOG that is 5.5.3 that you can try:

    Download that file to /var/www/html/fog/service/ipxe directory on the FOG server. Make sure the case of the file name is kept intact it should be called bzImage553

    Then go into the host definition for this Latitude 5510 and set the Host Kernel parameter to bzImage553. Now pxe boot the computer into imaging. Understand what we are doing right now is only testing to see if this one-off kernel works for this system.

  • @george1421

    this is what im getting disregard the previous reply.

    1. lo: <loopback.up.lower_up> mtu65536 qdisc noqueue qlen 1000
      link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      inet scope host to lo
      valid_lft forever preferred_lft forever

    2. I get
      00:14.3 Network Controller [0280]: Intel Corporation Device [8086:02f0]
      00:1f.6 Ethernet Controller [0200]: Interl Corporation Ethernet Connection (10) I219-LM [8086:0d4e}

  • @george1421 tried that debug checkout box but I still get the same error. “No network interface found” and i’ve check to see if the ethernet port has connectivity and it does has and any other pc does work fine in the same port.

  • Moderator

    @asbenavides said in Dell Latitude 5510 No network interface found! Kernel might not have the correct driver!:

    i was using the onboard network adapter and it didnt work

    I’m curious to why the onboard adapter to why that didn’t work. I might understand about the USB-C nic not working. On the Dells you need to go into the firmware (if uefi) and enable the uefi network stack on the network adapter page to enable pxe booting. In the case of a usb-c network adapter I can tell you the WD-15 and WD-19 docks support pxe booting with FOG. I believe the Dell usb-c to ethernet dongle also works with FOG.

    Just to be clear this is the model computer we are talking about?

  • @Sebastian-Roth i dont have trouble with any other machines only this ones every other machine works fine.

  • @george1421 ill try that tomorrow at work and i was using the onboard network adapter and it didnt work, but i used a usb c network adapter and it did work. The laptop is a Dell Latitude 5510 its a brand new laptop and i have a few that are going to come in later during the month.

  • Moderator

    This is a strange situation. If that is the 5510 Precision workstation it should be a similar platform to the 3510 laptops we have. If so those laptops are 3-4 years old, the FOS Linux kernel for FOG 1.5.9 should have the proper driver in it.

    What I want you to do is setup a new deploy task, but before you hit the schedule button tick the debug checkbox, then schedule the task.

    PXE boot the target computer and after a few screens of text that you need to clear with the enter key you will be dropped to the FOS Linux command prompt on the target computer. At the FOS Linux command prompt key in the following commands, please take a clear picture of the results and post them here.

    1. ip addr show
    2. lspci -nn |grep -i net

    The last question is, are you using the onboard network adapter to pxe boot or a usb based network adapter?

  • Senior Developer

    @asbenavides Do other machines on that exact same network port PXE boot just fine?

Log in to reply