PXE Booting & TFTP



  • Hi all,

    Trying to get a PC to PXE boot to the server but I get the error below:

    PXE-T01: The specified file was not found.
    PXE-E3B: TFTP Error - File Not Found.
    PXE-M0F: Exiting Broadcom PXE ROM.

    I have set the scope options on the subnet for my floor (66 and 67).

    Setting this up at work. We have a DHCP server. I’ve tried various combinations on the install (latest version) with Ubuntu desktop 12.10. Anyone know how I can get this working?

    Thank you!



  • Although it sounds like DHCP options are correct, it might be worth checking it using Wireshark on the client PC. If you filter the capture to ports 67 & 68 (UDP but it doesn’t matter if you capture both TCP and UDP), then perform an ipconfig /release, ipconfig /renew or simply disconnect/reconnect the network cable. Within the captured packets you should be able to see the DHCP options and that pretty rules out DHCP configuration issues.



  • Any other ideas? I have re-installed fog on Ubuntu 10.04 and still the same problem. I can retrieve the pxelinux.0 file if I tftp from the windows machine. I named the local acount as administrator on the Ubuntu machine as I read that calling it fog might be problematic.



  • Hi Moss,

    It is indeed a zero.



  • Have you double checked option 67 to make sure the names specified correctly? pxelinux.0, using a zero not an O?


Log in to reply
 

514
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.