PCs not joining correct OU



  • Hi I recently changed the FOG_AD_DEFAULT_OU to a different setting which didnt seem to work (all computers were going in to the default computers OU) even though I got the DN of the new OU using AD explorer. I have now changed it back to what it was previously, by copying an pasting the DN from a previously registered host but all machines are now defaulting to the Computers OU (default). Anyone any ideas?



  • I think we are going to go with adding PCs manually before imaging as a workaround just now. Does anyone know how to manually add multiple computers to AD from a text / csv file etc?



  • Thanks for your response, how do I resolve this? I noticed this earlier so removed the computer object from AD Users and Computers prior to re-imaging, it also does this when new PCs are imaged.



  • This shows it joined. maybe deleting the object in the OU and rebooting(PC) might get it to work.

    20/01/2012 14:35 FOG::HostnameChanger Attempting to connect to fog server…
    20/01/2012 14:35 FOG::HostnameChanger Module is active…
    20/01/2012 14:35 FOG::HostnameChanger AD mode requested, confirming settings.
    20/01/2012 14:35 FOG::HostnameChanger Hostname is up to date
    20/01/2012 14:35 FOG::HostnameChanger Attempting to join domain if not already a member…
    [COLOR=#ff0000] 20/01/2012 14:35 FOG::HostnameChanger Domain Replied: (‘SetupAlreadyJoined’ Code: 2691)[/COLOR]



  • I’ve double checked the user account and it is in the format above, it shouldnt be a problem anyway as the PCs are joining the domain but for whatever reason they are bypassing the OU settings. Its not really a great issue but would be handy to get working again. I’ve uploaded a copy of the fog log from one of the PCs in question

    [url="/_imported_xf_attachments/0/19_foglog.txt?:"]foglog.txt[/url]



  • Yeah I understand that you haven’t changed anything but the OU. From what you put OU=Workstations,DC=ourdomain,DC=gov,DC=uk that looks okay. So i’m not exactly sure what could be the issue other than making sure some of the little nuances of using Hostname changer are checked. I already mentioned log files to see if you could get any info and you said there is nothing relating to it in there.

    So what I would try is:

    make sure you put: [FONT=Ubuntu][COLOR=#333333]FOG_AD_DEFAULT_USER: [/COLOR][/FONT]‘DOMAIN\USER’ (Other wise it would t work for me)
    try adding a machine to AD manually with the exact same credentials your using in fog

    Other than that im all out ideas.



  • I can have a look through the logs again. Both the settings you have mentioned are OK, nothing else was changed other than the [FONT=Ubuntu][COLOR=#333333]FOG_AD_DEFAULT_OU[/COLOR][/FONT]



  • Thats weird your not seeing anything in the logs have you tried checking to see if the hostname changer setting is set to on.
    Other Information -> Fog Settings -> Fog-Service Hostname Changer -> Value = ‘1’.

    and under

    Host Management -> (Find your PC) -> Service Settings (on the left) -> In the list under ‘Hostname changer enabled?’ make sure that it is checked.



  • Hello,
    It used to go into an OU called workstations OU=Workstations,DC=ourdomain,DC=gov,DC=uk and then I changed it to OU=subou2,OU=subou1,OU=TopLevel,DC=ourdomain,DC=gov,DC=uk (I copied and pasted it from AD explorer as I said above then changed it back to the original which was working) This now also defaults to computers when the machines join the domain. Obviously the account, password and domain are correct. There is nothing untoward in the event log or fog log. Is there anywhere else that can effect the OU that the machines are going in to?
    Thanks



  • Hey,

    I have been testing this feature for the last few days. Make sure you got the right OU structure. So if I have a computer in the computer OU it should look like this.

    [FONT=Ubuntu][COLOR=#333333]FOG_AD_DEFAULT_DOMAINNAME: fogproject.org[/COLOR][/FONT]
    [FONT=Ubuntu][COLOR=#333333]FOG_AD_DEFAULT_OU: OU=Computers,DC=[/COLOR][/FONT][FONT=Ubuntu][COLOR=#333333]fogproject[/COLOR][/FONT][FONT=Ubuntu][COLOR=#333333],DC=org[/COLOR][/FONT]
    [FONT=Ubuntu][COLOR=#333333]FOG_AD_DEFAULT_USER: [/COLOR][/FONT][FONT=Ubuntu][COLOR=#333333]fogproject.org[/COLOR][/FONT][FONT=Ubuntu][COLOR=#333333]\fogproject[/COLOR][/FONT]
    [FONT=Ubuntu][COLOR=#333333]FOG_AD_DEFAULT_PASSWORD: 3red339dsa23kjdo9[/COLOR][/FONT]
    [FONT=Ubuntu][COLOR=#333333][/COLOR][/FONT]

    Also check the fog.log in the C:\ drive for errors it was really helpful for troubleshooting.


Log in to reply
 

385
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.