Default.IPXE-no such file or directory (2e008081)

  • @george1421
    Hi, here is results of this two commands.

  • Moderator

    @TOXYKILLER So what does showmount -e give you?

    Also that directory will be on the fog server in /images/dev, so show us the results of ls -la /images

  • @george1421
    Thanks i can preform now registration and schedule image capture. But i have issue with fog “/images/dev permission denied”
    I try find this folder via this commands showmount -e and find but i can’t find anything with this direct path and name. IMG_4938.jpg

  • Moderator

    @TOXYKILLER If you are using the USB boot method that boots via grub. You missed one of the caveats with this method. You need to schedule the task first within the FOG web ui then pick option 1 on the grub menu. What that error is saying, “hey you want to image, but I don’t have any task to tell me what to image”

    Schedule the task first in the fog ui then pxe boot the computer and you should be good.

  • @Sebastian-Roth
    Hi thank you for this manual it’s help. I can now register host but i can’t capture image from PC (i also choose in fog this options in host list). It’s seems i have issue with “/tmp/himfo.txt”. I try find this file but it’s doesn’t exit. IMG_4932.jpg

  • Senior Developer

    @TOXYKILLER Sorry for not answering but there was lot’s to do before X-Mas and I lost track of this. The USB boot method in the wiki is kind of old. Better you take a look at this: (page 2!)

  • @Sebastian-Roth
    I try it with via using web settings still not working also i tried .fog settings file but it’s seen won’t work at all(after install i don’t have this file created and also file tftpboot missing as well). I change this setting and try create usb again via this manual .

  • Senior Developer

    @TOXYKILLER As mentioned already the storage node IP seems to be different. Did you setup the server using that IP and then changed it later on?

  • Moderator

    @TOXYKILLER If you want to continue to use your existing dhcp server that is possible. You just need to install DNSMASQ onto your FOG server. The dnsmasq configuration will only provide pxe boot information. All other network details come from your main dhcp server. The only issue is if your pxe booting clients are on a different subnet than the fog server. If that is the case, you will need to update a setting in your network configuration. On your vlan/subnet router you will need to add the FOG server’s IP address as the last host in your router’s dhcp-helper/relay service. I didn’t mention this before, because you said you had no access to any infrastructure changes. Here is the tutorial for installing dnsmasq onto your FOG server. The instructions are centos/rhel specific but the only real difference for Ubuntu distro is to use apt-get instead of yum:

  • @george1421
    We now for this testing purpose using tp-link TL-MR6400.I check router setting and about DHCP is almost non existent settings so you advice about this issue is a create own linux base DHCP server ?

  • Moderator

    @TOXYKILLER Well I was going to say that it appears your dhcp server isn’t sending out the next-server value so iPXE is asking for it. But you deleted your post. Depending on the router, some soho routers send the next server address as them selves even if you set it to something else.

  • @george1421
    Since our last conversation i revoke a little bit topology (for more similar to production network).Now i don’t have static IPs and i using router as DHCP server.

    Server IP is now
    Client have

    So now when i boot via usb stick i put IP addres of sever.

    and here is full error screen


    here are logs from

    and here are from var/log/syslog | grep php


  • Moderator

    @TOXYKILLER Well from your picture the first thing I noticed is that your fog server is at 10.<something off the screen> but your storage ip is is that correct?

  • Senior Developer

    @TOXYKILLER Check apache und php-fpm logs, see my signature.

  • @george1421
    Thank i found that options but i have issue register any host now. I try both options(full host registration and quick registration) and i still have same error.Can you please help ?


    Thank you.

  • Moderator

    @TOXYKILLER Well I would expect that menu if you haven’t told FOG what to do.

    I take it you have registered the host with FOG by either doing a quick inventory or a full inventory. Once that is done there will be an entry in the host management view. From there if you want to capture an image you need to create an image definition and then go back to the registered computer and link the registered computer with the image definition you created. Then finally on the host definition create a capture task and schedule it. When you reboot the computer and pxe boot it, the target computer will check in with the FOG server and since there is a task, start imaging the computer.

  • @george1421
    Thank you a lot.
    After i was change default.ipxe it’s work but i can’t capture image from my test PC. It the limitation of booting via usb or something else is wrong ? When i booted i see only:
    Boot from HDD
    Run Memtest86+
    Deploy image
    Join Multicast session
    Client system information

    Or it’s in some fog setting this ?

    Thank you very much.

  • Moderator

    Well lets take this issue one by one.

    default.ipxe should look like this:

    cpuid --ext 29 && set arch x86_64 || set arch ${buildarch}
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param product ${product}
    param manufacturer ${product}
    param ipxever ${version}
    param filename ${filename}
    param sysuuid ${uuid}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme

    Where is the IP address of your FOG server.

    But I would have to question, if you installed FOG this directory should exist and be populated. I might suggest that you rerun the fog installer because something went wrong with the install.

    Second USB boot.
    The default ipxe boot loaders that come with FOG rely on dhcp to find the boot server via option 66 in dhcp. If you don’t have that you will have to manually rebuild the ipxe boot loaders as you saw in the article. The modified boot loader has the built in script where we ignore what dhcp is telling the target computer and force a specific address to be chained to. As in the wiki page

    set next-server
    set filename ipxe.efi
    chain tftp://${next-server}/${filename}

    But in my opinion that will cause issues for 2 reasons.

    1. That only works for uefi systems, you will need to build a bios boot loader.
    2. The chain just reloads the server version of ipxe.efi which again would rely on dhcp to find the fog server.

    If we look at the script that FOG uses to build the ipxe boot kernels here:

    I might modify the built in script from the wiki page to be something like this

    set next-server
    chain tftp://${next-server}/default.ipxe ||
    prompt --key s --timeout 10000 Chainloading failed, hit 's' for the iPXE shell; reboot in 10 seconds && shell || reboot

    That chain command will call the default.ipxe file that will connect into the FOG boot.php file. Rebuild ipxe.efi with that script using the rom-o-matic site and load that into the uefi boot location and it should work better.

    There is an alternative is to boot FOS Linux (bzImage kernel and init.xz virtual hard drive) directly from the usb stick bypassing the ipxe boot loaders all together. There are some drawbacks using this method, but for normal imaging with FOG it will work well. I have a starter image created that will take you to step 7 in the tutorial, all you will need to do is use RUFUS to “burn” the image to the usb flash drive and then update the grub.cfg file. There are some caveats with this method so be mindful of them if you go this route.

Log in to reply