Compiling custom kernel and running into problems



  • I’m trying to get FOG basics like host registration and debug mode working for some machines based on AMD E350 and the default kernels provided aren’t working for me. Even though I’ve tried acpi=off nomodeset, I still get a static snow screen when booting from the kernels provided.

    I’ve tried some kernels that people have compiled here to work with AMD video cards, and I can at least get to a shell in debug mode, but it fails to load drivers for the network and storage components.

    So I tried compiling my own kernels. Watching the output when booting in debug mode, I can see that the network and storage drivers are coming up correctly, but I end up with kernel panic before being dropped to a shell. Compiling from one system, I keep getting “runaway loop modprobe binfmt-464c”, whether I tried using “make ARCH=i386…” or not…which didn’t make much sense to me. I’ve tried compiling on another system, also using “make ARCH=i386…” and without, and I’m still getting kernel panic but without the modprobe loop. The messages before kernel panic look like this:

    RAMDISK: gzip image found at block 0
    VFS: mounted root (ext2 filesystem) on device 1:0.
    Freeing unused kernel memory: 436k freed
    Kernel panic - not syncing. No init found…

    Any help would be appreciated. Thank you.



  • Well, I fixed my problem by ditching the kitchensink.config in favor of the core.config.

    I wonder what was in the kitchensink.config that was messing things up.

    I also wonder why, if my drivers are already selected in fog’s core.config, they were not properly loading when using a kernel compiled by the fog project.


Log in to reply
 

366
Online

38982
Users

10712
Topics

101679
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.