Exit boot options



  • Hello!

    I have solidified the functionality on Macs at my office environment and now I am moving onto migrating our Linux workstations.

    When I boot into FOG and no task is scheduled, it then boots into the hard drive.

    Although this is where the issue is.

    When FOG exits with the Host BIOS/EFI Exit:

    • Type of “GRUB” grub.exe … ok | Could not boot: Exec format error)
    • Type of “SANBOOT”: “Boot from SAN device failed” (expected)
    • Type of “GRUB_FIRST_HDD”: grub.exe … ok | Could not boot: Exec format error)
    • Type of “GRUB_FIRST_CDROM”: grub.exe … ok | Could not boot: Exec format error)
    • Type of “GRUB_FIRST_WINDOWS”: grub.exe … ok | Could not boot: Exec format error)
    • Type of “REFIND_EFI”: Boots into rEFInd fine, but this is being used for Macs with a default_selection 3.
      ** When I attempt to use default_selection "Boot Fallback,3" or default_selection Fallback,3 or any mixture of it to change the selection it does not auto-select in order but always selections option 3 (which MacOS are using)
    • Type of “EXIT”: Chainloading fails and I am thrown back to iPXE shell which results in a bootloop.

    What am I doing incorrectly on my refind.conf for it to not select the proper ordered default_selection options I have entered? I wish to have it boot either option

    I have attached the refind bootscreen for reference, it is highlighting “4” as I have to hit the down arrow to stop the autoboot timer.

    alt text



  • I was editing the wrong refind.conf file in another location.

    /var/www/fog/service/ipxe/refind.conf

    vs my other refind.conf for Macs chainloader

    /tftpboot/fog/refind.conf



  • okay thanks for the reply



  • I was editing the wrong refind.conf file in another location.

    /var/www/fog/service/ipxe/refind.conf

    vs my other refind.conf for Macs chainloader

    /tftpboot/fog/refind.conf


Log in to reply
 

285
Online

7.4k
Users

14.5k
Topics

136.5k
Posts