FOG 1.6, identified problems



  • Hello,
    I decided to install my new server to 1.6. It takes a lot of testers!
    My server is in Centos 8.0

    Here are some problems I had:

    • where could I dowload client installer from the web intreface ?

    • /tftpboot/default.ipxe is not updated in the web interface

    • I use advanced ipxe to access mdt server. I have a problem with accessing to advanced ipxe
      In legacy boot I get a black background with slider
      In UEFI, I get

    Could not boot! Exec format error (http://ipxe.org/2e008081)
    Chainloading failed. hit 's' for the iPXE shell
    


  • @Tom-Elliott Thank you! I can confirm this fixed the issue. Snap-ins are deploying successfully and the tasks are clearing.


  • Senior Developer

    @maverick2041 I found the issue and was able to add a fix for it.

    Please run a git pull and reinstall.

    Of the fix also 2 little features come in:

    A refresh button for the Data tables, so you can force a refresh of the data within the table being seen.

    Added whoami route to the API. This returns a json formatted string with the following information:

    {"ipaddress": "275.275.275.275", "hostname": "fogserver", "osid": "1", "osname": "Redhat", "installtype": "N"}
    

    The 275 is meant to ensure nobody guesses a proper IP.

    Hopefully this will allow snapins to work properly in 1.6



  • @Tom-Elliott No, for each tail I cancelled and re-queued a snapin, then restarted the FOGService on the target machine. Here is the output:

    tail -f /var/log/php-fpm/www-error.log
    ------
    (no changes)
    
    
    tail -f /var/log/httpd/error_log
    ------
    (no changes)
    
    
    tail -f /var/log/httpd/access_log
    ------
    
    Attempt #1
    172.16.16.11 - - [20/Nov/2019:11:41:15 -0500] "GET /fog/management/other/ssl/srvpublic.crt HTTP/1.1" 200 1769 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:41:15 -0500] "POST /fog/management/index.php?sub=requestClientInfo&authorize&newService HTTP/1.1" 200 326 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:41:15 -0500] "GET /fog/management/index.php?sub=requestClientInfo&configure&newService&json HTTP/1.1" 200 122 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:41:16 -0500] "GET /fog/management/index.php?sub=requestClientInfo&mac=84:A9:3E:1D:D2:11&newService&json HTTP/1.1" 200 937 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:41:16 -0500] "GET /fog/service/getversion.php?clientver&newService&json HTTP/1.1" 200 7 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:41:16 -0500] "GET /fog/service/getversion.php?newService&json HTTP/1.1" 200 9 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:41:16 -0500] "GET /fog/service/usertracking.report.php?action=login&user=testhost01%5CAdministrator&mac=84:A9:3E:1D:D2:11&newService&json HTTP/1.1" 200 105 "-" "-"
    
    Attempt #2
    172.16.16.11 - - [20/Nov/2019:11:47:05 -0500] "GET /fog/management/other/ssl/srvpublic.crt HTTP/1.1" 200 1769 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:47:05 -0500] "POST /fog/management/index.php?sub=requestClientInfo&authorize&newService HTTP/1.1" 200 326 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:47:05 -0500] "GET /fog/management/index.php?sub=requestClientInfo&configure&newService&json HTTP/1.1" 200 123 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:47:05 -0500] "GET /fog/management/index.php?sub=requestClientInfo&mac=84:A9:3E:1D:D2:11&newService&json HTTP/1.1" 200 937 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:47:06 -0500] "GET /fog/service/getversion.php?clientver&newService&json HTTP/1.1" 200 7 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:47:06 -0500] "GET /fog/service/getversion.php?newService&json HTTP/1.1" 200 9 "-" "-"
    172.16.16.11 - - [20/Nov/2019:11:47:06 -0500] "GET /fog/service/usertracking.report.php?action=login&user=testhost01%5CAdministrator&mac=84:A9:3E:1D:D2:11&newService&json HTTP/1.1" 200 105 "-" "-"
    
    

  • Senior Developer

    @maverick2041 Anything in the /var/www/php-fpm/www-error.log file?



  • @Sebastian-Roth That part is strange, the tasks just sit there forever after the response changes, though they do update to Checked In but never further. The duplicated instances under “Tasks > Active Snapin Tasks” stay as well. This was a fresh install starting with working-1.6 about a week ago and then a git pull after @Tom-Elliott fixed the snapin uploads in this thread. We have a totally separate 1.5.7 install that I use in production, but nothing has been taken from that server.


  • Developer

    @Tom-Elliott The response changes from Response No snapins to Response Success in the client logs, so it does seem it is piking them up. Though it’s strange there is no further output and the task is not finished.

    @maverick2041 Did you upgrade from dev-branch or an earlier working-1.6 version or from 1.5.7 or even earlier? Did those exact snapins` work before?



  • @Tom-Elliott No problem.

    11/19/2019 9:09 PM Main Overriding exception handling
     11/19/2019 9:09 PM Main Bootstrapping Zazzles
     11/19/2019 9:09 PM Controller Initialize
     11/19/2019 9:09 PM Controller Start
    
     11/19/2019 9:09 PM Service Starting service
     11/19/2019 9:09 PM Bus Became bus server
     11/19/2019 9:09 PM Bus Emmiting message on channel: Status
     11/19/2019 9:09 PM Service Invoking early JIT compilation on needed binaries
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:09 PM Client-Info Version: 0.11.16
     11/19/2019 9:09 PM Client-Info OS:      Windows
     11/19/2019 9:09 PM Middleware::Authentication Waiting for authentication timeout to pass
     11/19/2019 9:09 PM Middleware::Communication Download: http://fog.mydomain.com/fog/management/other/ssl/srvpublic.crt
     11/19/2019 9:09 PM Data::RSA FOG Server CA cert found
     11/19/2019 9:09 PM Middleware::Authentication Cert OK
     11/19/2019 9:09 PM Middleware::Authentication No token found at C:\Program Files (x86)\FOG\token.dat, this is expected if the client has not authenticated before
     11/19/2019 9:09 PM Middleware::Authentication ERROR: Could not get security token
     11/19/2019 9:09 PM Middleware::Authentication ERROR: Could not find file 'C:\Program Files (x86)\FOG\token.dat'.
     11/19/2019 9:09 PM Middleware::Communication POST URL: http://fog.mydomain.com/fog/management/index.php?sub=requestClientInfo&authorize&newService
     11/19/2019 9:09 PM Middleware::Response Success
     11/19/2019 9:09 PM Middleware::Authentication Authenticated
    
    
     11/19/2019 9:09 PM Middleware::Communication URL: http://fog.mydomain.com/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     11/19/2019 9:09 PM Middleware::Response Success
     11/19/2019 9:09 PM Middleware::Communication URL: http://fog.mydomain.com/fog/management/index.php?sub=requestClientInfo&mac=84:A9:3E:1D:D2:11&newService&json
     11/19/2019 9:09 PM Middleware::Response Success
     11/19/2019 9:09 PM Middleware::Communication URL: http://fog.mydomain.com/fog/service/getversion.php?clientver&newService&json
     11/19/2019 9:09 PM Middleware::Communication URL: http://fog.mydomain.com/fog/service/getversion.php?newService&json
    
     11/19/2019 9:09 PM Service Creating user agent cache
     11/19/2019 9:09 PM Middleware::Response Module is disabled on the host
     11/19/2019 9:09 PM Middleware::Response Module is disabled on the host
     11/19/2019 9:09 PM Middleware::Response Module is disabled globally on the FOG server
     11/19/2019 9:09 PM Service Initializing modules
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:09 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:09 PM Client-Info Client OS:      Windows
     11/19/2019 9:09 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:09 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:09 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:09 PM Client-Info Client OS:      Windows
     11/19/2019 9:09 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:09 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:09 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:09 PM Client-Info Client OS:      Windows
     11/19/2019 9:09 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:09 PM Middleware::Response Success
     11/19/2019 9:09 PM HostnameChanger Checking Hostname
     11/19/2019 9:09 PM HostnameChanger Renaming host to testhost01
     11/19/2019 9:09 PM HostnameChanger Joining domain
     11/19/2019 9:09 PM HostnameChanger Success, code =  0
     11/19/2019 9:09 PM Power Creating shutdown command in 60 seconds
     11/19/2019 9:09 PM Bus Emmiting message on channel: Power
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:09 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:09 PM Client-Info Client OS:      Windows
     11/19/2019 9:09 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:09 PM Middleware::Response No snapins
     11/19/2019 9:09 PM SnapinClient A power operation is pending, aborting module
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:09 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:09 PM Client-Info Client OS:      Windows
     11/19/2019 9:09 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:09 PM Middleware::Response Module is disabled on the host
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:09 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:09 PM Client-Info Client OS:      Windows
     11/19/2019 9:09 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:09 PM Middleware::Response Module is disabled globally on the FOG server
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:09 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:09 PM Client-Info Client OS:      Windows
     11/19/2019 9:09 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:09 PM Middleware::Response Module is disabled on the host
     11/19/2019 9:09 PM Middleware::Communication URL: http://fog.mydomain.com/fog/service/usertracking.report.php?action=login&user=HP-8AD8JIE0T2KC\Administrator&mac=84:A9:3E:1D:D2:11&newService&json
    ------------------------------------------------------------------------------
    
     11/19/2019 9:09 PM Service Sleeping for 116 seconds
     11/19/2019 9:10 PM Power Creating shutdown request
     11/19/2019 9:10 PM Power Parameters: /r /c "FOG needs to rename your computer" /t 0
     11/19/2019 9:10 PM Bus Emmiting message on channel: Power
     11/19/2019 9:10 PM Power Attempt 1/6 to shutdown computer
     11/19/2019 9:10 PM Power --> API call returned 1, will re-attempt in 5 minutes
     11/19/2019 9:10 PM Main Overriding exception handling
     11/19/2019 9:10 PM Main Bootstrapping Zazzles
     11/19/2019 9:10 PM Controller Initialize
     11/19/2019 9:10 PM Controller Start
    
     11/19/2019 9:10 PM Service Starting service
     11/19/2019 9:10 PM Bus Became bus server
     11/19/2019 9:10 PM Bus Emmiting message on channel: Status
     11/19/2019 9:10 PM Service Invoking early JIT compilation on needed binaries
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:10 PM Client-Info Version: 0.11.16
     11/19/2019 9:10 PM Client-Info OS:      Windows
     11/19/2019 9:10 PM Middleware::Authentication Waiting for authentication timeout to pass
     11/19/2019 9:10 PM Middleware::Communication Download: http://fog.mydomain.com/fog/management/other/ssl/srvpublic.crt
     11/19/2019 9:10 PM Data::RSA FOG Server CA cert found
     11/19/2019 9:10 PM Middleware::Authentication Cert OK
     11/19/2019 9:10 PM Middleware::Communication POST URL: http://fog.mydomain.com/fog/management/index.php?sub=requestClientInfo&authorize&newService
     11/19/2019 9:10 PM Middleware::Response Success
     11/19/2019 9:10 PM Middleware::Authentication Authenticated
    
    
     11/19/2019 9:10 PM Middleware::Communication URL: http://fog.mydomain.com/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     11/19/2019 9:10 PM Middleware::Response Success
     11/19/2019 9:10 PM Middleware::Communication URL: http://fog.mydomain.com/fog/management/index.php?sub=requestClientInfo&mac=84:A9:3E:1D:D2:11&newService&json
     11/19/2019 9:10 PM Middleware::Response Success
     11/19/2019 9:10 PM Middleware::Communication URL: http://fog.mydomain.com/fog/service/getversion.php?clientver&newService&json
     11/19/2019 9:10 PM Middleware::Communication URL: http://fog.mydomain.com/fog/service/getversion.php?newService&json
    
     11/19/2019 9:10 PM Service Creating user agent cache
     11/19/2019 9:10 PM Middleware::Response Module is disabled on the host
     11/19/2019 9:10 PM Middleware::Response Module is disabled on the host
     11/19/2019 9:10 PM Middleware::Response Module is disabled globally on the FOG server
     11/19/2019 9:10 PM Service Initializing modules
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:10 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:10 PM Client-Info Client OS:      Windows
     11/19/2019 9:10 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:10 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:10 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:10 PM Client-Info Client OS:      Windows
     11/19/2019 9:10 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:10 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:10 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:10 PM Client-Info Client OS:      Windows
     11/19/2019 9:10 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:10 PM Middleware::Response Success
     11/19/2019 9:10 PM HostnameChanger Checking Hostname
     11/19/2019 9:10 PM HostnameChanger Hostname is correct
     11/19/2019 9:10 PM HostnameChanger Attempting to join domain
     11/19/2019 9:10 PM HostnameChanger Host already joined to target domain
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:10 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:10 PM Client-Info Client OS:      Windows
     11/19/2019 9:10 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:10 PM Middleware::Response No snapins
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:10 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:10 PM Client-Info Client OS:      Windows
     11/19/2019 9:10 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:10 PM Middleware::Response Module is disabled on the host
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:10 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:10 PM Client-Info Client OS:      Windows
     11/19/2019 9:10 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:10 PM Middleware::Response Module is disabled globally on the FOG server
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:10 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:10 PM Client-Info Client OS:      Windows
     11/19/2019 9:10 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:10 PM Middleware::Response Module is disabled on the host
    ------------------------------------------------------------------------------
    
     11/19/2019 9:10 PM Service Sleeping for 110 seconds
     11/19/2019 9:12 PM Middleware::Communication URL: http://fog.mydomain.com/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     11/19/2019 9:12 PM Middleware::Response Success
     11/19/2019 9:12 PM Middleware::Communication URL: http://fog.mydomain.com/fog/management/index.php?sub=requestClientInfo&mac=84:A9:3E:1D:D2:11&newService&json
     11/19/2019 9:12 PM Middleware::Response Success
     11/19/2019 9:12 PM Middleware::Communication URL: http://fog.mydomain.com/fog/service/getversion.php?clientver&newService&json
     11/19/2019 9:12 PM Middleware::Communication URL: http://fog.mydomain.com/fog/service/getversion.php?newService&json
    
     11/19/2019 9:12 PM Service Creating user agent cache
     11/19/2019 9:12 PM Middleware::Response Module is disabled on the host
     11/19/2019 9:12 PM Middleware::Response Module is disabled on the host
     11/19/2019 9:12 PM Middleware::Response Module is disabled globally on the FOG server
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:12 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:12 PM Client-Info Client OS:      Windows
     11/19/2019 9:12 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:12 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:12 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:12 PM Client-Info Client OS:      Windows
     11/19/2019 9:12 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:12 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:12 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:12 PM Client-Info Client OS:      Windows
     11/19/2019 9:12 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:12 PM Middleware::Response Success
     11/19/2019 9:12 PM HostnameChanger Checking Hostname
     11/19/2019 9:12 PM HostnameChanger Hostname is correct
     11/19/2019 9:12 PM HostnameChanger Attempting to join domain
     11/19/2019 9:12 PM HostnameChanger Host already joined to target domain
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:12 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:12 PM Client-Info Client OS:      Windows
     11/19/2019 9:12 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:12 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:12 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:12 PM Client-Info Client OS:      Windows
     11/19/2019 9:12 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:12 PM Middleware::Response Module is disabled on the host
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:12 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:12 PM Client-Info Client OS:      Windows
     11/19/2019 9:12 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:12 PM Middleware::Response Module is disabled globally on the FOG server
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     11/19/2019 9:12 PM Client-Info Client Version: 0.11.16
     11/19/2019 9:12 PM Client-Info Client OS:      Windows
     11/19/2019 9:12 PM Client-Info Server Version: 1.5.7.757
     11/19/2019 9:12 PM Middleware::Response Module is disabled on the host
     11/19/2019 9:12 PM Middleware::Communication URL: http://fog.mydomain.com/fog/service/usertracking.report.php?action=login&user=testhost01\Administrator&mac=84:A9:3E:1D:D2:11&newService&json
    ------------------------------------------------------------------------------
    
     11/19/2019 9:12 PM Service Sleeping for 144 seconds
     11/19/2019 9:13 PM Controller Stop
     11/19/2019 9:13 PM Service Stop requested
     11/19/2019 9:13 PM Bus Emmiting message on channel: Status

  • Senior Developer

    @maverick2041 can you post the full log or at least the last 2 full iterations of checks? That should give us more context.



  • Did a ‘git pull’ and reinstall tonight of “working-1.6”. Host OS is CentOS 8 - 1905, Apache v2.4.37.

    A) It seems Snapins are not getting picked-up.

    1. Select Host > Tasks > Advanced > Single Snapin > (choose snapin) > Immediate > Create
    2. “Creating task succeeded”
    3. Tasks > Active Tasks — see “Single Snapin” is queued, status “Checked In”
    4. FOG client log on target host (repeats):
      ---------------------------------SnapinClient---------------------------------
      11/19/2019 8:38 PM Client-Info Client Version: 0.11.16
      11/19/2019 8:38 PM Client-Info Client OS: Windows
      11/19/2019 8:38 PM Client-Info Server Version: 1.5.7.757
      11/19/2019 8:38 PM Middleware::Response Success

    1. No snapin deployed
    2. Snapin task remains in Tasks > Active Tasks
    3. 2x copies of task remain in Tasks > Active Snapin Tasks

    B) Choosing “Client Settings” menu from left column causes whole page to dim and then freeze. Reload of browser page required.

    Please let me know if there’s anything you’d like me to try/test.

    Thank you for all your hard work on FOG, the new interface is awesome.


  • Senior Developer

    It took some doing, but group module status’s will now be reflected in the group if all hosts in the group have the module associated, otherwise it will display as unchecked as we don’t know which hosts do/don’t have the modules applied.


  • Senior Developer

    @lebrun78 You should be able to update and have these items added to the hosts in question. I know it’s not displaying all the modules that are set on all hosts yet, but it does appear to be removing and adding the modules as needed. There is another minor issue that I’m still trying to narrow down, but it should still work at the least now.



  • @Tom-Elliott said in FOG 1.6, identified problems:

    I have identified a few more issues and been able to correct them.

    1. Clicking on pages within the menu as opposed to full refresh on the same page, some elements such as list -> select items to delete, click delete, the modal not appearing requesting password to ensure you want to do this. On full refresh to link it worked. On clicking from the menu it didn’t. Fixed by causing reinitialization.

    2. Import elements didn’t return proper notification items. Similarly warnings and info notifications always assumed error. This has been fixed

    3. Added rudimentary file upload progress system. Will be working to implement a progress indicator.

    4. Creating images when entering the name, the path didn’t auto populate. This has been re-implemented.

    5. Snapin file uploads were already set to be operational, but did not work due to typo on the POST field to send up the files. Renamed and introduced.

    6. Host export didn’t properly indicate the primac field. It didn’t even pull in the Mac at all and the values were improper. The host name appeared in description, and name field was the spot Mac was trying to populate. Added the primac field and properly pulling the data now.

    7. Along with the reinitialization for the modal requesting passwords, this same reinitialization was causing table populating to be reinitialization and throw an error as it already existed. Set to retrieve so not to throw the error.

    What a job, thank you very much !

    When I edit a group, I can’t set module association in client module settings


  • Senior Developer

    Added very rudimentary progress bar for file uploads.

    e0659c1e-8182-4d35-b90a-7b69e92604c8-image.png

    Just an example. It auto updates and removes itself when complete. I just have it appended below the file input information.

    Yay, progress bars.


  • Senior Developer

    I have identified a few more issues and been able to correct them.

    1. Clicking on pages within the menu as opposed to full refresh on the same page, some elements such as list -> select items to delete, click delete, the modal not appearing requesting password to ensure you want to do this. On full refresh to link it worked. On clicking from the menu it didn’t. Fixed by causing reinitialization.

    2. Import elements didn’t return proper notification items. Similarly warnings and info notifications always assumed error. This has been fixed

    3. Added rudimentary file upload progress system. Will be working to implement a progress indicator.

    4. Creating images when entering the name, the path didn’t auto populate. This has been re-implemented.

    5. Snapin file uploads were already set to be operational, but did not work due to typo on the POST field to send up the files. Renamed and introduced.

    6. Host export didn’t properly indicate the primac field. It didn’t even pull in the Mac at all and the values were improper. The host name appeared in description, and name field was the spot Mac was trying to populate. Added the primac field and properly pulling the data now.

    7. Along with the reinitialization for the modal requesting passwords, this same reinitialization was causing table populating to be reinitialization and throw an error as it already existed. Set to retrieve so not to throw the error.


  • Senior Developer

    @lebrun78 All import elements should be functional now if you run a git pull and reinstall.


  • Senior Developer

    @lebrun78 The thing is I don’t know what is or isn’t.

    For what it’s worth, I just updated the code base so you should be able to import images now.
    I’ll be working throughout the day to get all the import elements functional.



  • @Tom-Elliott said in FOG 1.6, identified problems:

    @lebrun78

    Cool, thank you for that. This feature has not been implemented yet. Here’s the code behind the scenes, so it is a known thing and needs to be worked. I’m only one person though…

    Could you tell me which features are not implemented todoy, so I will be able to test all the others ?


  • Senior Developer

    @lebrun78

    Cool, thank you for that. This feature has not been implemented yet. Here’s the code behind the scenes, so it is a known thing and needs to be worked. I’m only one person though…

    (function($) {
        var importFile = $('#importfile'),
            importForm = $('#import-form'),
            importFormBtn = $('#import-send');
        importForm.on('submit', function(e) {
            e.preventDefault();
        });
        importFormBtn.on('click', function() {
            importFormBtn.prop('disabled', true);
            // TODO: Start uploading file.
            // Send for processing.
            // complete data set and reset our layout.
            importFormBtn.prop('disabled', false);
        });
    })(jQuery);


  • @Tom-Elliott said in FOG 1.6, identified problems:

    @lebrun78 What do you mean no image imported?

    There should be another log file that’s handling the php stuff. Usually called /var/log/php-fpm/www-error.log

    The error.log from php-fpm is specifically error’s and processes starting dealing only with the php-fpm service. The www-error.log is the errors php-fpm is seeing from the php code passed by the browser.
    The is only one line in www-error.log:

    cat /var/log/php-fpm/www-error.log

    [14-Nov-2019 10:03:13 UTC] PHP Warning:  socket_strerror() expects parameter 1 to be integer, string given in /var/www/html/fog/lib/router/route.class.php on line 570
    

    Either way, “no image imported” means what? The definitions weren’t created? The physical image data didn’t import to the fog server?

    No definition created


Log in to reply
 

469
Online

6.3k
Users

13.8k
Topics

129.9k
Posts