DHCP works but no internet to clients



  • okay I got fog set up, DHCP is giving out IP and booting to the fog menu. I’m using a server with two NICs
    one is connected to my work network for internet, the second is on a separate switch to provide imaging and internet to client machines ( we use an isolated network for imaging of new machines)
    I can ping from and remote in tothe server so I know its getting a network connection, just for whatever reason its not serving the connection through the second NIC along with the DHCP. I Feel like there needs to be something else in the DHCP config file, I just cant figure out what to put in there. This is on Fedora 30 with the latest Fogserver from github. (as of Oct 25 2019)

    This is my current DHCPD config

    # DHCP Server Configuration file\n#see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    #Definition of PXE-specific options
    # Code 1: Multicast IP Address of bootfile
    # Code 2: UDP Port that client should monitor for MTFTP Responses
    # Code 3: UDP Port that MTFTP servers are using to listen for MTFTP requests
    # Code 4: Number of seconds a client must listen for activity before trying
    #         to start a new MTFTP transfer
    # Code 5: Number of seconds a client must listen before trying to restart
    #         a MTFTP transfer
    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16;
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    # Specify subnet of ether device you do NOT want service.
    # For systems with two or more ethernet devices.
    # subnet 136.165.0.0 netmask 255.255.0.0 {}
    subnet 192.168.1.0 netmask 255.255.255.0{
        option subnet-mask 255.255.255.0;
        range dynamic-bootp 192.168.1.10 192.168.1.254;
        default-lease-time 21600;
        max-lease-time 43200;
       # option routers 192.168.1.1
        option domain-name-servers 8.8.8.8;
        next-server 192.168.1.1;
        class "Legacy" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:>
            filename "undionly.kkpxe";
        }
        class "UEFI-32-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:>
            filename "i386-efi/ipxe.efi";
     }
        class "UEFI-32-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:>
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-64-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:>
            filename "ipxe.efi";
        }
        class "UEFI-64-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:>
            filename "ipxe.efi";
        }
        class "UEFI-64-3" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:>
            filename "ipxe.efi";
        }
        class "SURFACE-PRO-4" {
            match if substring(option vendor-class-identifier, 0, 32) = "PXEClient:>
            filename "ipxe.efi";
     }
        class "Apple-Intel-Netboot" {
            match if substring(option vendor-class-identifier, 0, 14) = "AAPLBSDPC/>
            option dhcp-parameter-request-list 1,3,17,43,60;
            if (option dhcp-message-type = 8) {
                option vendor-class-identifier "AAPLBSDPC";
                if (substring(option vendor-encapsulated-options, 0, 3) = 01:01:01)>
                    # BSDP List
                    option vendor-encapsulated-options 01:01:01:04:02:80:00:07:04:8>
                    filename "ipxe.efi";
                }
            }
        }
    }
    #END OF DHCPD.conf
    

    #AND this is my current NIC config(I stared out part of the IP because its my works IP from our ISP and you know, I don’t want to be the guy that gave the IP to the world.)

    #This is the connection that gets internet from the network and allows remote connection for managing the server

    eno1: connected to eno1
            "Intel 82579V"
            ethernet (e1000e), *C:*2:*9:20:CE:B0, hw, mtu 1500
            ip4 default
            inet4 ***.***.215.106/24
            route4 ***.***.215.0/24
            route4 0.0.0.0/0
            inet6 fe80::c**f:c9dd:**6f:d2bd/64
            route6 fe80::/64
            route6 ff00::/8
    

    #This is the connection that DHCP is served to

    enp3s0: connected to enp3s0
            "Intel 82574L"
            ethernet (e1000e), **:0*:CA:2C:5D:45, hw, mtu 1500
            inet4 192.168.1.1/24
            route4 192.168.1.0/24
            inet6 fe80::f111:****:3679:****/64
            route6 fe80::/64
            route6 ff00::/8
    
    lo: unmanaged
            "lo"
            loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536
    
    DNS configuration:
            servers: ***.***.37.20
            interface: eno1
    
            servers: ***.***.37.20
            interface: enp3s0


  • Figured it out, re running the fog installer after messing with the passwords etc reset my option routers in the dhcpd.conf file.



  • and now my routing has stopped working again. did’nt notice it because i had to step away for a bit, but the test machine that just imaged has no network access. I also tried another machine that is a known good one and its not getting network either. I can ping the 192.168.1.1 just fine, PXE booting still works, its just now not routing. I mean its better than nothing we can get by with out network on this if it comes down to it. Thank you to every one who has helped me so far.


  • Moderator

    @davidka Just as an FYI, only the capture uses FTP. The deployment should work just fine. As for the upload residue, you can safely delete the directories that appear as mac address in /images/dev. You can also salvage the upload too but it will take a little manual activity.



  • @george1421 okay so setting that to NO seems to have done the trick. I can log in to ftp now, and the image capture successfully put the finished image in the images dir. I am now doing my first image restore to a test machine, its looking promising ^_^


  • Developer

    @davidka @george1421 We removed the tcp_wrapper= option from vsftpd.conf in our install scripts just recently because it caused an issue with CentOS 8. It’s very unfortunate that no one noticed this to be an issue in Fedora 30 as well. Just remove the line from the config, restart your FOG server and things should be working.


  • Moderator

    @davidka While I’m a bit baffled why its set. One link I found said to edit vsftpd.confg (should be some place under /etc) and remove or comment out the tcp_wrappers statement.

    Edit: Actually I think it needs to be tcp_wrappers=no the default may be yes



  • @george1421 Fedora 30


  • Moderator

    @davidka said in DHCP works but no internet to clients:

    500 OOPS: tcp_wrappers is set to YES but no tcp wrapper support compiled in

    what is the OS distro FOG is running on?



  • @george1421

    tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN
    

    thats what that gave me.

    and this

    ftp> open ***.***.215.106
    Connected to ***.***.215.106.
    500 OOPS: tcp_wrappers is set to YES but no tcp wrapper support compiled in
    Connection closed by remote host.
    

  • Moderator

    @davidka Well there is a tutorial I have on resyncing all of the password locations that you can run through. You can change the password to what ever you like as long as its secure and consistent. https://forums.fogproject.org/topic/11203/resyncing-fog-s-service-account-password

    Looking at your other posts it appears you do have the imaging lan nic set to 192.168.1.1 (at least in your OP).

    From your fog server you can run this command to see if the ftp server is running. netstat -an | grep ":21" should show you the ftp server is up and running.

    From either the imaging network or from your business network you should be able to connect to the ftp server on the FOG server using a windows computer and the ftp command line client. Again the password will be what is found in /opt/fog/.fogsettings file once you resync all of the passwords. If you can log in via ftp to the fog server then we will dig elsewhere.



  • @george1421 I went into all the config files and changed it. didnt realize it was a big deal. But it was messing up even before I did that. do I need to run the fog installer again ?

    I’ve got two NICs one is 192.168.1.1 for DHCP on an isolated network the other is ***.***.215.106 this one has access to the rest of the schools network and assigned by my sysadmin. I needed to be able to remote into the server and supply intert the clients at the same time, so I have it configured to route the traffic from 192.168.1.1 through IP tables and NAT to the 215.106 interface.

    My sysadmin does not want DHCP to the rest of the network, hence the utterly complex setup i’m trying to pull off. I’ve tryed to explain to him that FOG wants to be part of the main network, and is expecting a DHCP server to already be setup, etc. But at this time he don’t want that. Its a whole other rant for another time… (we are manually updating everything, not using SCCM or any thing…)


  • Moderator

    @davidka said in DHCP works but no internet to clients:

    the 192.168.1.1 is my DHCP pool the server IP is different. it ends in 215.106

    You are going to have to explain how you have things setup, because from your picture the client is trying to connect to 192.168.1.1

    I’m also concerned about this statement

    I’ve changed that password in all its locations to a custom password

    What does that mean? The fogproject service account is owned and managed by the fog installer. Its password shouldn’t be touched.



  • @george1421 I’ve changed that password in all its locations to a custom password. (but it was messing up before I did that though) and no it doesn’t connect.

    Okay so I changed it to port 21 and got this

    Connect socket #1760 to ***.***.215.106, port 21...
    500 OOPS: tcp_wrappers is set to YES but no tcp wrapper support compiled in  
    Can't establish connection --> ***.***.215.106:21 @ Tue Nov 05 15:12:53 2019   (0-
    

    the 192.168.1.1 is my DHCP pool the server IP is different. it ends in 215.106



  • @Sebastian-Roth 22 is just was in the blank be default. I’m not sure what port it should be.


  • Moderator

    @davidka From your windows computer, can you ftp to 192.168.1.1 (your fog server I guess) with the user name of fogproject and the password found in /opt/fog/.fogsettings ? it will be a random long password. If you can connect via FTP from a windows computer then we have something else going wrong.


  • Developer

    @davidka said in DHCP works but no internet to clients:

    Connect socket #1904 to ***.***.215.106, port 22…

    Port 22 is SSH/SCP not FTP?!


  • Moderator

    @davidka Hmmm did someone play (test) with iptables that may be blocking ftp access? </snark>



  • @Sebastian-Roth when I try to connect using an ftp client (coreftp) it gives me this:```

    Connect socket #1904 to ***.***.215.106, port 22...
    Can't establish connection --> ***.***.215.106:22 @ Tue Nov 05 14:38:50 2019   (0-38)
    Connection Failed
    

    I started out the first part of my IP as that is a a private IP for our school.


  • Developer

    @davidka This Type: 1024 error is probably caused by a connection issue. We often have people post a similar picture but with authentication error. Here I guess it’s a connection thing. From the network where you have your hosts can you open a FTP connection from any of the clients (e.g. use WinSCP or FileZilla)? Username is fogproject and the password you find in /var/www/html/fog/lib/fog/config.class.php on your FOG server.


Log in to reply
 

438
Online

6.3k
Users

13.7k
Topics

129.0k
Posts