NXtop Noob Question



  • Hi, first let me mention that i am very new to Linux and imaging (like, i just installed ubuntu for the first time).

    I managed to get the fog server itself up and running. Now i tried to add the NXtop client engine to the fog menu, but whatever link i follow, it just won’t start.

    I am pretty sure i made a mistake somewhere but i just don’t know where.

    I downloaden de nxtop engine, extracted the files and copied them to the locations:

    -mboot.c32 -> /tftpboot
    -vmlinuz , initrd.img, xen.gz /tftpboot/nxtop41
    -nxtopengine.iso -> /var/www (also tried /var/www/fog/)

    then i did edit the file /tftpboot/pxelinux.cfg/default and add those lines:

    LABEL NxTop Engine Install
    kernel mboot.c32
    append nxtop41/xen.gz — nxtop41/vmlinuz boot=casper webboot=[url]http://ip-of-webserver/nxtopengine.iso[/url] ro — nxtopengine/initrd.img –

    I can see the entry in the boot menu, but when i hit it, nothing happens.

    Anyone got any idea (or maybe idiot proof step by step) ? I allready read the documentation in the wiki for adding any iso file and adding third party software but i allways have the feeling im missing something.

    Any help would be greatly appreciated.

    EDIT 27-11-2012

    Looks like i cant get any iso to work.
    I did append anything from UBCD to Kaspersky live CD and cant start any iso at all.

    Im pretty sure im storing de different files in the wrong locations or something.

    The Menu entries appear, but when i select them, nothing happens.



  • I’ve solved the problem myself. It seems that the machine i was using for testing is not compatible.
    I have just tested with two different models and all works well.

    The incompatible model is a Lenovo A70z (1165-ABG). The config im using is:

    LABEL NXTOP 41 Engine Installer
    MENU NXTOP 41 Engine Installer
    kernel mboot.c32
    append fog/nxtop41/xen.gz — fog/nxtop41/vmlinuz boot=casper webboot=[url]http://ip-of-server/fog/nxtop41/nxtopengine.iso[/url] ro quiet console=tty8 — fog/nxtop41/initrd.img –

    Maybe someone else has any use of this information.



  • well, seems that noone else is using this …



  • Not sure who is reading this beside me but maybe my notes are some help for others who try to get this working.

    I still cant get the iso to boot. Currently having those lines in default config:

    LABEL NXTOP Engine Install
    kernel mboot.c32
    append nxtop41/xen.gz dom0_mem=1024M — nxtop41/vmlinuz boot=casper webboot=[url]http://ip-of-webserver/nxtop41/nxtopengine.iso[/url] ro — nxtop41/initrd.img –
    MENU LABEL NXTOP Engine Install
    TEXT HELP
    Install NXTOP 4.1 Engine op Client
    ENDTEXT
    Anyone got an idea what might be wrong ?



  • OK, i told you im a noob.

    I solved the problem myself. It seems that the tftp user and password were wrong.

    It took me a while to understand that the tftp user is the ubuntu root user that i had to define during initial install and not the user i use to log into management.
    I changed the username and password in the fog options screen and now i am able to select the boot option i added.

    NXtop still does not boot. It starts and then the test machine is caught in a boot loop. I think it is because im using the wrong startup parameters, but i’ll figure that out too sooner or later.


Log in to reply
 

430
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.