(407) Proxy Authentication Required.



  • Fog did rename the device but did not join it to the domain, anyone any ideas?

    26/09/2019 09:17 FOG::TaskReboot Sleeping for 1 minute.
    26/09/2019 09:17 FOG::SnapinClient Attempting to connect to fog server…
    26/09/2019 09:17 FOG::SnapinClient Failed to connect to fog server!
    26/09/2019 09:17 FOG::SnapinClient The remote server returned an error: (407) Proxy Authentication Required.
    26/09/2019 09:17 FOG::SnapinClient at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    at System.Net.WebClient.DownloadString(Uri address)
    at FOG.SnapinClient.startWatching()
    26/09/2019 09:17 FOG::SnapinClient Sleeping for 1 minute.
    26/09/2019 09:17 FOG::HostnameChanger Attempting to connect to fog server…
    26/09/2019 09:17 FOG::HostnameChanger Failed to connect to fog server!
    26/09/2019 09:17 FOG::HostnameChanger The remote server returned an error: (407) Proxy Authentication Required.
    26/09/2019 09:17 FOG::HostnameChanger at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    at System.Net.WebClient.DownloadString(Uri address)
    at FOG.HostNameChanger.changeHostName()
    26/09/2019 09:17 FOG::HostnameChanger Sleeping for 1 minute.
    26/09/2019 09:18 FOG::ClientUpdater Attempting to connect to fog server…
    26/09/2019 09:18 FOG::ClientUpdater Failed to connect to fog server!
    26/09/2019 09:18 FOG::ClientUpdater The remote server returned an error: (407) Proxy Authentication Required.
    26/09/2019 09:18 FOG::ClientUpdater at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    at System.Net.WebClient.DownloadString(Uri address)


  • Developer

    @Trev-lchs Did you ever solve this? I just stumbled upon this issue report which we got years ago: https://github.com/FOGProject/fog-client/issues/72



  • @Sebastian-Roth HI Sebastian, just to let you know that this is something internally that keeps setting a proxy server, a bit of software or GPO I am struggling like crazy to find it, but every time I change the proxy when I log in , it is there again. I can find no GPO that is responsible, an absolute mystery to me, Microsoft and our third line support, but we will get there eventually or die trying.


  • Developer

    @Trev-lchs said in (407) Proxy Authentication Required.:

    However on a win 10 PC it went to the proxy. (10.10.1.7 is the proxy) how very frustrating.

    This is kind of strange. I have searched the web for keywords like “WebClient DownloadFile ignore bypass proxy” but have not found much yet. You might try searching for “Win 10 ignore proxy bypass”…



  • @Sebastian-Roth said in (407) Proxy Authentication Required.:

    http://x.x.x.x/fog/management/other/ca.cert.der

    this is windows 10, i typed this url on a win 7 PC and it used the proxy settings as expected and returned a Certificate to install. However on a win 10 PC it went to the proxy. (10.10.1.7 is the proxy) how very frustrating.

    196 4.133452 10.10.7.160 10.10.1.7 HTTP 366 GET http://10.10.1.26/fog/management/other/ca.cert.der HTTP/1.1


  • Developer

    @Trev-lchs Yes looks like it still calls out to the proxy. What Windows version is this?

    Try opening this URL in IE or Edge browser: http://x.x.x.x/fog/management/other/ca.cert.der (put in the correct FOG server IP instead of x.x.x.x)

    Watch this in Wireshark to see if it goes through the proxy or not!

    We might add this code to entirely ignore system proxy settings but I don’t think this is wise.



  • @Sebastian-Roth whoever on running wireshark just sniffing the network i do see this coming from the proxy, so looks like somehow the proxy settings are being ignored
    980 23.971899 10.10.1.7 10.10.7.160 HTTP 181 HTTP/1.1 407 Proxy Authentication Required (text/html)




  • Developer

    @Trev-lchs said in (407) Proxy Authentication Required.:

    please could you confirm the web root is /fog

    Yes, that’s right!

    no output it just seems to be waiting to do something

    As I said before your client obviously still uses your proxy server which doesn’t allow this connection without authentication.

    Please post a picture of the proxy settings!



  • @Sebastian-Roth no output it just seems to be waiting to do something

    root@fog-03:~# tail -f /var/log/apache2/access.log



  • @Sebastian-Roth yes that is the version i am trying to install. please could you confirm the web root is /fog


  • Developer

    @Trev-lchs said in (407) Proxy Authentication Required.:

    Hi, unfortunately i cannot get as far in the process as adding an IP in the new client it fails before that, i can with the old client, will that work?

    What exactly do you mean? When you run the most recent fog-client installer (version 0.11.16) it will step you through a couple of setup screens and one is where you enter the FOG server IP address and other information. Proceed till you get to that setup screen, enter the information and then start watching the access.log on the FOG server as mentioned below.



  • @Sebastian-Roth Hi, unfortunately i cannot get as far in the process as adding an IP in the new client it fails before that, i can with the old client, will that work?



  • @Sebastian-Roth OK will do thanks for the advice, i will get back to you once i have tried everything.


  • Developer

    @Trev-lchs Please post a picture of the Windows proxy settings here! Do you have a log file on your proxy server? If not, we can use the FOG server access log to verify if the new client really talks to your FOG server on install.

    • Get the installer ready on your client machine - up to the point where you have all the information like FOG IP address already typed in.
    • Login to your FOG server command shell and run tail -f /var/log/apache2/access.log - your should see the last 10 lines of the log file and it will update as soon as new log messages come in - hit ENTER a couple of times so you know where it started
    • Now proceed with the installer and keep an eye on the log on the FOG server.

    My guess is that you won’t see this clients’ requests as it get’s caught up in the proxy.



  • @Sebastian-Roth Proxy exceptions setting defo have the fog server excluded, still have the same error when trying to install the new client, the install goes through till it gets to Pinning Fog Server then a pop up titled “Fog Service Setup” with an error in the window “Unable to Install CA certificate”



  • @Trev-lchs I mean the fog server is an exception, fingers getting ahead of brain



  • @Sebastian-Roth Thanks Sebastian, fully understand the reason behind not supporting the old client, i will check the proxy settings although i an sure the proxy is an exception, i will let you know either way.


  • Developer

    @Trev-lchs I can imagine the “(407) Proxy Authentication Required” error coming from proxy settings you have on the client machine configured in Windows control panel -> internet settings -> connection settings. The .NET functions (System.Net.WebClient.DownloadDataInternal) probably use the Windows proxy settings but it fails to connect through the proxy because we don’t authenticate.

    What you need to do is add the FOG server IP to the list of addresses that don’t go through the proxy in Windows control panel -> internet settings -> connection settings. This might also fix the issues you have with the latest installer.

    We don’t fully support old versions as we don’t have the time to packport fixes. So if you stick with the old client you are on your own. We won’t fix any issue you find in the old client.



  • @Sebastian-Roth the error i get when trying to install the new fog client, the install goes through till it gets to Pinning Fog Server then a pop up titled “Fog Service Setup” with an error in the window “Unable to Install CA certificate”


Log in to reply
 

377
Online

6.4k
Users

13.8k
Topics

130.0k
Posts