• Hello fogproject community!

    The goal is to be able to PXE boot into the ESXI installer, and I have taken a liking to fogproject, also due to its open source nature, I really want to make it work. All I have found on the topic is an old post about ESXI 5.5 but that was not of much help as it seems that the contents of the iso have changed and I do not know what files are needed for it to boot or how to modify the boot.cfg in the root directory. I have extracted the iso image of the installer at /var/www/html/fog/isoimages/esxi67 and it tells me it cannot find the required files from my parameters here:

    Menu Item

    ESXI 6.7

    kernel -n mboot.c32 http://${next-server}/isoimages/esxi67/mboot.c32
    imgargs mboot.c32 -c http://${next-server}/isoimages/esxi67/boot.cfg

  • Senior Developer

    @nexx34 said in PXE Booting ESXI 6.7u2:

    Is it ever planned to make pxe booting “easier”?

    Any suggestions are welcome. 🙂

  • @george1421
    I guess it was a dumb question.
    I heard of things like “serva” (though I couldn’t even test them due to the horrible degree of trial-ware-ness the have) where you just put an iso in a directory. But I already understand that there are so many different isos and there is just no standard to them that it is impossible to have it universal. Maybe it’d be cool to have some sort of auto support for the most widespread things people want to PXE boot, but all it really hangs on for me is being able to properly follow instructions, as the wiki is already all that is needed. :^)
    I don’t want to spam this thread with off-topic questions. Again, thank you. Awesome that it works now, I understand that there is a balance between simplicity and flexibility, I was just wondering a little.

    Have a great day.

  • Moderator

    @nexx34 said in PXE Booting ESXI 6.7u2:

    Is it ever planned to make pxe booting “easier”?

    Can you explain what you mean by this? How could this be done, looking through your eyes? Just off the top of my head, there is always a sliding scale between easy to use and flexible to support most situations.

  • @george1421
    Yes, I will take this to heart, next time I have a problem in the future I will post shots right off the bat.
    And you are right, it is amazing what can be done with the project.
    Is it ever planned to make pxe booting “easier”?
    (Just asking for curiousity now, I read in another post, maybe it was even by you, that it is very much not desired to have something else other than the imaging aspect be developed to a major degree where it could detract from the former.)

  • Moderator

    @nexx34 That is the reason why both Sebastian and I say that pictures are important in that they show not only the error, but the context around the error. Something simple like a dot, semicolon, or extra character here or there can bring down the entire system.

    I’m glad you have it going and it show the flexibility of the FOG Project platform to do more than just its primary mission.

  • @george1421
    Oh god, that was it.
    Thanks for your unbelievable patience, I hope you aren’t mad at me now.
    The installer is booting. THANKS
    You woudln’t believe how happy I am right now.
    Now I just need to set up all the other images, what coud possibly go wrong? :^)
    Again, thank you very much, @george1421 for your amazing help, and you too, @Sebastian-Roth .

  • Moderator

    @nexx34 OK you have two ways to fix this.

    1. Remove the $ symbol in front of the 192 in each occurrence of $192

    2. Remove the address and replace it with ${fog-ip} where the iPXE menu will replace ${fog-ip} automatically with the IP address of the fog server.

  • @george1421

    Menu Item

    ESXI 6.7u2

    kernel nfs://$ -c nfs://$
    boot || goto MENU

    Menu Show with
    Alll Hosts

    Thanks very much for your fast reply!

  • Moderator

    @nexx34 In your infamous error picture, what is that character between 192 and nfs://?

    Please post the parameters section of the FOG Menu for this iPXE menu.

  • @george1421
    I have now tested this all on a more recent motherboard that is three years old.
    It worked in bringing me to the fog menu while having “uefi only” set for the LAN Boot option. Success!
    However, it still gives me that good old http://ipxe.org/err/3e11616e error code which redirects to http://ipxe.org/err/3e1161.
    This can be seen on my screenshot below:
    The infamous error:

    I linked the screenshots above, the dns address (my router) I get with <s> and <show dns> is correct by the way.

  • Senior Developer

    @nexx34 said in PXE Booting ESXI 6.7u2:

    what is making me wonder now is that afterfirst loading default.ipxe via tftp and the others (boot.php and bg.png) via http it all stops and nothing happens anymore, it just stays there.

    Can you take a picture of the messages on screen and post here?

  • Moderator

    @nexx34 Something isn’t right here.

    The process is supposed to flow this way.
    PXE rom requests dhcp boot options.
    DHCP server gives {next-server} and {boot-file} setting to target computer.
    Target computer downloads ipxe.efi
    Target computer runs ipxe.efi (at this point you should see the ipxe.efi banner)
    ipxe.efi chains to default.ipxe
    default.ipxe then calls boot.php
    boot.php should return the iPXE menu (you can view this menu by keying in http://<fog_server_ip>/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00)
    There is a line in the iPXE boot menu to load bg.png, but it has to have the iPXE menu to get that value.

    The just sits there part is confusing me. Lets have you post the iPXE menu using the path I provided. Lets see what it says. Post the results here in the thread.

  • @nexx34 @george1421 Well, I am testing a different computer now, it is a desktop this time, and it has gotten past the “Can’t get NBP” stage, what is making me wonder now is that afterfirst loading default.ipxe via tftp and the others (boot.php and bg.png) via http it all stops and nothing happens anymore, it just stays there.

  • @george1421 Okay, I will have to get such a PC real quick, looks like lenovo FW is shoddy all the way, because I was sure to enable the uefi option in the uefi menu.

  • Moderator

    @nexx34 said in PXE Booting ESXI 6.7u2:

    NBP is too big to fit in free base memory

    ok that is the sign that the target computer is in bios mode or at least bios compatibility mode. I would grab a different model of target computer and try again. That way you can rule out the fog side and just focus on the target system.

  • @george1421 Yes, it tells me what it had already told be before when I tried this, “NBP is too big to fit in free base memory”.
    I would take this is a client issue, but seeing how I had something along those lines in testing with a VM too, I really am clueless as to why it is happening…I mean, the machine I am testing now is halfway modern, it is a more recent lenovo.

  • @nexx34 Sorry for being a little bit spammy, for me the suspicion is mounting, that when I boot into fog, the client will not boot with uefi and instead takes the CSM regardless of the option being there in pfsense for the uefi files to load.

    @george1421 Okay, I will do that, let us see if it will accept booting fog with uefi enabled and the undionly crutch removed >:)

  • Moderator

    @nexx34 ok that is what I needed to know. If the esxi and fog setup is exact then lets focus on pfsense. Set all (2) non-i386 values to ipxe.efi. Yes I know this will break the bios boot systems, but for testing we need to understand if its an iPXE issue or a target system issues (note you might need to make sure the firmware is up to date on those lenovos, they have been known to have a very cruddy first gen bios/firmware)

  • @george1421 Nope, I followed them exactly, I think the problem really lies at the entries about undionly/ipxe.efi/etc in the pfsense dhcp settings, as when using legacy boot it works (but fails to load the esxi image, as that is efi) but that is just what I am guessing right now.