Tfpp time out



  • System: Ubuntu 12.04 LTS Desktop
    FOG: 0.32 w/Kernel (Version that came with 0.32 download)

    This was working fine then we lost power. Now when the server reboots the dhcp server (administered by the fog server) will not start. I have to manually start it. Then tftp times out:

    /etc/init.d/isc-dhcp-server start
    *Server starts accepting dhcp clients.

    *Testing tftp:
    -Command:
    tftp -v 192.168.1.24 -c get pxelinux.0

    *Result:
    Connected to 192.168.1.24 (192.168.1.24), port 69 getting from 192.168.1.24 xelinux.0 to pxelinux.0 [netascii] [B]Transfer timed out.[/B]

    I used the gui to enable and siable the ubuntu firewall as well with same results. Have tried fog on it’s own switch standalone from network between client and fog server. Also changed the tftp password, fog password and the password to in storage management node to the same pass just to test with same result. This was working before we lost power.

    Also when I try to download a new kernel (3.3.3 Core FOG ID: 1049) it downloads and then gives me error: Unable to connect to tftp server. This puzzles me because according to the tftp check it was able to connect to the tftp server @ 192.168.1.24. COuld this be related to a file permission corruption after the power loss? How can I start the tftp server service?

    Any help would be awesome.

    *Edit:
    Was able to start the tftp service with command:
    start xinetd
    *Result: xinetd start/running, process 3164
    Kernel still produces same error.

    *Edit #2:
    Gave \tftpboot\fog\Kernel full folder permissions as well
    Same error in kernel update.

    *Edit #3:
    Reset the passwords again just incase and now I can download the kernels and install them but still cannot get the client to connect to server and bring up the fog screen…


Log in to reply
 

447
Online

39174
Users

10821
Topics

102951
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.