Please Wait...



  • Ubuntu 10.4.4 LTS
    fog .32

    During fog instillation no mysql password was set for all 3 options

    unicast works perfectly

    multicast task disappears in 5 seconds but i can get it to start if i start it when the computer is waiting for a task. than it blue screens at please wait.

    if i change the 2 config files in:
    /var/www/fog/commons
    /opt/fog/service/etc

    i can no longer connect to the database though the web ui.

    i need this working please help



  • There is not an easy way that i’m aware of. But in the web settings(FOG_WOL_INTERFACE, FOG_UDPCAST_INTERFACE, FOG_NFS_ETH_MONITOR) and in the two config files switch all the eth0’s with eth1’s. And restart the FOGMulticastManager and FOGScheduler.

    There may be more you need ot edit for each of the services if they are configured to listen on only one interface.

    I havn’t tried this but perhaps editing “/etc/udev/rules.d/70-persistent-net.rules” and swapping the eth0 and eth1 for the devices, then rebooting would swap which one is which. This may break other things that are depending on specific interfaces though(other services/uses for the server).



  • also is there an easy way to switch eth0 with eth1? i need it on 1 and not 0



  • yes thank you very veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery veryvery very much



  • Is it working successfully now?



  • [CODE][11-09-12 9:18:10 am] * [11-09-12 9:18:10 am] I am the group manager.
    [11-09-12 9:18:10 am] | [11-09-12 9:18:10 am] Task (6) multicast today test is new!
    [11-09-12 9:18:10 am] | [11-09-12 9:18:10 am] Task (6) multicast today test image file found.
    [11-09-12 9:18:10 am] | [11-09-12 9:18:10 am] Task (6) multicast today test 2 clients found.
    [11-09-12 9:18:10 am] | [11-09-12 9:18:10 am] Task (6) multicast today test sending on base port: 63110
    [11-09-12 9:18:10 am] CMD: gunzip -c “/images/win7dual2/d1p1.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63110 --interface eth0 --half-duplex --ttl 32 --nokbd;gunzip -c “/images/win7dual2/d1p2.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63110 --interface eth0 --half-duplex --ttl 32 --nokbd;gunzip -c “/images/win7dual2/d1p3.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63110 --interface eth0 --half-duplex --ttl 32 --nokbd;
    [11-09-12 9:18:15 am] | [11-09-12 9:18:15 am] Task (6) multicast today test has started.
    [11-09-12 9:18:25 am] * [11-09-12 9:18:25 am] Checking if I am the group manager.
    [11-09-12 9:18:25 am] * [11-09-12 9:18:25 am] I am the group manager.
    [11-09-12 9:18:35 am] * [11-09-12 9:18:35 am] Checking if I am the group manager.
    [11-09-12 9:18:35 am] * [11-09-12 9:18:35 am] I am the group manager.[/CODE]



  • the network cable was switched to the second nic which was eth1 it is now back to eth0



  • [CODE]root@T412-fogserver:/# tail -f /opt/fog/log/multicast.log.udpcast*
    tail: cannot open /opt/fog/log/multicast.log.udpcast*' for reading: No such file or directory tail: no files remaining root@T412-fogserver:/# tail -f /opt/fog/log/multicast.log.udpcast tail: cannot open/opt/fog/log/multicast.log.udpcast’ for reading: No such file or directory
    tail: no files remaining
    [/CODE]



  • You typed in upcast, it is supposed to be udpcast.
    [CODE]tail -f /opt/fog/log/multicast.log.udpcast*[/CODE]

    Post #13 suggests there is an issue starting UDPcast, Is eth0 the correct interface and is not disabled? Do you have SE Linux or a firewall running?

    Run this (taken from the multicast log in post #13)and see what error it gives you
    [CODE] gunzip -c “/images/win7dual2/d1p1.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;gunzip -c “/images/win7dual2/d1p2.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;gunzip -c “/images/win7dual2/d1p3.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;[/CODE]



  • [CODE]root@T412-fogserver:/# tail -f /opt/fog/log/multicast.log.upcast*
    tail: cannot open `/opt/fog/log/multicast.log.upcast*’ for reading: No such file or directory
    tail: no files remaining[/CODE]

    [CODE]root@T412-fogserver:/# tail -f /opt/fog/log/multicast.log
    [11-09-12 8:57:51 am] * [11-09-12 8:57:51 am] Checking if I am the group manager.
    [11-09-12 8:57:51 am] * [11-09-12 8:57:51 am] I am the group manager.
    [11-09-12 8:58:01 am] * [11-09-12 8:58:01 am] Checking if I am the group manager.
    [11-09-12 8:58:01 am] * [11-09-12 8:58:01 am] I am the group manager.
    [11-09-12 8:58:11 am] * [11-09-12 8:58:11 am] Checking if I am the group manager.
    [11-09-12 8:58:11 am] * [11-09-12 8:58:11 am] I am the group manager.
    [11-09-12 8:58:21 am] * [11-09-12 8:58:21 am] Checking if I am the group manager.
    [11-09-12 8:58:21 am] * [11-09-12 8:58:21 am] I am the group manager.
    [11-09-12 8:58:31 am] * [11-09-12 8:58:31 am] Checking if I am the group manager.
    [11-09-12 8:58:31 am] * [11-09-12 8:58:31 am] I am the group manager.
    [/CODE]

    [CODE]root@T412-fogserver:/# tail -f /opt/fog/log/multicast.log.upcast
    tail: cannot open `/opt/fog/log/multicast.log.upcast’ for reading: No such file or directory
    tail: no files remaining
    [/CODE]

    the machines i am testing on are still on the please wait screen



  • if it isn’t working , could you also check the udpcast log , to see if clients are connecting successfully or not.

    [CODE]tail -f /opt/fog/log/multicast.log.udpcast*[/CODE]



  • still does not work



  • changed both configs back to 127.0.0.1 and i now get new messages in the multicast log file.

    [CODE][11-09-12 8:49:20 am] * [11-09-12 8:49:20 am] I am the group manager.
    [11-09-12 8:49:20 am] | [11-09-12 8:49:20 am] Task (4) multicast today test is new!
    [11-09-12 8:49:20 am] | [11-09-12 8:49:20 am] Task (4) multicast today test image file found.
    [11-09-12 8:49:20 am] | [11-09-12 8:49:20 am] Task (4) multicast today test 2 clients found.
    [11-09-12 8:49:20 am] | [11-09-12 8:49:20 am] Task (4) multicast today test sending on base port: 63106
    [11-09-12 8:49:20 am] CMD: gunzip -c “/images/win7dual2/d1p1.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;gunzip -c “/images/win7dual2/d1p2.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;gunzip -c “/images/win7dual2/d1p3.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;
    [11-09-12 8:49:25 am] | [11-09-12 8:49:25 am] Task (4) multicast today test failed to start!
    [11-09-12 8:49:25 am] | * Don’t panic, check all your settings!
    [11-09-12 8:49:25 am] | even if the interface is incorrect the task won’t start.
    [11-09-12 8:49:25 am] | If all else fails run the following command and see what it says:
    [11-09-12 8:49:25 am] | gunzip -c “/images/win7dual2/d1p1.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;gunzip -c “/images/win7dual2/d1p2.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;gunzip -c “/images/win7dual2/d1p3.img” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 63106 --interface eth0 --half-duplex --ttl 32 --nokbd;
    [11-09-12 8:49:25 am] | [11-09-12 8:49:25 am] Task (4) multicast today test has been cleaned.
    [11-09-12 8:49:35 am] * [11-09-12 8:49:35 am] Checking if I am the group manager.
    [11-09-12 8:49:35 am] * [11-09-12 8:49:35 am] I am the group manager.
    [11-09-12 8:49:45 am] * [11-09-12 8:49:45 am] Checking if I am the group manager.
    [11-09-12 8:49:45 am] * [11-09-12 8:49:45 am] I am the group manager.
    [11-09-12 8:49:55 am] * [11-09-12 8:49:55 am] Checking if I am the group manager.
    [11-09-12 8:49:55 am] * [11-09-12 8:49:55 am] I am the group manager.
    [11-09-12 8:50:05 am] * [11-09-12 8:50:05 am] Checking if I am the group manager.
    [11-09-12 8:50:05 am] * [11-09-12 8:50:05 am] I am the group manager.[/CODE]



  • System error 111 is connection refused. Is your MySQL server configured to allow connections from IP’s other than 127.0.0.1? Does using define( “MYSQL_HOST”, “127.0.0.1” ); allow the PHP code to connect?

    That IP should almost always be 127.0.0.1 or localhost, since each invidual client does not actually connect to the MySQL server themselves.



  • i tried changing the /etc/hosts

    127.0.0.1 localhost
    192.168.155.69 T412-fogserver

    and still no luck



  • define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “824561” );
    define( “DB_TYPE”, “mysql” );
    define( “DB_HOST”, MYSQL_HOST );
    define( “DB_NAME”, MYSQL_DATABASE );
    define( “DB_USERNAME”, MYSQL_USERNAME );
    define( “DB_PASSWORD”, MYSQL_PASSWORD );

    define( “UPDSENDERPATH”, “/usr/local/sbin/udp-sender” );
    define( “MULTICASTLOGPATH”, “/opt/fog/log/multicast.log” );
    define( “MULTICASTDEVICEOUTPUT”, “/dev/tty2” );
    define( “MULTICASTSLEEPTIME”, 10 );
    define( “MULTICASTINTERFACE”, “eth0” );
    define( “UDPSENDER_MAXWAIT”, null );

    define( “MYSQL_HOST”, “192.168.155.69” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “824561” );



  • now that i have fixed the mysql password and the tftp password and i now get the “I could not connect!” doing the php command

    root@T412-fogserver:/# php -r "include(’/opt/fog/service/etc/config.php’);mysql_connect(MYSQL_HOST,MYSQL_USERNAME,MYSQL_PASSWORD) or die('I could not connect! '.PHP_EOL); echo 'I connected successfully '.PHP_EOL;"
    PHP Warning: mysql_connect(): Lost connection to MySQL server at ‘reading initial communication packet’, system error: 111 in Command line code on line 1
    I could not connect!



  • had to reinstall and now he is whats happening.
    the php command listed above still works and completes successfully
    when i make a group and give it a multicast task it disappears in the task listings

    /opt/fog/service/etc/config.php
    define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “” );

    /var/www/fog/commons/config.php?
    define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “” );

    i will try the multicast by giving it the task while it’s waiting for one. that normally works.



  • Since you can get into the Web UI and start a task fine, does /opt/fog/service/etc/config.php has the same database name as /var/www/fog/commons/config.php?

    If so, that’s all i can think of for now.



  • root@T412-fogserver:/# php -r "include(’/opt/fog/service/etc/config.php’);mysql_connect(MYSQL_HOST,MYSQL_USERNAME,MYSQL_PASSWORD) or die('I could not connect! '.PHP_EOL); echo 'I connected successfully '.PHP_EOL;"
    I connected successfully


Log in to reply
 

338
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.