Trouble with booting to windows



  • So i got a job to set up fog for a classroom… the people who were supposed to help me don’t know how to solve the issue i have which is that no matter which bios exit type i use the pc is unable to boot into windows from the fog menu.

    I just loop in the fog menu, get a chainloading error or get stuck in the rEFInd menu depending on which option i choose.

    I haven’t used software like this before and so have no idea on how i should be looking to fix this…

    What are the first steps i should take to troubleshoot this?


  • Moderator

    @JerJer said in Trouble with booting to windows:

    @george1421 the computer names are nifferent from fog names. Would they all have to be changed manually?

    If you want the fog errors clear when you list the hosts then you need to have the fog name match the real system name and fog will need to be able to find the systems using dns lookups.



  • @george1421 the computer names are nifferent from fog names. Would they all have to be changed manually?


  • Moderator

    @JerJer

    Are the names registered in FOG the real names of the computers out in the field?

    If so, from a window computer, can you ping the target computer by the names listed in the fog web ui?

    If so, from the fog server linux console, can you ping the target computers by the names listed in the fog web ui?

    If all tests are true then you need to look at the target computer’s firewall settings to be sure udp port 445 is enabled.

    I suspect the tests will fail before the firewall fix.



  • @george1421 said in Trouble with booting to windows:

    @JerJer Ah that’s fog’s ping command.

    You need:

    1. The hosts to be able to be resolved by name by DNS
    2. The host have udp port 445 open in the windows firewall.

    How would i go about doing step 1?



  • @george1421 reinstalled windows on one of the pcs now… The windows is now uefi and the booting works correctly now


  • Moderator

    @george1421 Looking at the sourceforge page for rEFInd it looks like 0.9.1 was release in Sept 2015 which (if I’m remembering correctly) predates the wide adoption of nvme disks. Understand this is only a suspicion, but I wonder if 0.9.1 can even see nvme disks…

    I’m wondering if we grab a current version of refind from here: https://sourceforge.net/projects/refind/files/0.11.4/ download the zip file and then in the zip file change to /refind-bin-0.11.4/refind/ Extract refind_x64.efi and rename it to refind.efi and move it to /var/www/html/fog/service/ipxe directory on the fog server. Don’t forget to rename the existing refind.efi file before copying the new version of refind there.


  • Moderator

    @JerJer said in Trouble with booting to windows:

    Apparently they do use uefi

    I was thinking about this as I ran my morning trips. The part we were missing in the tests is that iPXE will tell boot.php what type of system it is (32bit vs 64bit) and (bios vs uefi). When we called the boot url those parameters weren’t passed as iPXE would. That is why the tests always came up bios. I was going to have you double check to ensure these systems were uefi because bios based systems could not boot refind.efi only uefi systems should understand that environment.

    Ok now we understand the conditions we can focus on the problem. When iPXE exits it calls refind.efi to locate the bootable hard drive.

    I have 2 thoughts on this

    1. We need to adjust the refind config file to look in more places
    2. I’m a bit surprised that the FOG developers switched back to 0.9.1 of refind. That is somewhat old. I know we were doing testing with 0.11.3 and then had to back up to 0.11.0 because of a bug in 0.11.3. I wonder if 0.9.1 supports nvme disks…


  • @george1421 got more info on the pcs… Apparently they do use uefi. I set up bios as instructed but windows seems to be installed in some “bios mode” and will need to be reinstalled



  • @george1421 ok got the location for fog now and changed the refind name… Now the boot from hard disk just loops back to the menu… Can see some text for redind conf and efi flash… The installation was done in some weird way as the server didnt have straight internet connection… Will prolly try reinstalling tomorrow or monday unless i get instructions for it today


  • Moderator

    @JerJer Well… I found in the git hub notes that 0.9.1 was in the build release for quite a while. I have not contacted one of the developers to find out what is currently shipping.

    I would then revert to my previous request to temporarily rename refind.efi and then go through the pxe boot process and exit to the hard drive. I have not ever heard of refind being sent to a bios based computer before, especially since its not listed in the iPXE menu. I don’t understand how its getting to the target computer.



  • @george1421 did you find anything out about refind?



  • @george1421 sry hopped off the pc but the version is 1.5.5


  • Moderator

    @JerJer What version of FOG are you running?


  • Moderator

    @JerJer My initial reaction is that isn’t fog’s refind. I don’t know of a way to confirm, but FOG’s version of refind should be 0.11.0 to 0.11.4.

    Wait I have a fog build environment, let me check that version.




  • Moderator

    @JerJer Ah that’s fog’s ping command.

    You need:

    1. The hosts to be able to be resolved by name by DNS
    2. The host have udp port 445 open in the windows firewall.


  • @george1421 FOG version is 1.5.5
    9046fd07-54e2-435b-acc4-6c165fd8eb1e-image.png
    errors in the list all hosts screen.
    will send pics of the refind screen in a bit.
    Can’t seem to find the file /var/www… FOG was installed for me on the server but i don’t know how… will have to ask if they remember


  • Moderator

    @JerJer I’m about out of ideas here. refind should not be sent by the fog server if its not in the iPXE menu.

    I guess one way to tell if its coming form fog would be to rename refind on the fog server to something else as a test.

    In /var/www/html/fog/service/ipxe directory you should find refind.efi. Rename that with mv refind.efi refind.efi.sav Then pxe boot the target computer again. You might see a chain loading error, but that will tell us if refind is coming from FOG.

    no such device or address on every host

    That depends on where you are seeing this error message.

    I think we should see screen shots of the screens you are seeing. Refind as well as error screens to see if we can get the context of the error.

    Oh, and I forgot to ask, what version of FOG are you using?



  • @george1421
    Can’t find refind on the page. The pcs only have windows but i have no idea if they have refind installed and how i would go about checking that

    EDIT: oh and the no such device or address on every host shouldnt affect this? they still wake up and do all the fog stuff

    EDIT2: heading off for the night gonna continue trying to solve this tomorrow if you come up with more ideas and i have time to try them


Log in to reply
 

291
Online

7.4k
Users

14.5k
Topics

136.6k
Posts