SOLVED Unable to deploy Image

  • Hi,
    I am unable to deploy an image to my new Lenovo T590. Seems to work fine on everything else but for some reason i’m getting the follow error:
    Fog Error.jpg

  • Moderator

    @bartont126 Well unfortunately we need to see what the partclone error is. Partclone doesn’t give a good quality error message back to fog, other than the copy failed. FOG ties to make a good guess to why the copy didn’t happen but misses some times. If you setup a debug capture then single step through the deployment you can capture what is on the partclone screen.

  • @george1421 lol, tagged myself on accident on that last post.

  • @bartont126 This seems to be the error now trying to upload the T480. I haven’t tried another 7390 image yet. I’ll be doing that later since I have built a new one. There is around 411gb of free space.

    Fog upload error.jpg

  • @Quazz Got it, that makes sense. Thank you!

  • @george1421 Got it, thanks! Seems to be working as normal on the 7390 now which is good. Back to the T480. Though, the kernel is now updated to 4.19 but when trying to upload the image it would only upload around 250mb or so. I increased the compression rate from 6 to 8 (as this actually allowed it to upload once) now it uploaded to a typical image size of around 100gb but it’s back to saying no valid data. Now that I know how to clear that out I will do so. Any suggestions on how to get the no valid data to stop happening? ill go through my bios settings and make sure they’re correct real quick.

  • Moderator

    A lot of these laptops have a “RAID” mode that isn’t really intended for traditional RAID, but rather to enable Intel Rapid Storage caching.

    Then again, they’re often set to RAID while not even having a cache SSD to begin with, making it pretty pointless.

  • Moderator

    @bartont126 said in Unable to deploy Image:

    What is the downside to running off achi instead of Raid

    Nothing as long as you are not running a raid configuration (multiple disks teamed together). On a laptop its kind of hard since you only have one disk anyway.

    haven’t had this issue before, unless the 7390s I’ve imaged before were on ACHI for some reason

    If they were in bios mode, or ahci mode you wouldn’t have had an issue.

  • @george1421 So, I switched it over to AHCI… And it took an image! I turned it BACK to raid… OS would not load. Turned it back to ACHI… still wouldn’t load. So, i’ll have to image it in ACHI and leave it. What is the downside to running off achi instead of Raid… because i’m fine with changing the pc’s over to raid to take the image. but I really don’t know what the difference is or how to properly fix it. I haven’t had this issue before, unless the 7390s I’ve imaged before were on ACHI for somere reason

  • Moderator

    @bartont126 said in Unable to deploy Image:

    The 7390 is currently in UEFI Mode/Raid-on. I have the option for Raid, AHCI, or Disabled. ’

    OK there is an issue with linux, dell computers in raid-on, and uefi mode. If you set the disk to ahci linux (FOS in particular) will see the disks. The only risk to this is you may need to reinstall the os if it was configured for raid mode if it doesn’t have the driver built in.

  • @george1421 Nice! Seemed to work. When I did the ls -la /images /dev the space said around 200gb… and went down to 12k. However, when I went to properties on my images folder it seemed to free up a lot, have arouind 500gb left at the moment.

    The 7390 is currently in UEFI Mode/Raid-on. I have the option for Raid, AHCI, or Disabled. ’

  • Moderator

    @bartont126 Remember with great power comes great responsibility. Use the following commands with care.

    Use this commands to see what directories are from failed uploads (yes they do take up space)

    ls -la /images/dev

    Get the list of directories that appear to be mac addresses. Then run this command replacing <mac_address> completely with the directory names. Remember executing this command is unrecoverable.

    rm -rf /images/dev/<mac_address>

    The -rf makes the command dangerous. -r == recursive meaning do it on that directory/file and all objects below. -f == force or just do it and don’t ask questions.

    You can check the disk usage with this command before and after to see how much free space you made du -sh /images/dev

    You have a 7390 is it in bios or uefi mode? If is in uefi mode is the disk controller in raid-on mode or ahci mode?

  • @george1421 Alright, so I got it updated with the correct version. I’ll try re uploading the image now. So all those mac addresses are failed images… thus, its still taking up space, right? So if I delete those, it’ll free up the space its using? What is the command to remove those macs/failed images?

    I’ve got a Dell Latitude 7390 Image that’s worked just fine for awhile but all of the sudden its saying Cannot find disk on system. Is that a bios system or something with a fog setting somewhere?

  • @george1421 Disregard my last… I didn’t read it in full. I’m super in a hurry to get this fixed so my mind is all over the place lol

  • Those aren’t coming thorugh as links to click on to downlload. I found this googling it, is this pulling from the same link? The article was from 2016 but I figured the links were probably updated with the correct version.

  • Moderator

    @bartont126 First being on 4.11.0 is the root of the issue with l219-V network adapter. That support was added into the 4.12.0 linux kernel. So close but not quite.

    There is no guide to manually update the kernels because its not recommended you do by hand. With that said download the kernels from here:

    Download Kernel.TomElliott. and save it as bzImage
    Download Kernel.TomElliott. and save it as bzImage32

    Move both of those files to your FOG server in the following directory
    -or- this if the above errors out

    Note: you will probably want to rename the existing files before you move these new kernels in place just in case you need to backup for some reason.

  • @george1421 Is there a guide on how to manually update the kernel without being on a network.

  • @george1421 Thanks you sir! So it does appear i’m on 4.11.0 kernel, very much behind. I’ll find the update and push it to the server now.

  • Moderator

    @bartont126 said in Unable to deploy Image:

    Finally, when running ls -la /images/dev I get

    Just for clarity those files in the /images/dev directory that look like ethernet mac addresses, those are failed uploads. Its safe to delete those directories (only that match mac addresses) if you want to recover the space.

  • Moderator

    @bartont126 Ok one last question/task. On the fog server linux console key in:
    file /var/www/html/fog/service/ipxe/bzImage
    -or- this if the above errors out
    file /var/www/fog/service/ipxe/bzImage

    That should return with a kernel version number. If the version of the FOS Linux kernel is less than 4.12.x then your kernel is too old to support that hardware. You can update the kernel manually if you are on an isolated network or if on the network you need to do a fix to a directory permissions but then you can update via the fog web ui.