UNSOLVED Fog Snapin Pack - zip never downloads

  • Hi All,
    I’ve got a snapin pack setup in my Fog 1.5.1 server (10 locations, 1 storage node each).
    I’ve got a test client i’m trying to deploy it too, however from what I can see a zip file gets created in C:\Program Files(x86)\fog\tmp\biosupdate.zip but it stays at 0kb (its a 138MB file).
    I’ve configured the snapin to only be on storage node local to my test machine at present until I confirm it works as intended.
    Any thoughts as to why? My first attempt for a long while trying to get snapins operating on my system.
    Log file from one of my test clients and snapin config attached
    I’ve also tried enabling Fog Settings\Fog Client Snapins\SNAPIN LOCATION SEND ENABLED… probably not understanding it’s use but didn’t see a change so I’ve set it back to disabled.
    Thanks in advance for any help!



  • Configure the snapin to be replicated on the locations nodes, configure FOG to get the snapin from the location, be sure to be configured in general, as default and on the client settings.

    Be sure that the snapin is replicated on the server you need and try it.

    maybe you need to change, on the Snapin Pack Arguments the &quot ; by "

  • I also just tried with the AV active protection disabled. The AV has no firewall on it, and I have specifically disabled all profiles of the Windows firewall in the image anyway - same result.

    Are there any specific ports or protocols that are required for deploying snapins? I could get my ICT infrastructure team to look at those, just in case?


  • Hi Eduardo - appreciate the quick reply!
    I rebuilt the zip file using win10 ‘send to>compressed folder’.
    Then I unlinked the snapin pack from my two test hosts, deleted it and deleted the file from the local storage node. I also checked the ‘default storage group’ master server and removed it from there too (I’d initially uploaded it there, but realised I forgot to delete the file).

    rebuilt the snapin pack (using a slightly different file name and zip file name and linked it to my test clients and retried an ‘all snapins’ install task.

    Unfortunately I’ve still got the same behaviour. 0KB file and log indicates a failure return code… 😞

  • If the snapin pack download is not complete you see 0kb sizes unless you take the properties of the file, on the log it seems downloaded.

    I had the same log a few months ago in other client version 0.11.12.
    In my case the zip format was the problem.

    On my experience the best compatible zip format for snapin packs is sending the files to a zip folder from windows 10.

    Can you try it?

    I’m not sure to be explained correctly any doubt i try to answer.