Error creating tasks .... internal service error



  • I can successfully perform a full or quick host registration and inventory from the pxe menu.

    In the management interface i can see the hosts i have added to fog, but when i try to create a task it fails.

    note: i am trying to create an upload image task.

    I can get to the confirm task screen (after selecting the type of task i want to run/create). When i click on the ‘upload image’ button the page reloads, but only displays about half of the output/page (see second screenshot).

    The 1st screenshot is the confirm task page; the last point in the task creation process which works.

    I monitored the loading of the page using the dev console in google chrome, which says that i get the following error for the index.php file:

    “response”: {
    “status”: 500,
    “statusText”: “Internal Server Error”,

    Furthermore no tasks are created in the database and no files are created in the pxelinux.cfg directory on the tftp server (http/fog, mysql and tftp servers are all on the same machine).

    I can write to the database, because i can add hosts to the system and i have checked the the pxelinux.cfg directory has the correct owner and permissions.

    What’s doing on???
    Someone please help!!!

    [url="/_imported_xf_attachments/0/184_Screenshot from 2012-11-01 14:55:03.png?:"]Screenshot from 2012-11-01 14:55:03.png[/url][url="/_imported_xf_attachments/0/185_Screenshot from 2012-11-01 14:55:51.png?:"]Screenshot from 2012-11-01 14:55:51.png[/url][url="/_imported_xf_attachments/0/186_upload image - task creation problem.txt?:"]upload image - task creation problem.txt[/url]



  • Ok so the issue seems to stem from two things, incorrect php/mysql version or a &$tmp flag in part of the includes scripts for FOG itself.

    [B]Check your php version first with “php -v” in a terminal - if you’re running 5.1 or earlier you will need to update![/B]

    I ran these instructions/commands to update from PHP 5.1 to 5.2 in Centos 5.5 and it got my FOG working again. Please try updating to php 5.2 first before you go to 5.3 - you never know what it’ll break.

    1. Get the Atomic repo (for Centos)
      [QUOTE]wget -q -O - [url]http://www.atomicorp.com/installers/atomic.sh[/url] | sh[/QUOTE]

    2. Edit repo to exlude php 5.3 (we just want 5.2 for testing purposes, coz we’re updating from 5.1)
      [QUOTE]nano /etc/yum.repos.d/atomic.repo[/QUOTE]

    (and add in the line) [I]exclude = php5.3[/I]

    1. Update php
      [QUOTE]yum update php[/QUOTE]

    2. Restart Apache
      [QUOTE]/etc/init.d/httpd restart[/QUOTE]

    After these steps, I went through the help provided here: [url]http://fogproject.org/forum/threads/solved-cant-upload-images.3652/#post-8628[/url]

    [QUOTE]So you should be able to search the /var/www/fog/management/includes/tasks.confirm.include.php for all instances of “&$tmp” and replace them with just “$tmp” [/QUOTE]

    Everything is now imaging again and working the way it should :D



  • Ok I have the same problem…

    [url]http://fogproject.org/forum/threads/solved-cant-upload-images.3652/#post-8625[/url]

    I followed instructions from here, deleted all the “&” out of the &$tmp flags, but still no luck :(

    Running Centos 5.5, just had to upgrade to Fog 0.32 (due to new Dell machines and their fancy unsupported BIOS), and PHP is version 5.1.6.

    Not sure where to go from here, perhaps a PHP upgrade? Dunno…

    [url="/_imported_xf_attachments/0/233_hrmmm.jpg?:"]hrmmm.jpg[/url]


Log in to reply
 

388
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.