FOG 1.5.6 Multicast problem?!



  • Hi,
    till now I’ve used FOG 1.5.4 with multicast. I’ve installed a new debian based machine and the FOG Server is now running on a HP Elite 8300 (I5 8GB RAM 120GB Samsung SSD and 1.2TB HDD mounted for the images). The FOG version is the really brand new 1.5.6.
    Installation was working perfectly. Upload of a new image as well.

    Multicast deployment starts perfectly with a group of 25 PCs. But then all the PCs are stuck with the partclone screen but there is no data transfer (the red bars of the block process do not appear).

    Now I clone 90 PCs just with normal Deployment which takes several hours compared to 8 Minutes with multicast FOG 1.5.4 …

    I’ve checked Kernel 4.19.36 (booting), 4.19.6 (booting), 4.19.1 (booting) and 4.1.2 (kernel panic). That didn’t help.

    The client computers are all:
    System Manufacturer LENOVO
    System Product 10MNS1QP00
    System Version ThinkCentre M910t

    Thank you for your advice

    Alexander



  • @Sebastian-Roth WhatsApp Image 2019-05-04 at 15.35.11.jpeg WhatsApp Image 2019-05-04 at 15.34.44.jpeg
    25 an 36 PC in Multicast


  • Senior Developer

    @kratkale Ok thanks for the update. So I will mark this solved again. Will push the systemd fixes to dev-branch soon.



  • @Sebastian-Roth
    I can confirm it is working with 1.5.6 and 1.5.4!

    I’ve done a big mistake!
    I was booting form the old system SSD connected via USB. So the changes where applied to 1.5.4 not to 1.5.6. That was why the hdd was not mounted; why I lost the image …

    Now I’ve another Problem.
    Before rebooting I get the messeage:
    “A warning has been detected!”
    Failed to set disk guid …
    I’ll open a new task


  • Senior Developer

    @kratkale said in FOG 1.5.6 Multicast problem?!:

    Erasing current MBR/GPT Tables takes a looooooooooooooooong time

    You have the older init files (1.5.4) still in place I am fairly sure. Hope you still have a copy of the 1.5.6 inits. If not, download here.

    So to sum things up, systemd might bring up network interfaces too late and we need to wait for that! I will push a fix for that soon.



  • ok I took now an old image
    it is working but:
    -) Erasing current MBR/GPT Tables takes a looooooooooooooooong time
    -) Cloning works much faster 12,7GB/min instead of 8GB/min
    no mistakes with the old image



  • @Sebastian-Roth
    ok - I lost the image I’ve done new on this configuration.

    The old images (importet with csv file) are still available in Web GUI

    in /images I can find all the folder: old an new …

    There was a mistake in the fstab file - so the hdd was not mounted



  • @Sebastian-Roth
    just the messeage you see in the pic. I’ve still this problem!

    WhatsApp Image 2019-05-04 at 12.40.11.jpeg

    There are no images anymore???
    I ve to check the mounting …


  • Senior Developer

    @kratkale Then schedule another multicast task and see if it’s working. I guess we are on the right way with this.

    Earlier on you said:

    This aproach is cousing a boot loop " Unable to locate image store …"

    Where did you see this message?



  • Now the addrees is here:


    [05-04-19 10:25:00 am] Interface Ready with IP Address: 127.0.0.1
    [05-04-19 10:25:00 am] Interface Ready with IP Address: 127.0.1.1
    [05-04-19 10:25:00 am] Interface Ready with IP Address: 192.168.0.196
    [05-04-19 10:25:00 am] * Starting MulticastManager Service
    [05-04-19 10:25:00 am] * Checking for new items every 10 seconds
    [05-04-19 10:25:00 am] * Starting service loop
    [05-04-19 10:25:00 am] * No tasks found!


  • Senior Developer

    @kratkale Let’s try to take a new approach to this. Please edit /lib/systemd/system/FOGMulticastManager.service, goto line 18 that looks like this:

    After=syslog.target network.target mysql.service
    

    Change it to look like this:

    After=syslog.target network-online.target mysql.service
    

    Then reboot your FOG server and check /var/log/fog/fogmulticast.log again.

    As well you might run systemd-analyze plot > systemd-deps.svg and upload that SVG graphics file to a file share and post a link here. On my Debian test VM it looks like this:
    systemd_debian_chain.jpg

    The FOG* services start late on that test system (latest Debian in virtualbox VM) anyway and that is without the above mentioned change. Would be interesting to see if that looks different on your hardware server. Possibly the network interface card on your hardware just takes a little longer…



  • @Sebastian-Roth
    This aproach is cousing a boot loop " Unable to locate image store …"

    /var/www/html/fog/lib/fog/fogbase.class.php, jump to line 2226 and comment the first three lines of the getIPAddress() function. Make it look like this:

        /**
         * Get IP Addresses of the server.
         *
         * @return array
         */
        protected static function getIPAddress()
        {
    //        if (count(self::$ips) > 0) {
    //            return self::$ips;
    //        }
            $output = array();
            exec(
                "/sbin/ip -4 addr | awk -F'[ /]+' '/global/ {print $3}'",
                $IPs,
                $retVal
            );
    

  • Senior Developer

    @kratkale Ahhhh, just remembered that we had a similar issue, see here https://github.com/FOGProject/fogproject/issues/268

    We ought to find a better solution to this…


  • Senior Developer

    @kratkale I tested on Debian as well, strange. Will take a look at the code when I get home in half an hour.





  • @Sebastian-Roth
    it is a brand new installed debian
    root@FOG:/images# cat /proc/version
    Linux version 4.9.0-9-amd64 (debian-kernel@lists.debian.org) (gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) ) #1 SMP Debian 4.9.168-1 (2019-04-12)

    normal deployment of single computers works very well!


  • Senior Developer

    @kratkale Seems like it does not find the right network interface. Please double check the FOG config settings in the web UI for the multicast network interface setting.

    As well, which Linux OS do you use?



  • @Sebastian-Roth
    What I’ve done:
    -) HD
    took the old image hdd put it in the new system.
    /dev
    /postdownloadscripts
    *.mntcheck
    i copied from the new installation to the old disk

    -) old csv files
    Export in the old system:
    +) users
    +) Host
    +) Groups
    +) Snapins
    +) images
    +) printers
    import to the new system



  • @Sebastian-Roth said in FOG 1.5.6 Multicast problem?!:

    /var/log/fog/fogmulticast.log

    [05-03-19 1:30:08 pm]

    === ==== ===== ====
    === ========= == === == ===
    === ======== ==== == ==== ===
    === ======== ==== == =========
    === ==== ==== == =========
    === ======== ==== == === ===
    === ======== ==== == ==== ===
    === ========= == === == ===
    === ========== ===== ====

    ===== Free Opensource Ghost ======

    ============ Credits =============
    = https://fogproject.org/Credits =

    == Released under GPL Version 3 ==

    [05-03-19 1:30:08 pm] Interface Ready with IP Address: 127.0.0.1
    [05-03-19 1:30:08 pm] Interface Ready with IP Address: 127.0.1.1
    [05-03-19 1:30:08 pm] * Starting MulticastManager Service
    [05-03-19 1:30:08 pm] * Checking for new items every 10 seconds
    [05-03-19 1:30:08 pm] * Starting service loop
    [05-03-19 1:30:08 pm] | This is not the master node

    The last line is repeated 6000 times with different times …


  • Senior Developer

    @kratkale The old inits won’t help you I am fairly sure. But if you want to give it a try you can download those here: 1.5.5 and 1.5.4

    Please take a look at the multicast log and post the full contents here. You find that log in /var/log/fog/fogmulticast.log


Log in to reply
 

400
Online

7.4k
Users

14.5k
Topics

136.5k
Posts