error creating epoll fd: Function not implemented



  • Hi,
    Fog version: 1.5.5
    OS: Ubuntu 18.04 lts server
    3 hosts:
    srv-fog (where fog server is installed)
    srv-dhcp (dhcp server)
    host-client (host that serves as an image deployment test)

    When registering the host-client, I have the following message:

    “populating / dev using udev: udevd [2447]: error creating epoll fd: Function not implemented”

    on the management interface fog, I see that the file is bytes, would you have an idea?

    Thank you in advance 🙂


  • Moderator

    @ethan7888 said in error creating epoll fd: Function not implemented:

    You confirm that the snapin, we can not put deployment programs of more than 3MB?

    This is a setting in php.ini that limits the upload size of files. If you increase this value then you can upload larger packages. I have to tell you if the package is too large (like autocad), its better to install autocad on a hidden network share and then configure a snapin to call that network installation point instead of copying all of those files to the PC then installing the software.



  • @george1421

    Hi,

    In fact I had followed a procedure that I had found on the internet or the deployment procedure was not starting to register the host. Then create the image and associate the image with the host. I would have to find exactly the details of this procedure (it will be in my next message ^^)

    But since I reread another procedure (and read a little your wiki) it works really well, on a linux and windows deployment and the snapin (I hallucinated the deployment speed of seven zip: less than two minutes : Awesome !!!)

    In short, I am very happy with this software, still have to tweak certain parameters on my side

    You confirm that the snapin, we can not put deployment programs of more than 3MB? Will it ever be possible to deploy Office 365 in your next releases?

    thank you again for your help and follow-up.


  • Moderator

    @ethan7888 Ok so what did you do wrong to create that error from before? How did you fix it? Did you just change to the procedure below, that is all?

    The reason why I ask is the FOG capture/deploy system should not do what you posted in the pictures. We need to understand what you did so maybe the developers can trap that condition before it becomes an unknown error.



  • @george1421

    Hi,

    I’m sorry, I was very stupid. I reread another deployment procedure.

    In summary:

    • Create your image via the management console
    • register your host via “quick registration and inventory”
    • Capture the image of the client host
    • deploy the image

    In any case, I managed to do two deployments, I hope I’m close to the correct methodology ^^


  • Moderator

    @ethan7888 So did you fix the IP address on your FOG server before or after you installed FOG for the first time?

    If you go into FOG Configuration -> FOG settings and then expand all. Confirm the IP address listed like under tftp server and one other match the current IP address of your FOG server. Also in the Storage Configuration for the default storage node, make sure the IP address listed there is correct too.



  • @george1421 said in error creating epoll fd: Function not implemented:

    When you setup your fog server. For the linux OS did you define a static IP address for your server or are you using dhcp to assign the IP address for your FOG server?
    Is to also safe to assume that you are running your fog server as a VM under virtual box too?

    Hi,

    Yes, my test environment is fully realized under virtual machines via virtualbox (fog-rsv, host client, srv-dchp: three virtualbox machines)

    I am using a DHCP server that provides my client host and fog server
    But I fixed the IP on my fog server and the client host 🙂


  • Moderator

    @ethan7888 When you setup your fog server. For the linux OS did you define a static IP address for your server or are you using dhcp to assign the IP address for your FOG server?

    Is to also safe to assume that you are running your fog server as a VM under virtual box too?


  • Moderator

    @Sebastian-Roth If we ignore the spectre and other kernel warning, it looks like the last thing FOS tried to do is register with the FOG server. If we also consider that it still can’t find the fog postinit stuff. Wouldn’t this kind of be the same condition if the FOG server changed IP addresses after FOG was installed? Typically the FOG server would have a static IP address, but if that was missed…

    I would expect it to fail sooner with the default.ipxe file pointing in the wrong location. But if in the fog configuration settings the IP address there did not match the FOG server’s IP address FOS may be trying to reach out to a host no longer at its location.

    When FOG typically errors out it will display the kernel parameters but it doesn’t appear to be doing it here. I wonder if the OP didn’t wait long enough for the attempting to register host… to timeout before snapping the picture.???



  • @Sebastian-Roth said in error creating epoll fd: Function not implemented:

    About your other question. The “No Data” means FOG never deployed an image to that client. But then I am wondering why you want to do registration if the client seems to be registered in the host list already?!?! This doesn’t make sense.
    When you PXE boot that client, do you get the FOG PXE menu? Does it say “Host is NOT registered” or “Host is registered as …” in the headline of the menu??

    Ok, it’s quite possible that I did not understand at all how fog server worked 🙂

    When I boot in pxe, here is the list of choices in screenshot:
    Capture01.JPG


    I thought it was then necessary to create the image of the client host by clicking on “quick registration and inventory”. After that I went to my web management console and I saw my registered host.


  • Senior Developer

    @ethan7888 Please take a new picture of what you see on screen. I highly doubt that you still get the “line 22: fog.postinit: No such file or directory” message.

    So when you say it’s the same, do you mean it just hangs at “Attempting to register host…” ??? Never gets past that saying “Done”?

    About your other question. The “No Data” means FOG never deployed an image to that client. But then I am wondering why you want to do registration if the client seems to be registered in the host list already?!?! This doesn’t make sense.

    When you PXE boot that client, do you get the FOG PXE menu? Does it say “Host is NOT registered” or “Host is registered as …” in the headline of the menu??



  • @Sebastian-Roth

    Hi,

    When I boot in pxe from the client host, I check: “quick registration and inventory”

    I have the messages as before (see screenshot):

    after-quick-registration-inventory.JPG

    Then another screenshot via the web console management,

    no-data.JPG

    or I see written “no data” after the quick resgistration and inventory “.It normally I have to see one or more files corresponding to my image of my client host, in the directory” / images "?


  • Senior Developer

    @ethan7888 There you go. The installer created those and your images directory looks fine now. Now when you register a client (PXE boot and select register from the menu) what happens?



  • @Sebastian-Roth

    Hi,

    Here is the result of the command line 🙂

    fog-srv.JPG

    Best regards


  • Senior Developer

    @ethan7888 The /images directory looks a bit better now. The file we were talking about is in one of the sub-directories. So please run find /images -name "fog.*" command again to see if it’s there. Please use the command exactly as suggested here.



  • @george1421

    Hi,

    I restart the script (see screenshot) but I still do not have the file fog.postinit?

    Also when I restart my management console, I still have the existing configuration "with my reference image) as if nothing had been reset? Would I still miss something after you?Capture.JPG



  • @george1421

    Hi,

    Thanks, I try to do your procedure quickly. I’ll come back to you as soon as possible 🙂


  • Moderator

    @ethan7888 Yes, just rerun the installer it will rebuild your /images directory. I hope that addresses your issues. If not then we take the next error until your problem is resolved. Understand that the bin directory is inside the expanded tar file path not /bin.



  • @george1421 Hi,

    If you use the tar method change to the bin directory where you extracted the tar file and run the installfog.sh script. >> I chose this method there. So if I understand correctly, I download the .tar package. Then I extracted. I go to / bin and execute “./installfog.sh”, is that it?

    Thanks you very much !


  • Moderator

    @ethan7888 I think the picture is a bit clearer now.

    Please rerun the FOG installer to rebuild the /images directory. You have missing files. If you installed fog using the git method change into the bin directory in the cloned git repo and run ./installfog.sh to run the script. It will use the parameters you used last time you installed fog.

    If you use the tar method change to the bin directory in the directory path where you extracted the tar file and run the installfog.sh script.

    When the installer is finished you should have a directory /images/postinstallscript and /images/dev/postinitscripts (the scripts part may not be on the directory name, I can’t remember for sure). If those are in place, then rerun the capture of your reference image.


Log in to reply
 

349
Online

7.4k
Users

14.5k
Topics

136.7k
Posts