Issues with Gparted PXE Booting



  • I have been trying to get Gparted to work from FOG for the past week. I feel like there is something that I am simply missing.

    I can get Gparted to boot but when it boots it is giving me this error:

    6fd7ca8b-0b4b-4f9f-98a6-4f820cacea4b-image.png

    Am I missing a config file or something? It seems that it is not finding any drives? I know that Gparted works because if I plug the USB with the exact same live image it works no problem on the device.

    Here is what I have defined for my PXE menu settings:

    260bee7f-2706-4b02-bed3-f7e30bb1f1d0-image.png

    kernel http://${fog-ip}/fog/gparted/vmlinuz initrd http://${fog-ip}/fog/gparted/initrd.img boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=http://${fog-ip}/fog/gparted/filesystem.squashfs
    boot
    

    Any advice would be greatly appreciated.



  • @george1421 I forgot to mention that in my notes. I will fix that. Changing fetch=tftp://${fog-ip}/gparted/filesystem.squashfs to fetch=tftp://<fog_server_ip>/gparted/filesystem.squashfs worked just fine and booted properly.


  • Moderator

    @quinniedid said in Issues with Gparted PXE Booting:

    Will boot but crashes later due to the FQDN

    So then to fill out the truth table, change the fqdn (temporarily) to an IP address and see if that is the issue. I know in my setup the ${fog-ip} is the real ip address of my fog server. Maybe there is something broken in the latest release of gparted… actually all you need is the real IP address of the fog server in the fetch parameter the reset can stay conical names its the gparted kernel that is not able to resolve the fqdn name.



  • @george1421 I have my fog server configured with an FQDN instead of IP addresses as we have had to change our IP a few times. So ${fog-ip} is not an actual IP. Also, all computers/VM’s in our network our UEFI configured. I just find it interesting that Clonezilla will work but not this particular version of Gparted.

    I changed the files to the following versions and the associated results:

    0.33.0-2-i686 - Won't even boot
    0.33.0-2-AMD64 - Will boot but crashes later due to the FQDN not resolving for some reason, if IP specified on fetch booted no problem
    0.33.0-1-AMD64 - Will boot but crashes later due to the FQDN not resolving for some reason
    0.32.0-1-AMD64 - Will boot and works with the FQDN no problem!!! :)

    This is the iPXE parameters I am using:

    kernel tftp://${fog-ip}/gparted/vmlinuz
    initrd tftp://${fog-ip}/gparted/initrd.img
    imgargs vmlinuz initrd=initrd.img boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=tftp://${fog-ip}/gparted/filesystem.squashfs
    boot || goto MENU

  • Moderator

    @quinniedid said in Issues with Gparted PXE Booting:

    I am using the 0.33.0 AMD64

    My tests were with i686 version. Lets start eliminating the differences, can you try the i686 files? Those will work on both x86 and x64 systems.

    also in your browser key in http://<fog_server_ip>/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00

    Make sure at the top of that its setting ${fog-ip} correctly

    For example when I run that on my home fog server I get this. So you see the variable fog-ip is being set to an IP address here.

    #!ipxe
    set fog-ip 192.168.112.24
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    ...
    


  • @george1421 I am using the 0.33.0 AMD64. I think I am going to download the previous version and test. I wonder if PXE booting is an issue in this version.


  • Moderator

    @quinniedid said in Issues with Gparted PXE Booting:

    The boot log is reporting a bad address to the FQDN of our server

    Why would that be? In the ipxe menu the reference is ${fog-ip} which should be the IP address of your fog server. Where is it getting the fqdn name from?


  • Moderator

    @Sebastian-Roth said in Issues with Gparted PXE Booting:

    Did you ever get to check what’s in /boot.log

    while I was testing I go similar messages, the boot.log in my case was empty (0 bytes).


  • Moderator

    @quinniedid I guess what version of gparted are you using. Are you using the same one I did? Did you try it in a bios based VM. There as to be something different between your setup and mine. If you look at your clonezilla setup, that mirrors pretty much the gparted setup. So one might think your gparted files are not right if all things are equal.



  • @Sebastian-Roth I did find that it works with an IP address in the fetch portion of the commands.

    hosts: files dns

  • Developer

    @quinniedid That definitely is strange. Can you check /etc/nsswitch.conf when you get to the shell? Please post its contents here.



  • @Sebastian-Roth The boot log is reporting a bad address to the FQDN of our server. Which is strange as within the same command-line I can nslookup the FQDN and get back the associated IP. I can ping the IP address but I cannot ping with the FQDN. Giving me the same error as bad address.


  • Developer

    @quinniedid Did you ever get to check what’s in /boot.log as suggested in the pictures?



  • @george1421 What I find interesting is that I can now get Clonezilla to work on the UEFI VM but NOT on a physical box…
    You would think that Gparted an Clonezilla would be somewhat the same.

    kernel tftp://${fog-ip}/clonezilla/vmlinuz
    initrd tftp://${fog-ip}/clonezilla/initrd.img
    imgargs vmlinuz initrd=initrd.img boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=tftp://${fog-ip}/clonezilla/filesystem.squashfs
    boot

  • Moderator

    @quinniedid My instructions worked on my system using the i686 gparted kernel. I didn’t try the amd64 kernel.

    In both of the pictures I was there during testing. The VM I used for testing was a bios based system. I did not try with a uefi based VM.

    In your second picture I also go that during testing when I moved the kernel arguments to the kernel line in the iPXE code. When I put them back is when it started working once I stopped copying the squashfs via initrd and used the fetch kernel parameter.



  • @george1421 I got a lot closer! But I am now getting a failed to boot…
    3c5d103e-b2b8-4ac0-98de-f2991a8c6d59-image.png

    @Tom-Elliott Also tried these:

    kernel tftp://${fog-ip}/gparted/vmlinuz vmlinuz initrd=initrd.img boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=tftp://${fog-ip}/gparted/filesystem.squashfs
    initrd tftp://${fog-ip}/gparted/initrd.img
    boot
    

    This seemed to get further

    kernel tftp://${fog-ip}/gparted/vmlinuz initrd=initrd.img boot=live union=overlay username=user config components quiet noswap toram=filesystem.squashfs ip= net.ifnames=0 nosplash
    initrd tftp://${fog-ip}/gparted/initrd.img
    initrd tftp://${fog-ip}/gparted/filesystem.squashfs
    boot
    

    030e95ae-d795-4b3a-b8e9-66289b58bbe2-image.png


  • Moderator

    Ok I have a working solution here

    Using gparted-live-0.33.0-2-i686.zip as the base file being used

    This is the parameters settings:

    kernel tftp://${fog-ip}/gparted/vmlinuz
    initrd tftp://${fog-ip}/gparted/initrd.img
    imgargs vmlinuz initrd=initrd.img boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=tftp://${fog-ip}/gparted/filesystem.squashfs
    boot || goto MENU
    

    gparted1.png

    ref: https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images/18


  • Senior Developer

    Move the components of imgargs to the kernel line after vmlinuz

    Remove imgargs line



  • @george1421 This is what I have configured:

    kernel tftp://${fog-ip}/gparted/vmlinuz
    initrd tftp://${fog-ip}/gparted/initrd.img
    initrd tftp://${fog-ip}/gparted/filesystem.squashfs
    imgargs initrd=initrd.img boot=live union=overlay username=user config components quiet noswap toram=filesystem.squashfs ip= net.ifnames=0 nosplash

  • Moderator

    @quinniedid Strange, the files appear to download but then ipxe blew up on the imgargs command and then didn’t try to boot. Are you sure the ipxe menu doesn’t have any extra stuff in it? or like you missed the imgargs command?


Log in to reply
 

463
Online

6.2k
Users

13.6k
Topics

128.0k
Posts