Lenovo z-50



  • Every device we image has got along with fog just fine- except these Lenovo z-50s. 20190123_125854_LI.jpg 20190123_125807.jpg
    not sure what to do next.


  • Senior Developer

    Yeah, too lessen confusion for myself, I called what you call “raw” a “super base” or “base”

    Adjusting “base” for whatever I mean.

    For example:

    Superbase is the base image that ALL machines regardless of who or where the machine sits will start from.

    XXXBase is a specific base based from the “superbase”.

    Just my thoughts. No real value here!


  • Moderator

    @TechInADesert said in Lenovo z-50:

    When I referred to the image as “raw” it just means it’s the image I created without the sysprep

    Ah OK, because in FOG terms RAW is a specific disk capture mode, akin to “single disk non-resizable” but also includes empty blocks. So the images are huge and slow to capture.



  • @george1421 Hello. When I referred to the image as “raw” it just means it’s the image I created without the sysprep. I always put a “raw” image so when I go to update the computers next year I do not have to start fresh. I can load that “raw” image onto a machine and make the changes I want and then upload a “final” image which is the one that is syspreped and ready to go.

    When I put the image back onto a computer it took a matter of minutes, so that is fine. I can live with my “raw” image taking awhile to upload to FOG.


  • Moderator

    @TechInADesert said in Lenovo z-50:

    Question: Does the realtek.pxe take longer to work with imagines that the other?

    No it doesn’t. The iPXE boot kernel (undionly.kpxe or realtek.kpxe) is only used to transfer FOS (bzImage and init.xz) to the target computer. Once FOS starts then the ipxe boot kernel is unloaded from memory. According to partclone what is your transfer rate?

    Why are you uploading the image in raw format? FOS can’t take advantage of speed by only uploading disk blocks that have data in them. Its very uncommon to use raw disk format.

    Lastly, how many of these z-50s will you have on your campus? What is your dhcp server used on your site (maker and version)? If its linux or Windows 2012 or newer we have some options.



  • SOLVED IT

    Thank you for all of your help. You guys were on the right track when you told me to try a different option 67. I, however, was not putting the option in the right scope. I was putting it in the default server options when I should have been putting it into our Tech LAN scope. Once I went into this scope and changed it to realtek.pxe and tried to boot the Lenovo Z-50 booted up just fine.

    I’m learning a good deal about how the last person had our network set up every day. Check another thing off my list.

    Question: Does the realtek.pxe take longer to work with imagines that the other? Usually, I can get an image done in a matter of minutes but I am uploading my raw file to FOG and I’m already at the 33-minute mark and it says there are 17 minutes left to go.



  • @Tom-Elliott Secure Boot was set to disable. I do see that under it says Secure Boot Status and that says Enabled. However, you can’t highlight the Secure Boot Status to change it. The BIOS is also updated to the most recent posted on Lenovo’s website.


  • Moderator

    Here is the tutorial for creating a usb FOS boot image. https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image Make sure you read the caveats section as well as the post “image burn” onto the usb flash drive. You will need to update the grub config file with the IP address of your fog server.

    Also look at the forum chat bubble for a few more helpful hints


  • Moderator

    @TechInADesert We are far from dead in the water in regards to FOG and these laptops.

    Those realtek nic models are older and should be fully supported in FOG and iPXE. One thing we’ve seen with some Lenovo models, especially in uefi mode, they have buggy early release firmware. While I don’t think its going to solve this issue make sure you have the latest firmware (bios) installed on these devices.

    If we can’t get these devices to pxe boot we can move to the USB boot method. Its not quite as flexible as the pxe booting process but for certain models its the only way to bypass a buggy pxe process.


  • Senior Developer

    @TechInADesert turn off secure boot



  • @Tom-Elliott I went ahead and switched the machine to UEFI and put in ipxe.efi as the file. I got a message that said “EFI Network 0 for IPv4 has been blocked by the current security policy.”



  • @george1421 Yes, when I refer to the same error its the one from the above picture regarding the DHCP. Here are some more things I tried.

    1. Not sure if spanning tree is enabled or not, but I can take a look in a bit. I did, however, take a Netgear Fast Ethernet switch and plug it into my Ethernet port on my wall, then plugged the computer into the Netgear Fast Ethernet switch. I also removed option 66 and option 67 for this test. I still got the message about DHCP failing.

    2. The network adapter is Realtek PCIe GBE Family Controller. Hardware IDs are:

    • PCI\VEN_10EC&DEV_8168&SUBSYS_380B17AA&REV_10
    • PCI\VEN_10EC&DEV_8168&SUBSYS_380B17AA
    • PCI\VEN_10EC&DEV_8168&CC_020000
    • PCI\VEN_10EC&DEV_8168&CC_0200

    We were using KACE for our imaging service before moving to FOG but ran into the issue of our new Lenovo laptops ( Lenovo V3330-15IKB) not being able to boot into it. Because of this, we switched over to FOG. However, these white Lenovo laptops (Lenovo Z-50) could boot into KACE just fine. I’m almost thinking I might have to run both FOG and KACE. However, I would rather just use FOG.

    Thank you for your help in trying to figure this puzzle out.


  • Moderator

    @TechInADesert Just for clarity (sorry I have too many threads in the air) when you say the same error showing up, are you referring to your top picture? If so then you have dhcp options 66 and 67 set correctly.

    Looking at that error you see again, I have a suspicion that its a spanning tree issue. This is because iPXE is being transferred to the target computer. That tells me the computer is on the network and talking to the FOG server. The issue is at this point iPXE can’t get an IP address. This is typically for 2 reasons.

    1. Spanning tree (standard) is enabled on the switch port and one of the fast spanning tree protocols is not being used.
    2. The iPXE kernel doesn’t support the network adapter in the target computer.

    If its a spanning tree issue you can mask it by placing an unmanaged (dumb) switch between the pxe booting computer and the building network switch. If this works, then its a spanning tree issue.

    If its option #2 then you would try one of the other boot kernels. So in this case it would be interesting to know what network adapter is installed in that computer. To get this info you need a windows computer that is running on this hardware. Go into the device manager and then select hardware IDs on the details tab for this network adapter. We need to see what the vend and device ids are like {PCI\VEN_8086&DEV_1502&CC_0200
    }. The we can see if FOG supports them.


  • Senior Developer

    @TechInADesert Then I might suggest you boot the machine in UEFI mode and use the ipxe.efi file as opposed to the ipxe.pxe or undionly.kpxe files.

    For the most part, legacy net booting works fine, but there are cases where it just can’t for whatever reason. There’s another possibility causing the issue, in the case the ipxe.efi file doesn’t help anything.

    Is your network using STP (Spanning Tree Protocal) and if so, is Fast STP (sometimes called RSTP or PortFast) enabled?



  • @Tom-Elliott Hello. I went into the DHCP settings and enabled 66 with our FOG’s IP address and then I went into option 67 and tried putting in ipxe.pxe and realtek.pxe. We are still getting the same issue come up.



  • @george1421 I went in and enabled option 66 with our fog server IP address and then enabled option 67 with value undionly.kpxe. I’m still getting the same message showing up.


  • Moderator

    @TechInADesert said in Lenovo z-50:

    Trying ipxe.pxe and/or realtek.pxe was next on my list

    Look to your dhcp server, dhcp option 67 is where the boot file lives. Its not a linux issue but an infrastructure issue for pxe booting (changing the boot file name).



  • @Tom-Elliott Hello Tom. Thank you for the quick reply. Trying ipxe.pxe and/or realtek.pxe was next on my list. However, the person who setup FOG for us on a Linux VM has left and I am not sure how to do it. I was going to do some more research on it to see if I could figure it out. If you have an article you can link to save me the Google search, I’d appreciate it. If not I’ll be looking it up and giving this a try tomorrow. Thanks again!


  • Developer

    @TechInADesert Maybe set to UEFIinstead of legacy BIOS boot and see if ipxe.efi picks up properly.


  • Moderator

    It appears that iPXE (not necessarily FOG) has an issue with your hardware. What network adapter are you using? What is the model #?

    If we can’t get iPXE to work with your hardware we can build a usb boot stick that bypasses ipxe for simple image capture and deployment.


Log in to reply
 

471
Online

5.5k
Users

12.7k
Topics

120.2k
Posts