Create UEFI ISO and prepare Surface go deployement.



  • Hello,

    In the next months, i have to deploy 30 surface go tablet.

    As i know there no way to boot over pxe using a usb ethernet adapter.

    I use Zalman VE350 enclosure which allow to boot into iso directly i’ve tried to grab the ixpxe.efi file and create a iso :

    Structure of my iso (based on the netboot.xyz’s efi iso)
    alt text

    and this seem do not working on VmWare workstation uefi enabled and secure boot disabled and on a physical machine (DELL Latitude 3390 and surface go)

    i’ve tried the netboot.xyz 's efi iso image wich is ipxe based and this also not working.

    There is a way to make a UEFI iso and get the fog boot menu ?

    Thanks

    best regard,


  • Developer

    Just for the notes: I pushed a fix for populating the “Working with node” column properly. But still I don’t think this is causing @TheDiskDrive’s issue. Please post a picture of the error you see and we should be able to help.


  • Developer

    @TheDiskDrive I have looked into this again and I am still not sure I really get this. You said:

    i’ve tried the deploy task to a 10 tablet group and this is not working i have this following error:
    Invalid storage group

    Where/when exactly do you get this error message? Please take a picture of the error on screen and post here!

    When i launch the task and watching task progression ( in task management section) no working node is used

    As I said before, the empty column in the web UI is not causing the problem from my point of view. I have just done another test and it deploys perfectly fine on my test systems.


  • Developer

    @TheDiskDrive Thanks for the detailed pictures and explaination. I’ll try to replicate the issue. Won’t be this week but I won’t forget!



  • @Sebastian-Roth said in Create UEFI ISO and prepare Surface go deployement.:

    @TheDiskDrive Re-reading the whole topic I think I have missed an important part. Just can’t keep all the details of all the different posts in my head. So let’s go back a few steps.

    Okay i think i have found why i can’t use the task “deploy” on a group of computer.
    For some reason there no storage node being used.

    I am not sure why but seems like this is normal. I just tried a multicast deploy on my test system and this table column is empty for me as well. I am fairly sure this is not what is causing the issue for you. See what George posted earlier.

    Is not about multicast deploy but the “Deploy” task, here is my issue

    I go to a group of computer then i click on basic task and select deploy task
    Deploy_Task.png

    here is a list of 10 computer from the group
    Group_Task_Deploy.png

    When i launch the task and watching task progression ( in task management section) no working node is used but when i create deploy task to ONE computer ( the first computer named GEII) the defaultMember node is used
    Working_Node.png

    When i’ve installed fog on my debian server i’ve changed the path in the Storage node settings to use my 1 tb virtual disk and moved all the data from the default path to my 1tb drive (/data on /dev/sdb)

    DataPath.png

    By the way i have deployed all my tablets, deployement took 5 minutes per machine. Now i want to understand where i’m wrong


  • Moderator

    @Sebastian-Roth said in Create UEFI ISO and prepare Surface go deployement.:

    The USB boot stuff is not a fully official part of FOG and therefore we might not have noticed that multicast is not working using that. @george1421 would you have the chance to give it a try and see if it fails for you as well.

    I think it should be possible since the session name is no longer needed. Getting the session name in grub menu wasn’t possible. That is why it didn’t work before. I can test when I’m back in the office. I’m currently on holiday so I don’t have any tools to test at the moment.


  • Developer

    @TheDiskDrive Re-reading the whole topic I think I have missed an important part. Just can’t keep all the details of all the different posts in my head. So let’s go back a few steps.

    Okay i think i have found why i can’t use the task “deploy” on a group of computer.
    For some reason there no storage node being used.

    I am not sure why but seems like this is normal. I just tried a multicast deploy on my test system and this table column is empty for me as well. I am fairly sure this is not what is causing the issue for you. See what George posted earlier.

    @george1421 said in Create UEFI ISO and prepare Surface go deployement.:

    Originally this wasn’t possible. I think there was some kernel parameter changes that now make it possible. I have not tested this feature as of now.

    The USB boot stuff is not a fully official part of FOG and therefore we might not have noticed that multicast is not working using that. @george1421 would you have the chance to give it a try and see if it fails for you as well. If so I will have a closer look and try to fix it.



  • i’m using the default username and password, they are removed for the screenshot.


  • Developer

    @TheDiskDrive Username and Password shouldn’t be empty and definitely are not by default!



  • Here the screenshot, i’m using the default storage node.

    the only thing i have changed is the Image Path and FTP Path

    storagenode.PNG storageNodeConfig.PNG


  • Developer

    @TheDiskDrive What does your storage node settings look like? Please post screenshots here.




  • Developer

    @TheDiskDrive Do you use any FOG plugins like “location” or “site”?



  • Hi everyone !

    Okay i think i have found why i can’t use the task “deploy” on a group of computer.

    noStorageNode.PNG

    For some reason there no storage node being used.

    very weird…

    on a single computer the default storage node is used.



  • @george1421 i have this error even when i created the multicast task.

    when i create my multicast task i do this:

    I select the computer group, click basic task and select multicast task and select “check Schedule instant”.

    then i power on my computer and i have the fatal error unknow request type error after the machine got their IP addresses.

    i tried another way

    i’ve tried the deploy task to a 10 tablet group and this is not working i have this following error:

    Invalid storage group

    I looked my fog group storage configuration and is was set to 30 max client.


  • Moderator

    @TheDiskDrive said in Create UEFI ISO and prepare Surface go deployement.:

    so how to make a multicast deployment using usb drive ? ( i think is a grub parameter to add on the menu entry ? )

    Originally this wasn’t possible. I think there was some kernel parameter changes that now make it possible. I have not tested this feature as of now.


  • Moderator

    @TheDiskDrive said in Create UEFI ISO and prepare Surface go deployement.:

    Fatal Error: unknow request type :: Null
    Kernel Variables and settings:

    Sorry I didn’t see this til now. The issue with the unknown user request is listed in the caveats. You MUST schedule the task in FOG BEFORE you select option 1 from the menu.



  • Hello,

    Today is the D-day, i’m trying to deploy my image and i run into some error, i’m unable to multicast my image with the USB drive.

    When i multi cast i got this error

    Fatal Error: unknow request type :: Null

    Kernel Variables and settings:

    Boot_Image=/boot/bzImage loglevel=4 initrd=init.xz root=/dev/ram0 rw ramdisk_size=127000 keymap=fr web=10.X.X.XX/fog boottype=usb consoleblank=0 rootfstype=ext4

    I can only Deploy or Capture my image. I have 10 hosts in my tablet group and when i use the deploy task i had invalid storage group error.

    so how to make a multicast deployment using usb drive ? ( i think is a grub parameter to add on the menu entry ? )

    thank you !



  • @george1421 a big thank you !

    Surface tablet don’t have integrated ethernet interface thus i can’t boot using UEFI PXE even if in the bios i have UEFI ipv6 and ipv4 pxe entry.

    I used your FOS image and burn on a usb stick ( we have a lot usb keys thanks to dell !) then i changed the grub.cfg file to use my fog server ip and add french keymap !

    I changed some files on the usb stick, i replaced the bzImage, bzImage32, init.xz and init_32.xz files to get the latest kernel avalable to be sure that everything work.

    Now i can deploy image on surface go tablet without trouble !


  • Moderator

    @TheDiskDrive said in Create UEFI ISO and prepare Surface go deployement.:

    but sadly this seem not working even with the efi iso from netboot.xyz

    Don’t use this netboot thing. On your fog server in /tftpboot directory grab ipxe.efi. Move that to a usb flash drive in the correct directory and renamed correctly. This will work.

    I have a tutorial on this: https://forums.fogproject.org/topic/6350/usb-boot-uefi-client-into-fog-menu-easy-way

    If you are going the other path building the usb bootable FOS image. I can give you a jump start if you need. Look at the fog forum chat bubble.


Log in to reply
 

466
Online

6.2k
Users

13.6k
Topics

128.0k
Posts