Could not mount images folder Error


  • Moderator

    @lschnider You can’t it a character mode terminal. If its scrolled off the top of the screen then its lost. Lets see if we can fix the TZ issue so those warning messages will go away.

    Let me ask you have you messed with / changed the password for the FOG linux service account called fog? This is not the default webui admin called fog this is the linux user called fog? If you changed this account I might expect this error message at this point in the capture process.



  • @george1421 The date/time was wrong. I fixed that, i will try to run the capture again.



  • Well maybe this is a dumb question but how do you scroll up on that screen. I have been trying to but it wont let me.


  • Moderator

    @lschnider Also I’ve seen that date.timezone warning message before. I don’t know if that is something new with 1.5.5 or not. Can you confirm that this FOG setting is correct for your timezone: FOG Configuration->FOG Settings->General Settings->TZ INFO


  • Moderator

    @lschnider scratch that, it is set to permissive. I did not read well enough.

    OK we need to see the error that is just off the top of the screen in your previous picture.


  • Moderator

    @lschnider You will still have an issue. You did not follow the prerequisites for installing FOG.

    Now you need to edit /etc/selinux/config
    In that file edit
    SELINUX=enforcing
    to read
    SELINUX=permissive

    reboot the fog server.



  • 
    [root@localhost cmc_it]# sestatus
    SELinux status:                 enabled
    SELinuxfs mount:                /sys/fs/selinux
    SELinux root directory:         /etc/selinux
    Loaded policy name:             targeted
    Current mode:                   permissive
    Mode from config file:          permissive
    Policy MLS status:              enabled
    Policy deny_unknown status:     allowed
    Max kernel policy version:      31
    
    

  • Moderator

    @lschnider

    systemctl disable firewalld
    systemctl stop firewalld
    

    Then check the status of selinux

    sestatus
    

    SELinux status: should be set to permissive.

    Edit: For your new post, we need to see the error at the top (just off the top edge if the screen)



  • Okay so it looks like its capturing the image now, i went back through the wiki article you sent me and followed all the steps again. and everything said “Warning already enabled” the only one that I wasnt sure about was the 0_1543932914055_f8a07d49-d8a9-40b6-9542-40463960a5af-image.png what command do i actually run in this.

    Also when it finished capturing the image it went to this 0_1543933655174_0d660f83-11f6-4af7-91b9-34798548cb7a-image.png

    It did not successfully capture the image after that.



  • I actually am trying to capture an image not deploy one. I havent been able to successfully capture one yet. I did follow the article but i definitely could have missed a step or something. I will try it with the firewall off and see if that works.


  • Senior Developer

    @lschnider Ok, so client can reach the server but firewall is enabled. Disable it for now and see if the deploy is working then. This looks like a CentOS ruleset. So I may ask if you have followed our wiki article on CentOS and disabled SELinux (and the firewall)??! I wonder how you were able to capture an image if the firewall was enabled all the time. Run the following command to switch off the firewall temporarily and then try to do another deploy: systemctl stop firewalld



  • Here is the output from the first thing you said to do. 0_1543876029626_fog error2.PNG

    and here is the second

    [root@localhost cmc_it]# iptables -L -n -v
    Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
     pkts bytes target     prot opt in     out     source               destination                      
        0     0 ACCEPT     udp  --  virbr0 *       0.0.0.0/0            0.0.0.0/0                                 udp dpt:53
        0     0 ACCEPT     tcp  --  virbr0 *       0.0.0.0/0            0.0.0.0/0                                 tcp dpt:53
        0     0 ACCEPT     udp  --  virbr0 *       0.0.0.0/0            0.0.0.0/0                                 udp dpt:67
        0     0 ACCEPT     tcp  --  virbr0 *       0.0.0.0/0            0.0.0.0/0                                 tcp dpt:67
     140K   21M ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                 ctstate RELATED,ESTABLISHED
    10190  612K ACCEPT     all  --  lo     *       0.0.0.0/0            0.0.0.0/0                        
    87460   13M INPUT_direct  all  --  *      *       0.0.0.0/0            0.0.0.0/0                     
    86467   13M INPUT_ZONES_SOURCE  all  --  *      *       0.0.0.0/0            0.0                     .0.0/0
    86467   13M INPUT_ZONES  all  --  *      *       0.0.0.0/0            0.0.0.0/0                      
        0     0 DROP       all  --  *      *       0.0.0.0/0            0.0.0.0/0                                 ctstate INVALID
    80445   12M REJECT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                 reject-with icmp-host-prohibited
    
    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
     pkts bytes target     prot opt in     out     source               destination                      
        0     0 ACCEPT     all  --  *      virbr0  0.0.0.0/0            192.168.122.                     0/24     ctstate RELATED,ESTABLISHED
        0     0 ACCEPT     all  --  virbr0 *       192.168.122.0/24     0.0.0.0/0                        
        0     0 ACCEPT     all  --  virbr0 virbr0  0.0.0.0/0            0.0.0.0/0                        
        0     0 REJECT     all  --  *      virbr0  0.0.0.0/0            0.0.0.0/0                                 reject-with icmp-port-unreachable
        0     0 REJECT     all  --  virbr0 *       0.0.0.0/0            0.0.0.0/0                                 reject-with icmp-port-unreachable
        0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                 ctstate RELATED,ESTABLISHED
        0     0 ACCEPT     all  --  lo     *       0.0.0.0/0            0.0.0.0/0                        
        0     0 FORWARD_direct  all  --  *      *       0.0.0.0/0            0.0.0.0                     /0
        0     0 FORWARD_IN_ZONES_SOURCE  all  --  *      *       0.0.0.0/0                                 0.0.0.0/0
        0     0 FORWARD_IN_ZONES  all  --  *      *       0.0.0.0/0            0.0.0                     .0/0
        0     0 FORWARD_OUT_ZONES_SOURCE  all  --  *      *       0.0.0.0/0                                 0.0.0.0/0
        0     0 FORWARD_OUT_ZONES  all  --  *      *       0.0.0.0/0            0.0.                     0.0/0
        0     0 DROP       all  --  *      *       0.0.0.0/0            0.0.0.0/0                                 ctstate INVALID
        0     0 REJECT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                 reject-with icmp-host-prohibited
    
    Chain OUTPUT (policy ACCEPT 132K packets, 78M bytes)
     pkts bytes target     prot opt in     out     source               destination                      
        0     0 ACCEPT     udp  --  *      virbr0  0.0.0.0/0            0.0.0.0/0                                 udp dpt:68
     132K   78M OUTPUT_direct  all  --  *      *       0.0.0.0/0            0.0.0.0/                     0
    
    Chain FORWARD_IN_ZONES (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
        0     0 FWDI_public  all  --  eth0   *       0.0.0.0/0            0.0.0.0/0                                [goto]
        0     0 FWDI_public  all  --  +      *       0.0.0.0/0            0.0.0.0/0                                [goto]
    
    Chain FORWARD_IN_ZONES_SOURCE (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain FORWARD_OUT_ZONES (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
        0     0 FWDO_public  all  --  *      eth0    0.0.0.0/0            0.0.0.0/0                                [goto]
        0     0 FWDO_public  all  --  *      +       0.0.0.0/0            0.0.0.0/0                                [goto]
    
    Chain FORWARD_OUT_ZONES_SOURCE (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain FORWARD_direct (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain FWDI_public (2 references)
     pkts bytes target     prot opt in     out     source               destination                      
        0     0 FWDI_public_log  all  --  *      *       0.0.0.0/0            0.0.0.                     0/0
        0     0 FWDI_public_deny  all  --  *      *       0.0.0.0/0            0.0.0                     .0/0
        0     0 FWDI_public_allow  all  --  *      *       0.0.0.0/0            0.0.                     0.0/0
        0     0 ACCEPT     icmp --  *      *       0.0.0.0/0            0.0.0.0/0                        
    
    Chain FWDI_public_allow (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain FWDI_public_deny (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain FWDI_public_log (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain FWDO_public (2 references)
     pkts bytes target     prot opt in     out     source               destination                      
        0     0 FWDO_public_log  all  --  *      *       0.0.0.0/0            0.0.0.                     0/0
        0     0 FWDO_public_deny  all  --  *      *       0.0.0.0/0            0.0.0                     .0/0
        0     0 FWDO_public_allow  all  --  *      *       0.0.0.0/0            0.0.                     0.0/0
    
    Chain FWDO_public_allow (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain FWDO_public_deny (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain FWDO_public_log (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain INPUT_ZONES (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    86449   13M IN_public  all  --  eth0   *       0.0.0.0/0            0.0.0.0/0                                [goto]
       17  2689 IN_public  all  --  +      *       0.0.0.0/0            0.0.0.0/0                                [goto]
    
    Chain INPUT_ZONES_SOURCE (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain INPUT_direct (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
      993 35276 ACCEPT     2    --  *      *       0.0.0.0/0            0.0.0.0/0                        
    
    Chain IN_public (2 references)
     pkts bytes target     prot opt in     out     source               destination                      
    86466   13M IN_public_log  all  --  *      *       0.0.0.0/0            0.0.0.0/                     0
    86466   13M IN_public_deny  all  --  *      *       0.0.0.0/0            0.0.0.0                     /0
    86466   13M IN_public_allow  all  --  *      *       0.0.0.0/0            0.0.0.                     0/0
        1    84 ACCEPT     icmp --  *      *       0.0.0.0/0            0.0.0.0/0                        
    
    Chain IN_public_allow (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
        2   104 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                 tcp dpt:22 ctstate NEW
     5600 1517K ACCEPT     udp  --  *      *       0.0.0.0/0            0.0.0.0/0                                 udp dpts:49152:65532 ctstate NEW
      408 21352 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                 tcp dpt:80 ctstate NEW
        0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                 tcp dpt:443 ctstate NEW
        0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                 tcp dpt:69 ctstate NEW
       11   679 ACCEPT     udp  --  *      *       0.0.0.0/0            0.0.0.0/0                                 udp dpt:69 ctstate NEW
    
    Chain IN_public_deny (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain IN_public_log (1 references)
     pkts bytes target     prot opt in     out     source               destination                      
    
    Chain OUTPUT_direct (1 references)
     pkts bytes target     prot opt in     out     source               destination```
    

    Im guessing it has something to do with every ip being 0.0.0.0/0


  • Senior Developer

    @lschnider said in Could not mount images folder Error:

    No the target computer is 10.2.227.199

    Can you please schedule a fresh deploy task. But this time tick the checkbox for debug. Start up the client and when you get to the shell run the following commands to verify:

    ip a s
    ping -c 3 10.2.227.200
    

    If the two machines are surely in the same subnet I suspect the error “No route to host” might come from the firewall being enabled on the FOG server and not allowing NFS access. Run iptables -L -n -v on the FOG server and post here.



  • No the target computer is 10.2.227.199


  • Moderator

    This error is interesting because it appears to be a network issue. The “no route to host” is the key. Is the target computer on a different subnet than the FOG server?


Log in to reply
 

391
Online

7.4k
Users

14.5k
Topics

136.5k
Posts