Issues during installation on Debian 9.6 stretch



  • I am having an issue installing Debian 9.6 stretch.

    The installation fails, it gets to a section asking to update the database schema by visiting http://ipaddress/fog/management however if i visit this address I get nothing as the address 404s, however under /var/www/ there is a fog directory and a fog/managment directory, I can load the machines default page so apache appears to be functioning.

    Is there an issue with the version of Debian I am running (the latest stable release as of this morning) as well of the latest version of fog as of 9AM EST this morning. I read that it does not support PHP 5, will this be an issue going forward? Or is the issue somewhere else? Fog itself says it can’t detect an internet connection during the installation however after going through the prompts it can hit the internet and download all required packages.

    If you need any further information please let me know…



  • @Sebastian-Roth
    Thank you so much, I missed it when you originally said that, running it with --exitFail didn’t work, however running it with -X did work. After this I was able to update/install the schema and actually log into the server via the web interface.

    Additionally I tested booting to the server via PXE and was able too!


  • Developer

    @thegiantcat said in Issues during installation on Debian 9.6 stretch:

    is there a way to start the installation and ignore this?

    As mentioned earlier, you can simply run the installer like this: ./installfog.sh --exitFail (actually means “don’t exit on failure”)



  • @Sebastian-Roth
    I do not have the requested directory(php-fpm) under/var/log,
    /var/log also doesn’t have an www-error.log
    I also checked just to be through and there isn’t a log under
    /etc/php/7.0/fpm


  • Developer

    @thegiantcat said in Issues during installation on Debian 9.6 stretch:

    500 Internal Server Error

    Please check your /var/log/php-fpm/www-error.log!



  • @Tom-Elliott
    Also here is the error part from the log about when it gets to “Backing up databases”

    Dec 06 12:23:00 zstsvreefog systemd[1]: Starting The PHP 7.0 FastCGI Process Manager...
    Dec 06 12:23:00 zstsvreefog systemd[1]: Started The PHP 7.0 FastCGI Process Manager.
    --2018-12-06 12:23:02--  http://172.24.28.71//fog//maintenance/backup_db.php
    Connecting to 172.22.0.102:3128... connected.
    Proxy request sent, awaiting response... 302 Found
    Could not parse String-Transport-Security header
    Location: ?node=schema [following]
    --2018-12-06 12:23:03--  http://172.24.28.71//fog//maintenance/backup_db.php?node=schema
    Connecting to 172.22.0.102:3128... connected.
    Proxy request sent, awaiting response... 500 Internal Server Error
    2018-12-06 12:23:04 ERROR 500: Internal Server Error.
    
    

    This is before making the requested change after the requested change i get

    Dec 06 13:31:46 zstsvreefog systemd[1]: Starting The PHP 7.0 FastCGI Process Manager...
    Dec 06 13:31:46 zstsvreefog systemd[1]: Started The PHP 7.0 FastCGI Process Manager.
    --2018-12-06 13:31:48--  http://172.24.28.71//fog//maintenance/backup_db.php
    Connecting to 172.24.28.71:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Could not parse String-Transport-Security header
    Location: ?node=schema [following]
    --2018-12-06 13:31:48--  http://172.24.28.71//fog//maintenance/backup_db.php?node=schema
    Connecting to 172.24.28.71:80... connected.
    HTTP request sent, awaiting response... 500 Internal Server Error
    2018-12-06 13:31:48 ERROR 500: Internal Server Error.
    
    

    The cert on the proxy server is self signed, i assume that its failing because of that, is there a way to start the installation and ignore this? Or a way to add it as a trusted site?


  • Senior Developer

    @thegiantcat Then why do you have:

    export no_proxy="localhost,127.0.0.1,localhost.localadmin,127.0.0.1,172.22.0.102"
    

    The 172.22.0.102 (which shows as your proxy), should be your FOG Server’s IP address.



  • @Tom-Elliott
    No,

    The fog server is seperate from the proxy.


  • Senior Developer

    @thegiantcat What’s the installer’s error log look like?

    It should show us more information as to why backing up is failing.

    I am a little confused too. Is your FOG Server also your PROXY machine?



  • @Tom-Elliott
    My wgetrc file contains

    http_proxy = http://172.22.0.102:3128
    use_proxy = on
    no_proxy="localhost",127.0.0.0/8,172.22.0.102
    

    I’m not showing a hidden file for curl under ~/ or a config file for curl under /etc/curlrc

    I edited my .bashrc to contain the following

    export http_proxy=<http://172.22.0.102>
    export rsync_proxy=$http_proxy
    export https_proxy=$http_proxy
    export ftp_proxy=$http_proxy
    export no_proxy="localhost,127.0.0.1,localhost.localadmin,127.0.0.1,172.22.0.102"
    

    Is the syntax for that correct, I re-booted the machine after making the change. However its still looking like no dice. (at this point it actually failed at getting binaries

    I made the following changes and it was able to get the binaries but it still failed at backing up the database

    export http_proxy="http://172.22.0.102:3128"
    export rsync_proxy=$http_proxy
    export https_proxy=$http_proxy
    export ftp_proxy=$http_proxy
    export no_proxy="localhost,127.0.0.1,localhost.localadmin,127.0.0.1,172.22.0.102"
    
    

  • Senior Developer

    @thegiantcat can you get an exact screen shot of your /etc/wgetrc file?

    If you literally have:

    "no_proxy="localhost""
    

    This may be a part of the problem.

    I’d imagine you should have:

    no_proxy=127.0.0.1,localhost,localhost.localdomain,X.X.X.X
    

    Change X.X.X.X to whatever your fog IP actually is.

    Also, I believe the installer uses curl for binaries and database backups, so I imagine editing the /etc/wgetrc is the wrong approach.

    I believe you would edit the file for whom you’re installing at:
    ~/.curlrc

    You could set the same information up in /etc/skel/curlrc too I suppose.

    however you’d want lines like:

    proxy = <proxyInfoHere>
    noproxy = localhost,127.0.0.1,localhost.localdomain,127.0.1.1,X.X.X.X
    

    You could also edit your ~/.bashrc To contain lines like:

     export http_proxy=<http://proxyInfoHere>
     export https_proxy=$http_proxy
     export ftp_proxy=$http_proxy
     export rsync_proxy=$http_proxy
     export no_proxy="localhost,127.0.0.1,localhost.localdomain,127.0.1.1,X.X.X.X"
    

    If you do add to the .bashrc file, however, you’ll need to close the terminal/logout of the console, and log back in for the changes to take effect.

    Hopefully this helps.

    In the case you use the bashrc method, please change the X.X.X.X to that of your fog server’s actual IP address, and of course change your http_proxy line to be appropriate. It should include the schema (http{,s}://…) information as well.


  • Developer

    @thegiantcat said in Issues during installation on Debian 9.6 stretch:

    Unfortunately due to the location, this machine has to go through a proxy to access the internet, is it possible to skip this step in the installation?

    Sure you can manipulate the scripts but you could also just run the installer like this: ./installfog.sh --exitFail (actually means “don’t exit on failure”)

    Strange that “no_proxy” wouldn’t properly work. Have you tested to set to no_proxy="localhost,127.0.0.1,x.x.x.x" where x.x.x.x is the FOG server IP?



  • @Sebastian-Roth
    Apache2 shows running
    The php log file mentioned only contains the following

    [02-Dec-2018 06:25:02] NOTICE: error log file re-opened
    [04-Dec-2018 09:42:25] NOTICE: Terminating ...
    [04-Dec-2018 09:42:25] NOTICE: exiting, bye-bye!
    [04-Dec-2018 10:08:03] NOTICE: fpm is running, pid 465
    [04-Dec-2018 10:08:04] NOTICE: ready to handle connections
    [04-Dec-2018 10:08:04] NOTICE: systemd monitor interval set to 10000ms
    [04-Dec-2018 11:59:51] NOTICE: Terminating ...
    [04-Dec-2018 11:59:51] NOTICE: exiting, bye-bye!
    [04-Dec-2018 12:00:25] NOTICE: fpm is running, pid 470
    [04-Dec-2018 12:00:25] NOTICE: ready to handle connections
    [04-Dec-2018 12:00:25] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 13:42:01] NOTICE: Terminating ...
    [05-Dec-2018 13:42:01] NOTICE: exiting, bye-bye!
    [05-Dec-2018 14:09:03] NOTICE: fpm is running, pid 8503
    [05-Dec-2018 14:09:03] NOTICE: ready to handle connections
    [05-Dec-2018 14:09:03] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 14:11:37] NOTICE: Terminating ...
    [05-Dec-2018 14:11:37] NOTICE: exiting, bye-bye!
    [05-Dec-2018 14:12:21] NOTICE: fpm is running, pid 9732
    [05-Dec-2018 14:12:21] NOTICE: ready to handle connections
    [05-Dec-2018 14:12:21] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 14:15:19] NOTICE: Terminating ...
    [05-Dec-2018 14:15:19] NOTICE: exiting, bye-bye!
    [05-Dec-2018 14:16:11] NOTICE: fpm is running, pid 11029
    [05-Dec-2018 14:16:11] NOTICE: ready to handle connections
    [05-Dec-2018 14:16:11] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 14:18:55] NOTICE: Terminating ...
    [05-Dec-2018 14:18:55] NOTICE: exiting, bye-bye!
    [05-Dec-2018 14:19:53] NOTICE: fpm is running, pid 12261
    [05-Dec-2018 14:19:53] NOTICE: ready to handle connections
    [05-Dec-2018 14:19:53] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 14:28:53] NOTICE: Terminating ...
    [05-Dec-2018 14:28:53] NOTICE: exiting, bye-bye!
    [05-Dec-2018 14:30:01] NOTICE: fpm is running, pid 13502
    [05-Dec-2018 14:30:01] NOTICE: ready to handle connections
    [05-Dec-2018 14:30:01] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 15:01:27] NOTICE: Terminating ...
    [05-Dec-2018 15:01:27] NOTICE: exiting, bye-bye!
    [05-Dec-2018 15:03:14] NOTICE: fpm is running, pid 14933
    [05-Dec-2018 15:03:14] NOTICE: ready to handle connections
    [05-Dec-2018 15:03:14] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 15:09:21] NOTICE: Terminating ...
    [05-Dec-2018 15:09:21] NOTICE: exiting, bye-bye!
    [05-Dec-2018 15:10:18] NOTICE: fpm is running, pid 16312
    [05-Dec-2018 15:10:18] NOTICE: ready to handle connections
    [05-Dec-2018 15:10:18] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 15:29:00] NOTICE: Terminating ...
    [05-Dec-2018 15:29:00] NOTICE: exiting, bye-bye!
    [05-Dec-2018 15:30:52] NOTICE: fpm is running, pid 18904
    [05-Dec-2018 15:30:52] NOTICE: ready to handle connections
    [05-Dec-2018 15:30:52] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 15:39:08] NOTICE: Terminating ...
    [05-Dec-2018 15:39:08] NOTICE: exiting, bye-bye!
    [05-Dec-2018 15:40:03] NOTICE: fpm is running, pid 20203
    [05-Dec-2018 15:40:03] NOTICE: ready to handle connections
    [05-Dec-2018 15:40:03] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 15:54:07] NOTICE: Terminating ...
    [05-Dec-2018 15:54:07] NOTICE: exiting, bye-bye!
    [05-Dec-2018 15:54:39] NOTICE: fpm is running, pid 470
    [05-Dec-2018 15:54:39] NOTICE: ready to handle connections
    [05-Dec-2018 15:54:39] NOTICE: systemd monitor interval set to 10000ms
    [05-Dec-2018 15:56:55] NOTICE: Terminating ...
    [05-Dec-2018 15:56:55] NOTICE: exiting, bye-bye!
    [05-Dec-2018 15:57:56] NOTICE: fpm is running, pid 2079
    [05-Dec-2018 15:57:56] NOTICE: ready to handle connections
    [05-Dec-2018 15:57:56] NOTICE: systemd monitor interval set to 10000ms
    [06-Dec-2018 11:15:22] NOTICE: Terminating ...
    [06-Dec-2018 11:15:22] NOTICE: exiting, bye-bye!
    [06-Dec-2018 11:16:06] NOTICE: fpm is running, pid 6848
    [06-Dec-2018 11:16:06] NOTICE: ready to handle connections
    [06-Dec-2018 11:16:06] NOTICE: systemd monitor interval set to 10000ms
    
    

    The apache2 error log also doesn’t seem to be throwing to many errors

    [Thu Dec 06 06:25:02.506492 2018] [mpm_prefork:notice] [pid 2080] AH00163: Apache/2.4.25 (Debian) OpenSSL/1.0.2l configured -- resuming normal operations
    [Thu Dec 06 06:25:02.506529 2018] [core:notice] [pid 2080] AH00094: Command line: '/usr/sbin/apache2'
    [Thu Dec 06 11:15:22.443225 2018] [mpm_prefork:notice] [pid 2080] AH00169: caught SIGTERM, shutting down
    [Thu Dec 06 11:16:06.707548 2018] [mpm_prefork:notice] [pid 6849] AH00163: Apache/2.4.25 (Debian) OpenSSL/1.0.2l configured -- resuming normal operations
    [Thu Dec 06 11:16:06.707626 2018] [core:notice] [pid 6849] AH00094: Command line: '/usr/sbin/apache2'
    

    However, after doing some digging I thing i found a clue, if I disable the setting in /etc/wgetrc “no_proxy=“localhost”” it fails on “Downloading Binaries” if I have this enabled it fails on “Backing up Database” this backup isn’t using FTP is it?

    Unfortunately due to the location, this machine has to go through a proxy to access the internet, is it possible to skip this step in the installation?


  • Developer

    @thegiantcat At the “Backing up database” stage it sends a HTTP web request to the FOG web server asking to deliver a DB backup. This can fail for various reasons. Could be the proxy or other things. You probably want to set no_proxy=127.0.0.1,x.x.x.x (while x.x.x.x is your FOG server IP).

    But could be other things as well. First check web server state via systemctl status apache2. Running? Then you might check the logs, /var/log/php-fpm*.log and the error logs mentioned in my signature.



  • @Sebastian-Roth

    Alright, I’m re-cloning the git repository and will re-perform the install and see what happens.

    Alright, after reclonining and trying to install it fails to download the binaries.
    I fixed this by running export http_proxy=http://myproxyserver:port
    However, now it gets to backing up databases and fails. Is this due to a setting because I’m behind a proxy?

    I’ve included the fog_install error log below if it helps.

       #      It will prepend the running with sudo if root is not set      #
       ######################################################################
       #           ** Notice ** FOG is difficult to setup securely          #
       #        SELinux and IPTables are usually asked to be disabled       #
       #           There have been strides in adding capabilities           #
       #          The recommendations would now be more appropriate         #
       #    to set SELinux to permissive and to disable firewall for now.   #
       #  You can find some methods to enable SELinux and maintain firewall #
       #   settings and ports. If you feel comfortable doing so please do   #
       ######################################################################
       #            Please see our wiki for more information at:            #
       ######################################################################
       #             https://wiki.fogproject.org/wiki/index.php             #
       ######################################################################
    
     * Here are the settings FOG will use:
     * Base Linux: Debian
     * Detected Linux Distribution: Debian GNU/Linux
     * Server IP Address: 172.24.28.71
     * Server Subnet Mask: 255.255.254.0
     * Interface: enp2s0
     * Installation Type: Normal Server
     * Internationalization: 0
     * Image Storage Location: /images
     * Using FOG DHCP: Yes
     * DHCP router Address: 172.24.28.1
    
    
     * Are you sure you wish to continue (Y/N)
     * Installation Started
    
     * Installing required packages, if this fails
     | make sure you have an active internet connection.
    
     * Adding needed repository....................................OK
     * Preparing Package Manager...................................OK
     * Packages to be installed:
    
            apache2 bc build-essential cpp curl g++ gawk gcc genisoimage gzip htmldoc isc-dhcp-server isolinux lftp libapache2-mod-php7.0 libc6 libcurl3 liblzma-dev m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php7.0 php7.0-bcmath php7.0-cli php7.0-curl php7.0-fpm php7.0-gd php7.0-json php7.0-mbstring php7.0-mysql php7.0-mysqlnd php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g
    
    
     * Skipping package:   apache2.................................(Already Installed)
     * Skipping package:   bc......................................(Already Installed)
     * Skipping package:   build-essential.........................(Already Installed)
     * Skipping package:   cpp.....................................(Already Installed)
     * Skipping package:   curl....................................(Already Installed)
     * Skipping package:   g++.....................................(Already Installed)
     * Skipping package:   gawk....................................(Already Installed)
     * Skipping package:   gcc.....................................(Already Installed)
     * Skipping package:   genisoimage.............................(Already Installed)
     * Skipping package:   gzip....................................(Already Installed)
     * Skipping package:   htmldoc.................................(Already Installed)
     * Skipping package:   isc-dhcp-server.........................(Already Installed)
     * Skipping package:   isolinux................................(Already Installed)
     * Skipping package:   lftp....................................(Already Installed)
     * Skipping package:   libapache2-mod-php7.0...................(Already Installed)
     * Skipping package:   libc6...................................(Already Installed)
     * Skipping package:   libcurl3................................(Already Installed)
     * Skipping package:   liblzma-dev.............................(Already Installed)
     * Skipping package:   m4......................................(Already Installed)
     * Skipping package:   mysql-client............................(Already Installed)
     * Skipping package:   mysql-server............................(Already Installed)
     * Skipping package:   net-tools...............................(Already Installed)
     * Skipping package:   nfs-kernel-server.......................(Already Installed)
     * Skipping package:   openssh-server..........................(Already Installed)
     * Skipping package:   php7.0..................................(Already Installed)
     * Skipping package:   php7.0-bcmath...........................(Already Installed)
     * Skipping package:   php7.0-cli..............................(Already Installed)
     * Skipping package:   php7.0-curl.............................(Already Installed)
     * Skipping package:   php7.0-fpm..............................(Already Installed)
     * Skipping package:   php7.0-gd...............................(Already Installed)
     * Skipping package:   php7.0-json.............................(Already Installed)
     * Skipping package:   php7.0-mbstring.........................(Already Installed)
     * Skipping package:   php7.0-mysql............................(Already Installed)
     * Skipping package:   php7.0-mysql............................(Already Installed)
     * Skipping package:   php-gettext.............................(Already Installed)
     * Skipping package:   sysv-rc-conf............................(Already Installed)
     * Skipping package:   tar.....................................(Already Installed)
     * Skipping package:   tftpd-hpa...............................(Already Installed)
     * Skipping package:   tftp-hpa................................(Already Installed)
     * Skipping package:   unzip...................................(Already Installed)
     * Skipping package:   vsftpd..................................(Already Installed)
     * Skipping package:   wget....................................(Already Installed)
     * Skipping package:   xinetd..................................(Already Installed)
     * Skipping package:   zlib1g..................................(Already Installed)
     * Updating packages as needed.................................OK
    
     * Confirming package installation
    
     * Checking package: apache2...................................OK
     * Checking package: bc........................................OK
     * Checking package: build-essential...........................OK
     * Checking package: cpp.......................................OK
     * Checking package: curl......................................OK
     * Checking package: g++.......................................OK
     * Checking package: gawk......................................OK
     * Checking package: gcc.......................................OK
     * Checking package: genisoimage...............................OK
     * Checking package: gzip......................................OK
     * Checking package: htmldoc...................................OK
     * Checking package: isc-dhcp-server...........................OK
     * Checking package: isolinux..................................OK
     * Checking package: lftp......................................OK
     * Checking package: libapache2-mod-php7.0.....................OK
     * Checking package: libc6.....................................OK
     * Checking package: libcurl3..................................OK
     * Checking package: liblzma-dev...............................OK
     * Checking package: m4........................................OK
     * Checking package: mysql-client..............................OK
     * Checking package: mysql-server..............................OK
     * Checking package: net-tools.................................OK
     * Checking package: nfs-kernel-server.........................OK
     * Checking package: openssh-server............................OK
     * Checking package: php7.0....................................OK
     * Checking package: php7.0-bcmath.............................OK
     * Checking package: php7.0-cli................................OK
     * Checking package: php7.0-curl...............................OK
     * Checking package: php7.0-fpm................................OK
     * Checking package: php7.0-gd.................................OK
     * Checking package: php7.0-json...............................OK
     * Checking package: php7.0-mbstring...........................OK
     * Checking package: php7.0-mysql..............................OK
     * Checking package: php-gettext...............................OK
     * Checking package: sysv-rc-conf..............................OK
     * Checking package: tar.......................................OK
     * Checking package: tftpd-hpa.................................OK
     * Checking package: tftp-hpa..................................OK
     * Checking package: unzip.....................................OK
     * Checking package: vsftpd....................................OK
     * Checking package: wget......................................OK
     * Checking package: xinetd....................................OK
     * Checking package: zlib1g....................................OK
    
     * Configuring services
    
     * Setting up fog user.........................................Already setup
     * Setting up fog password.....................................OK
     * Stopping FOGMulticastManager.service Service................OK
     * Stopping FOGImageReplicator.service Service.................OK
     * Stopping FOGSnapinReplicator.service Service................OK
     * Stopping FOGScheduler.service Service.......................OK
     * Stopping FOGPingHosts.service Service.......................OK
     * Stopping FOGSnapinHash.service Service......................OK
     * Stopping FOGImageSize.service Service.......................OK
     * Setting up and starting MySQL...............................OK
     * Backing up user reports.....................................Done
     * Stopping web service........................................OK
     * Removing vhost file.........................................OK
     * Is the MySQL password blank? (Y/n)  * Stopping FOGMulticastManager.service Service................OK
     * Stopping FOGImageReplicator.service Service.................OK
     * Stopping FOGSnapinReplicator.service Service................OK
     * Stopping FOGScheduler.service Service.......................OK
     * Stopping FOGPingHosts.service Service.......................OK
     * Stopping FOGSnapinHash.service Service......................OK
     * Stopping FOGImageSize.service Service.......................OK
     * Setting up and starting MySQL...............................OK
     * Setting up Apache and PHP files.............................OK
     * Testing and removing symbolic links if found................OK
     * Backing up old data.........................................OK
     * Copying new files to web folder.............................OK
     * Creating config file........................................OK
     * Unzipping the binaries......................................Done
     * Copying binaries where needed...............................Done
     * Enabling apache and fpm services on boot....................OK
     * Creating SSL CA.............................................OK
     * Creating SSL Private Key....................................OK
     * Creating SSL Certificate....................................OK
     * Creating auth pub key and cert..............................OK
     * Resetting SSL Permissions...................................OK
     * Setting up Apache virtual host (no SSL).....................OK
     * Starting and checking status of web services................OK
     * Changing permissions on apache log files....................OK
     * Backing up database.........................................Failed!```

  • Developer

    @thegiantcat Here we go. This has nothing to do with Debian. Someone messed with the installer scripts.

    If this is from github you can reset the local repo to install FOG 1.5.5 like this:

    cd /etc/fogproject
    git reset --hard
    git pull
    git checkout master
    

    If the git commands fail, you probably just have an extracted archive there. Then simply leave that stuff or better delete and clone fresh from github:

    cd /root
    git clone https://github.com/FOGproject/fogproject
    cd fogproject
    ...
    


  • @Sebastian-Roth
    Here ya go.

    configureMySql() {
        stopInitScript
        dots "Setting up and starting MySQL"
    #    for mysqlconf in $(grep -rl '.*skip-networking' /etc | grep -v init.d); do
    #        sed -i '/.*skip-networking/ s/^#*/#/' -i $mysqlconf >>$workingdir/error_logs/fog_error_${version}.log 2>&1
        done
    #    for mysqlconf in `grep -rl '.*bind-address.*=.*127.0.0.1' /etc | grep -v init.d`; do
    #        sed -e '/.*bind-address.*=.*127.0.0.1/ s/^#*/#/' -i $mysqlconf >>$workingdir/error_logs/fog_error_${version}.log 2>&1
        done
        if [[ $systemctl == yes ]]; then
            if [[ $osid -eq 3 ]]; then
    --
        configureMySql
        mysqlver=$(echo $mysqlver | awk -F'([.])' '{print $1"."$2}')
        runTest=$(echo "$mysqlver < $vertocheck" | bc)
        if [[ $runTest -eq 0 ]]; then
            [[ -z $snmysqlhost ]] && snmysqlhost='localhost'
            [[ -z $snmysqluser ]] && snmysqluser='root'
            case $snmysqlhost in
                127.0.0.1|[Ll][Oo][Cc][Aa][Ll][Hh][Oo][Ss][Tt])
                    sql="UPDATE mysql.user SET plugin='mysql_native_password' WHERE User='root';"
                    mysql "${options}" -e "$sql" >>$workingdir/error_logs/fog_error_${version}.log 2>&1
                    sql="ALTER USER '$snmysqluser'@'127.0.0.1' IDENTIFIED WITH mysql_native_password BY '$sqlescsnmysqlpass';"
    

  • Developer

    @thegiantcat Well that’s interesting. Can you please run grep -A 10 "configureMySql" /etc/fogproject/bin/lib/common/functions.sh and post result here.

    By the way, /etc is not exactly a great place to use for keeping this kind of data.



  • @Sebastian-Roth
    Here is the returned info.
    0_1544024050517_debug2.log


  • Developer

    @thegiantcat Thanks for the log but seems like my instructions were not as well though of. Didn’t have a machine to test and just made that up. So let’s do it a different way because we still miss the most important part in the debug log. Edit installfog.sh again and remove the -xv. Then start the installer like this: bash -x installfog.sh 2> debug.log. You will see some amount of debug messages go past ending with a line Choice: [1] ++ read osid. Just hit ctrl+c here and upload the new debug log. That should have the information I hope to see what’s going wrong.


 

428
Online

5.4k
Users

12.6k
Topics

118.9k
Posts