I am having Problems with FOG on Ubuntu 12.04



  • I’ve set up fog and It was working pretty well but for some reason when I restart the server the PXE side of fog doesn’t always seem to work:/
    the host computers often can’t seem to detect it at all when I restart the server
    now I am very new to servers so I tried restarting the SSH and the DHCP services and that allowed the host computers to detect the DHCP but couldn’t load the TFTP image

    my server has two Ethernet controllers
    a nic card built in to the server and a extra PCI Ethernet card
    the Nic card is what I’m using for the fog service the other is just so I can use the internet for research and stuff

    under the network manager I’ve set eth0 (fogs connection) as
    Manual
    IP address 192.168.1.1
    Netmask 255.255.255.0
    Gateway 192.168.1.1
    DNS server 192.168.1.1
    and search domains as Fog

    btw I have also set up a new storage node
    but I don’t think that is causing the problem as both servers are working very well together

    also both servers are oldish rack servers
    HP Proliant g4p (can’t remember the exact name as I’m at home atm)

    both have 10GBs of ram and 2 dual core Xeon CPUs with 3.4GHz of speed

    also if anyone can tell me how to get fog to log opticle Drives and Hard Drive capacity it would be much appreciated
    also are there any tools for configuring the PXELinux menu as I’ve been doing that manually and I want to add some custom tools to the menu

    thanks in advance



  • I had the same issue look at this thread it solved my problem. [url]http://fogproject.org/forum/threads/tftp-issues-but-fixable.779/[/url]



  • try to check the configuration file
    cat /etc/default/tftpd-hpa



  • hello erm yes
    I’ve recreated the fog server at home using VMware and from what I can tell it’s working perfectly here
    could it be due to it having 4 ethernet ports



  • nope it didn’t work :/



  • try to click save on the fog settings page related to tftp


Log in to reply
 

473
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.