Win 10 Hostname Changer



  • I am testing deploying Win 10 image. The first time I deployed it, everything worked flawlessly. I made some changes to the image (nothing major) and then redeploy the image to the same machine. Now it seems as if FOG is changing the name and deploying it in our domina to early. The computer reboots before Windows has a chance to set up completely. This then causes an error in the Windows set up. In the management console, I can uncheck hostname changer and the image deploys perfect (obviously with a generic name). Is there a way I can delay the hostname service?

    Thanks



  • @Scott-Adams Thanks Scott. That seemed to work with my initial test. I will test it again later this afternoon. I’m surprised that the service in the base image would impact the deployed host.

    Thanks



  • @benswan Yes. However, you have to make sure that it is not only stopped, but disabled. If it is not disabled, the service will start back up automatically and then hostnamechanger will do its job.



  • @Scott-Adams said in Win 10 Hostname Changer:

    setupcomplete.cmd

    Thanks Scott. I’m not sure if that is the problem or not. Shouldn’t the FOG service on the capture machine be turned off when sysprep runs? Also, the image works fine when I turn Hostname changer off, so would the service running on capture machine be the problem?

    Thanks for your reply.



  • Not sure if this is your issue, but I know that before you capture your image, you should stop the FOG Service and also set it to Disabled for the startup. Then, use a script that is called after the imaging to start the service again. I use a setupcomplete.cmd myself.


Log in to reply
 

386
Online

6.0k
Users

13.3k
Topics

125.1k
Posts