2 Error in iPXE (time out and sand device)



  • Hello, I cant figure out how to solve this, I spend a while now. The server ip is 10.0.0.72, maybe the error is because its says that the DHCP IP is .72?, I dont knwo to much about networking, if so how to change it?

    Some times i get this error:
    0_1540819908685_Sin nombre.png
    And some times this one
    0_1540820139562_sad.png


  • Moderator

    @FrancoDin said in 2 Error in iPXE (time out and sand device):

    Just one final doubt, what does dnsmasq do to the dhcp?

    We have dnsmasq only configured for proxy dhcp mode. In this configuration dnsmasq will only provide pxe boot information to override dhcp options 67 and 68. You MUST have a functional dhcp server on your network too. This configuration is used when people can change the settings in their dhcp server, we just override them with dnsmasq. If you turn off dnsmasq then the only thing that falls down is pxe booting. No other services are impacted.

    If you are getting unexpected results from your dhcp server, then its your dhcp server not dnsmasq doing this to you.

    If you want me to provide that dnsmasq is not messing up your dhcp process we can do that too. We’ll just capture a typical pxe booting process using tcpdump (or wireshark) to see exactly what is going down your network wire. I can show you how.



  • @george1421
    Ok, you are my new god.
    It was an extra character in that line, a type-o.
    Now all is working perfectly.
    Just one final doubt, what does dnsmasq do to the dhcp?, I am worry that maybe an error in the net and the DHCP failed for the server whit dnsmasq, when I put the server whit DHCP at the start, I lost connection in some devices because the two DHCP overwrite eachother. I am sure this not happen whit dnsmasq but, just wanna be sure.
    And sorry for the bad english.


  • Moderator

    @FrancoDin I don’t have this configuration setup any more, but from the error message tells me the fog bits are working correctly (even if FOG was not designed to do what you are doing). You are at the point of netbooting linux mint.

    Did you remember to add the kernel argument line after the initrd line?
    imgargs vmlinuz root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/images/os/mint/18.1/ locale=en_US.UTF-8 keyboard-configuration/layoutcode=us quiet splash

    (also make sure your paths are correct)

    What I’m doing in this configuration its loading the linux mint kernel and inital virtual drive using the tftp protocol then by using the kernel arguments (imgargs) I’m telling the kernel to get the rest of the files via the nfs protocol (hint: nfs base directory is /images) in the path provided. From your error message I would say that linux mint has started but can’t get the rest of the files over nfs.



  • @george1421
    ahh ok.
    I get to here:
    0_1540996794778_Captura de pantalla de 2018-10-31 11:37:08.png
    When I enter Linux MInt 17.3 It first load 100%, then ok.
    and I get to this
    0_1540996858296_Captura de pantalla de 2018-10-31 11:40:44.png

    0_1540997393216_Captura de pantalla de 2018-10-31 11:49:28.png


  • Moderator

    @FrancoDin said in 2 Error in iPXE (time out and sand device):

    @FrancoDin
    Also… why the route is
    kernel tftp://${fog-ip}/mint/18.1/vmlinuz
    when actually the vmlinuz is in /tftpboot/mint/18.1

    well this will become clear when you know that the tftp server’s base directory is /tftpboot. Just like the http server’s base directory is /var/www/html/. And the nfs servers base export directory is /images on the fog server. So knowing what tranfer protocol you want use, you would place the files in the correct base file directory.

    Your menu entry is using the tftp protocol so your base directory is /tftpboot. I can tell you that tftp is the slowest protocol of the three. Depending on how you want to use this configuration you might want to change some things. If its just a test or something you use once a month its fine. But for now get it working then improve on what you have once its works.


  • Moderator

    @FrancoDin said in 2 Error in iPXE (time out and sand device):

    But when I boot from there Its says “Connection time out”, its has anything to deal whit dnsmasq?

    If you are seeing the FOG iPXE menu then the issue is beyond dnsmasq. If you didn’t see the FOG iPXE menu then we would focus on the dnsmasq settings.

    I’m suspecting that there is something wrong with the custom iPXE menu you created or the needed files are missing.



  • @FrancoDin
    Also… why the route is
    kernel tftp://${fog-ip}/mint/18.1/vmlinuz
    when actually the vmlinuz is in /tftpboot/mint/18.1


  • Moderator

    @FrancoDin said in 2 Error in iPXE (time out and sand device):

    kernel tftp://${fog-ip}/mint/18.1/vmlinu

    If you use the fog parameter ${fog-ip} that will be replaced by the actual IP address of the fog server. That makes the fog menu entry portable between different fog servers.

    Also be aware that you typed in your post
    kernel tftp://${fog-ip}/mint/18.1/vmlinu

    I hope its just a type-o but you missed the z on the end
    kernel tftp://${fog-ip}/mint/18.1/vmlinuz

    Back to your question you can also enter it as this:
    kernel tftp://10.0.0.7/mint/18.1/vmlinuz

    In programming terms the ${ } denote a variable used in the iPXE menu. Where the variable name is between the curly braces.



  • @george1421

    Thank you a Lot, all working now.
    Just one think, I follow this guide (https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images/9) to add Linux Mint, to the fog menu. But when I boot from there Its says “Connection time out”, its has anything to deal whit dnsmasq?

    Also, in the parameters:
    kernel tftp://${fog-ip}/mint/18.1/vmlinu
    Should go like this
    kernel tftp://${10.0.0.7}/mint/18.1/vmlinuz
    or
    kernel tftp://$10.0.0.7/mint/18.1/vmlinuz
    in the 3 different times its appears.


  • Moderator

    @FrancoDin Well if you want to go through the process again, just make sure that the FOG server has a static IP address before you install FOG. Just install a normal FOG server without dhcp services.

    Then install dnsmasq and use the config file I provided. (hint: if you are using putty to connect to your fog server, you can use copy and paste to copy the text file into nano and ltsp.conf easily).

    Once dnsmasq is setup correctly using my config file it should work. If not then we will use the fog server and tcpdump to capture what is going wrong with the pxe booting process. We are far from just giving up. This WILL work.



  • @george1421

    Yhep, that broke the fog.
    But I managed it, to update the dnsmasq, after manually instaling 80 packes from https://www.debian.org/distrib/packages , that seems to work for the pxe boot error, but it direct me to my previous IP, so I will reinstall ubuntu server, and try all again, because I try to reinstall fog, but have a problem deleting it and when try to reinstall its gets an error instalin packges,(maybe I broke that aswell).


  • Moderator

    @FrancoDin said in 2 Error in iPXE (time out and sand device):

    BOOT Server ip:10.0.0.2

    fwiw: In a previous post you had the fog server at 10.0.0.27

    Also the fog server must have a static IP address or one created via dhcp reservation. FOG does not fog support servers that are configured to use dhcp. Your fog deployment will break if the IP address of your fog server changes after FOG is installed.



  • @george1421

    Now it works, but when I go to the PC and boot:

    Auto-Select:
    Boot to FOG

    BOOT Server ip:10.0.0.2
    TFTP.
    PXE-T01: File not Found
    Pxe-E3B: TFTP Error - File not found
    PXE-M0F: Exiting intel PXE ROm.
    Fatal: Could not read from the boot medium

    Also I see that maybe there is a problem in the IP, because there is another device whit the ip 10.0.0.2 so I will fix that tomorrow and tell you what happen


  • Moderator

    @FrancoDin well I can see from your screen shot that you have extra text in the config file. <10.0.0.2> should be 10.0.0.2 (assuming that 10.0.0.2 is your FOG server’s IP)

    PS: Look at the FOG Forum chat bubble for additional hits



  • @george1421

    0_1540909005732_jobdns.png

    So its fail at running, and the version of dnsmasq is 2.75
    I am editing that file whit nano, because I am using Putty, and I cant coppy paste files in the ubuntu server at the moment. The fog isent runing in virtual box.

    I just realized the error is in spanish, sorry my bad, that red line says:
    Rank of dhcp not valid, in line 26 of lstp.conf
    Fail at the start

    0_1540909587748_dpfconfig.png


  • Moderator

    @FrancoDin I also see from the screen shot you are editing the /etc/dnsmasq.conf file. This file should not be adjusted. It should have a reference to load any files in the /etc/dnsmasq.d directory. The dnsmasq.d directory is where the ltsp.conf file goes.

    Also, is your FOG server running on virtual box? If so, you need to ensure you are using a bridged network adapter for both the fog server and pxe booting client. Using a nat network adapter will cause you pains trying to get things to pxe boot.


  • Moderator

    @FrancoDin well from the screen shot I don’t see dnsmasq running.

    sudo systemctl start dnsmasq

    then make sure it starts every reboot
    sudo systemctl enable dnsmasq

    Also lets capture the version of dnsmasq to make sure its 2.76 or newer
    sudo dnsmasq -v



  • @george1421

    0_1540908314508_ram.png

    The target computer is in the same subnet as the dhcp server, and yes the mikrotik is the normal dhcp server.


  • Moderator

    @FrancoDin Can you confirm that dnsmasq is running in memory.

    sudo ps aux|grep dnsmasq

    I’m also not seeing it pick up a dhcp address. Is the target computer on the same subnet as your dhcp server? Your Mikrotik is your normal dhcp server right?


Log in to reply
 

516
Online

5.9k
Users

13.3k
Topics

125.1k
Posts