refind.conf doesn't appear to be used



  • I’ve been having a couple of niggling issues with rEFInd (mainly warning about legacy boot and “scanfor”)

    I’ve edited my refind.conf in /var/www/fog/service/ipxe/refind.conf to turn legacy scanning off as it’s not needed, but I’m still getting the error.

    As a test, I’ve also changed timeout from -1 to 10, but I still don’t see rEFInd’s menu.

    This leads me to believe that refind.conf is not being loaded.

    What might I be doing wrong?


  • Senior Developer

    @geekjosh Then for safety in the future:

    Please run:

    mv /var/www/fog{,_backupold}
    ln -s /var/www/html/fog /var/www/fog
    


  • @tom-elliott that was it! Thanks for your help :)


  • Senior Developer

    @geekjosh It is reading it from that location. Now there is a possibility that you have two separate installs of fog going on your machine, this happens from time to time.

    Try:

    cp /var/www/{fog,html/fog}/service/ipxe/refind.conf
    

    Then try booting your machine.



  • I’ve set exit type to REFIND, and that is working fine (as in, it loads refind) but refind appears to be ignoring the refind.conf - do I have to rebuild it with the new conf or something or should it just read that file at runtime like I’m expecting?


  • Senior Developer

    Exit type possibly?

    In FOG you can set exit per host, and globally.

    The defaults are:

    BIOS Boot: SANBOOT
    UEFI Boot: EXIT

    The global settings are found in FOG Configuration Page->FOG Settings->Boot Settings.

    If you set a specific host with defined exit types, that will override the Global for that host. Hopefully that helps.


Log in to reply
 

439
Online

6.3k
Users

13.7k
Topics

128.9k
Posts