PXE boot fails due to incorrect server IP



  • I’m setting up a FOG server and having trouble getting the PXE boot working. I’m pushing out the correct DHCP options via the router:

    Option 66: 10.10.10.10
    Option 67: undionly.kpxe

    However, the boot fails. I performed a packet capture on the port where the client is connected and interestingly, the client receives the correct DHCP options but is trying to download from the default gateway at 10.10.10.1 instead of 10.10.10.10

    Any ideas?

    0_1533835195719_Screenshot 2018-08-09 13.19.18.png
    0_1533835265093_Screenshot 2018-08-09 13.20.52.png

    0_1533835178192_PXE capture.pcap



  • I figured it out!

    I’m using Meraki as the router and setting option 66 and 67 doesn’t work (well… 67 does but 66 isn’t enough)

    Under DHCP, the appropriate boot options need to be set.

    0_1533836669297_Screenshot 2018-08-09 13.43.37.png



  • I figured it out!

    I’m using Meraki as the router and setting option 66 and 67 doesn’t work (well… 67 does but 66 isn’t enough)

    Under DHCP, the appropriate boot options need to be set.

    0_1533836669297_Screenshot 2018-08-09 13.43.37.png


Log in to reply
 

362
Online

7.4k
Users

14.5k
Topics

136.7k
Posts