SOLVED Active Multi-cast Tasks 'In-Progress, status 0'', while Active tasks ended.


  • 0_1533724319763_tasks-ended.png
    0_1533724323879_active-multicast-tasks.png

    • Multcast job sent for 21 machines;
    • all 21 machine run smooth through the multicast job process;
    • after sending another multicast job to deploy the same image, the imaging process doesn’t start transfer of the image.

    Mutlicast log:

    == Released under GPL Version 3 ==

    [08-08-18 10:39:17 am] Interface Ready with IP Address: 127.0.0.1
    [08-08-18 10:39:17 am] Interface Ready with IP Address: 127.0.1.1
    [08-08-18 10:39:17 am] Interface Ready with IP Address: 192.168.210.1
    [08-08-18 10:39:17 am] Interface Ready with IP Address: fog
    [08-08-18 10:39:17 am] * Starting MulticastManager Service
    [08-08-18 10:39:17 am] * Checking for new items every 10 seconds
    [08-08-18 10:39:17 am] * Starting service loop
    [08-08-18 10:39:18 am] * No tasks found!
    [08-08-18 10:39:27 am] | Task (27) Multi-Cast Task is new!
    [08-08-18 10:39:28 am] | Task (27) /images/xxxxx image file found.
    [08-08-18 10:39:28 am] | Task (27) Multi-Cast Task 21 clients found.
    [08-08-18 10:39:28 am] | Task (27) Multi-Cast Task sending on base port: 59814.
    [08-08-18 10:39:28 am] | Command: /usr/local/sbin/udp-sender --interface ens160 --min-receivers 21 --max-wait 360 --portbase 59814 --full-duplex --ttl 32 --nokbd --nopointopoint --file /images/xxxxx/d1p1.img;/usr/local/sbin/udp-sender --interface ens160 --min-receivers 21 --max-wait 10 --portbase 59814 --full-duplex --ttl 32 --nokbd --nopointopoint --file /images/20180731-HPpav/d1p2.img;
    [08-08-18 10:39:28 am] | Task (27) Multi-Cast Task has started!
    [08-08-18 10:39:37 am] | Task (27) Multi-Cast Task is already running with pid: 3107.

    FOG 1.5.4
    php fpm settings set

    update:
    Manual ‘cancel’ of Active Multi Task - In-Progess , status 0 - will do.

    update 2:
    Seems to be fixed after one time, cancel of active multi tasks.
    I did before a database cleanup (cause: php fpm settings not set);
    DEL * FROM multicastSessions
    DEL* FROM multicastSessionsAssoc
    DEL* FROM tasks

    FIXED

349
Online

8.1k
Users

15.0k
Topics

141.4k
Posts