Keys Disappear on Multi-cast?



  • FOG 1.5.3
    CentOS 7.5

    I am not sure if this is a known issue, an unknown issue or simply my own fault.

    I have 7 hosts registered. For each one set the key, clicked update, then went back to the hosts list, back to the updated host and verified the key was in the field. I then followed the same process for enabling a snappin on each and setting domain join on each.

    After having done that for all 7, I added all 7 to the same brand new group. From the group I applied the same snappin previously applied to each via the group and made no other changes/updates independent or via the group.

    I then did a multicast via the group and sent the same Windows 7 image to all the machines. I used an 8th machine already imaged from this image (literally solo deployed the image to it prior) to run the task via the web GUI. Its worth mention that the 8th machine was imaged and worked just fine.

    The 7 host machines went through the entire imaging process including joining the domain and running my snapin but did not activate Windows with the keys I had previously provided. Going back to check each host in the web GUI and none of the 7 have a key in the field now.

    I am hoping I just made a dumb mistake in how I executed my process (likely something to do with doing the keys before using the group to update something else), but its possible this is similar to the bug I found/helped find with the iPXE descriptions not being saved on creation (updates stuck, but initial creation would not save this field) in a prior version of FOG.

    I have assigned the keys 1 by 1 to all 7 hosts again, verified that they are in the field and also exported the key list from reports. This all checks out. I am going to re-image the same 7 machines using multi-cast again and see if the result changes or if it happens again. I will report back my findings in case this is a bug.

    Any input is welcome, as I am working on 0 sleep now its possible I will make more mistakes :/



  • Forget it, sorry to waste anyone’s time. Redoing it has worked on all machines. I am guessing applying just the snapin via group wiped the key fields for each host.


 

352
Online

41.8k
Users

12.3k
Topics

116.0k
Posts