FOG 1.6 Testing Needed - Help would be greatly appreciated as needed

  • Hello All,

    I know you all have been hearing about our work on 1.6 and maybe even our “kind of” roadmap with 1.7, 1.8, 1.9, and 2.0.

    I’ve branched our feature branch that was working with 1.6 to working-1.6 and just trying to get people out there who are interested and somewhat “dare-devilish” who would like to install and test 1.6.

    For the most part, I believe all the main page components are rewritten to be 1.6 gui friendly, but my Javascript is not necessarily the best. I believe most things are functional, but I’m only one person. There’s likely a ton of things that need to be re-worked, but I think it’s functional enough to be used in a testing environment (or those who are really brave, take the task of attempting in production based testing – not recommended but could help find real world issues much easier).

    I need a lot of help with finding issues and probably with javascript coding pieces.

  • Moderator

    @lebrun78 Just be aware there is no way back to the 1.5.x version of FOG if you switched to working-1.6 now other than very messy manual manipulations in the database. We are working towards 1.6 and hope to have most users upgrade at some point. So I am not saying you shouldn’t. Just want to make sure you understand the consequences.

  • @george1421 To test what will become 1.6 the git checkout needs to be: git checkout working-1.6

    dev-branch will put you on (ish) (ish) is in working-1.6

  • Moderator

    @lebrun78 Centos 8 is not currently supported by FOG 1.5.7, you can switched to the dev-branch and updated version of 1.5.7 that will bring you to ~ You can switch to the 1.6 deb branch which is a stepping stone towards FOG 1.6.0 which hasn’t been released as of now. Plus upgrading to 1.6.x is a one way street. Only make the move if you plan on staying on 1.6.x for better or worse.

    To install the dev branch change to the root of the fogproject directory (also understand this only works if you created the git install and not the tarball install). This directory is typically in either /opt or /root. Once in the fogproject directory issue this command git checkout dev-branch. Next change to the bin directory and reinstall FOG. If you already tried to install FOG 1.5.7 onto Centos 8 you may have to drop the fog database (understand you will loose the entire contents of the fog database and all configurations if you do this).

  • Hello,
    I’m installing a new server with Centos 8.0.
    Could I use 1.6 version for production ?


  • @astrugatch most likely parallel as a merge would create a TON of conflicts.

  • @Tom-Elliott

    Will they be living in parallel for the foreseeable future or is there a merge on the horizon?

  • @astrugatch The dev-branch and working-1.6 branches have more or less diverged. So while it may “seem” behind the curve, I assure you it is not. There may be some minor differences but they’re 2 totally separate things.

  • With what sounds to be the impending release of the 1.5.x (6?). The 1.6 branch seems to be several commits back from 1.5.5 (almost 200, not sure how many are just different based on the UI). Is 1.6 going to keep up with the new release or should I pump the breaks until it is more official. I prefer the UI greatly to the 1.5.5 release and am the impatient type. I just don’t want to move my system over only to have to back out.

  • I know it’s been a while since I posted this announcement, but I’ve been kind of keeping up with @Sebastian-Roth with his code changes with 1.5.5 and how they apply to 1.6 as well.

    Remember, for the most part, the backend side of FOG is staying the same with as minimal of changes as I can. What this means, is many of things in terms of overall performance and functionality that has been going into 1.5.5 can be relatively simple to apply to 1.6.

    There are some caveats to this though. But I think things are looking much better than they had from the initial posting of this.

    I know it’s the holiday season and I hope everybody enjoys it. I think this is all the more reason to apply the post so it can be viewed a little more readily.

    Thank you all.

  • Moderator

    @jms Are you sure you wanna use the current 1.6 testing branch of FOG? From what you write it doesn’t sound like it. Please let us know what exactly are you aiming for.

    We have a wiki article on CentOS that you might find interesting:

    About SELinux… first search result in the forums is:

  • @Sebastian-Roth I set SElinux to permissive and rebooted and now have full access to the web application. Are there any tips/tricks to get this to work in a more secure environment? My customer will require it.

  • Moderator

    @jms Those messages are fine I think. Check for SElinux with this command just to make sure: getenforce (should say permissive)

  • @Sebastian-Roth … SELinux maybe the culprit? This is the entire contents of /var/log/httpd/error_log

    [Tue Oct 30 15:18:54.950152 2018] [core:notice] [pid 18968] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
    [Tue Oct 30 15:18:54.951263 2018] [suexec:notice] [pid 18968] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Tue Oct 30 15:18:55.024509 2018] [auth_digest:notice] [pid 18968] AH01757: generating secret for digest authentication …
    [Tue Oct 30 15:18:55.025440 2018] [lbmethod_heartbeat:notice] [pid 18968] AH02282: No slotmem from mod_heartmonitor
    [Tue Oct 30 15:18:55.045190 2018] [mpm_prefork:notice] [pid 18968] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.6.38 configured – resuming normal operations
    [Tue Oct 30 15:18:55.045219 2018] [core:notice] [pid 18968] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’
    [Tue Oct 30 16:02:57.220914 2018] [mpm_prefork:notice] [pid 18968] AH00170: caught SIGWINCH, shutting down gracefully
    [Tue Oct 30 16:03:13.796605 2018] [core:notice] [pid 1099] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
    [Tue Oct 30 16:03:13.799657 2018] [suexec:notice] [pid 1099] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Tue Oct 30 16:03:13.873692 2018] [auth_digest:notice] [pid 1099] AH01757: generating secret for digest authentication …
    [Tue Oct 30 16:03:13.874639 2018] [lbmethod_heartbeat:notice] [pid 1099] AH02282: No slotmem from mod_heartmonitor
    [Tue Oct 30 16:03:13.928936 2018] [mpm_prefork:notice] [pid 1099] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.6.38 configured – resuming normal operations
    [Tue Oct 30 16:03:13.928975 2018] [core:notice] [pid 1099] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’

  • Moderator

    @jms Sounds like you are on the right track here. Can you please take a look at the apache error logs (see my signature). This is where we usually find evidence for why a blank page is shown.

  • Having some trouble on CentOS 7.5 (with all updates). Everything seems to go fine and I can log into the web console and then just get to a blank page. Happens on both Safari and Firefox (latest versions).

    Here are my steps … CentOS 7.5 VM – fresh install, freshly updated and rebooted.

    #> cd /opt
    #> git clone
    #> cd fogproject
    #> git pull
    #> git fetch --all
    #> git checkout working-1.6
    #> cd bin
    #> ./

    Set up as Fog server with DHCP and gateway, but not DNS. Then updated firewall …

    #> for service in http https tftp ftp mysql nfs mountd rpc-bind proxy-dhcp; do firewall-cmd --permanent --zone=public --add-service=$service; done
    #> firewall-cmd --permanent --add-port=49152-65532/udp
    #> firewall-cmd --permanent --direct --add-rule ipv4 filter INPUT 0 -p igmp -j ACCEPT
    #> systemctl restart firewalld

    Next completed the database install via the GUI and completed the text based installer with no issues. But as I’ve said I get sent to the following URL which is just a blank page in both browsers I tried …


    I have attached the full text output of the installation process.

    Sorry - I’m sure I’ve missed something simple and obvious – but can anyone spare a few minutes to take a look and provide some guidance? Thank you !!
    0_1540930468007_Fog Installation Log.txt

  • Hey, testing with 1.6 I have found that I’m having trouble creating tasks for hosts. When trying to create any task you get a toast notification in the top right saying ‘Internal Server Error.’

    I saw a number of other posts advising to check the apache logs however it doesn’t appear to create an entry when the task creation fails.

    Is there other log files I could check for more information?

    alt text

    Im running Centos 7.5 with mysql Ver 15.1 Distrib 5.5.60-MariaDB.

  • This post is deleted!

  • @zer0cool just where I wrote it already. Right now Joe is very very limited in his ability to help with the project so it really is just me at this point. We have our other people but they are very busy as well.

  • @tom-elliott said in FOG 1.6 Testing Needed - Help would be greatly appreciated as needed:

    I know you all have been hearing about our work on 1.6 and maybe even our “kind of” roadmap with 1.7, 1.8, 1.9, and 2.0.

    Is there any specific place we can check this info out? I would be interested to read about future plans. Thanks