UNSOLVED Lot of questions, various sections...all post image.

  • ALrighty.

    Thanks first of all, I’ve seen the couple admins and devs and this software is fantastic. I just started at a place that gets gobs of machines at once - 53 hit my desk this week, and I’d rather not touch them all 🙂 (save for unboxing, changing bios boot options, ya know)

    To first start testing fog I put it on a esxi vm on a closed network. Took a while to get it working correctly off one nic while the other was still functional (couldn’t modify dhcp server, still wanted fog snapins and such on main lan) and after a weekend of testing got that setup. Skipping past sysprep issues of course, which some people on here helped with without even knowing it, now I have issues with snapins.

    So my base image is win 10 1803, audit mode and copied over a .bat that runs xcopy from a server. That will house a local ‘tech package’ of some ninites, centrastage clients, and allow a sysadmin to change hostname, run wsus offline etc. Because it ills fresh after every install, i can modify that folder structure to pass commands to the next file that is called to run after sysprep - but I’d rather not. Originally it ran a chocolatey string of adobe,chrome,vlc type installs and when you have 53 machines query an http server well…lol so I started on snapins.

    The base list of snapins are simple mostly but have been giving me headaches. I’ve seen people throw a >apologize.txt file as output but that never seems to work. I get various ‘returns’ all from things i assume are because it runs as system. For example - easy one…vlc install. The tag is /S. Returns 0 or 1, but I get nothing. THats an .exe file, so I try other things…msiexec /i seems to work for the most part if it’s only a single install - but sometimes I try to run batch for things (we have a lot of activpanels, from a company called Promethean…think smartboards) so I’ll run a batch to install the 4-5 addons for that - nothing. Try seperately with /qn, nothing. Gave up.

    Cmd/batch is a very powerful tool in my repertoire so I use it as much as I can. A lot don’t work though. A simple
    Pushd \\postdeploy
    Wmic/append:servicetag.txt bios get serialnumber
    Echo %computername%>>servicetag.txt
    Should work, as it does easily when ran as any user on any machine…however fails when ran. The list goes on.

    I can attach anything you’d like, change commands give outputs of commands (if we can figure out the >appinstall.txt) and everything…that’s where I’m at so far though. I will ask more as time goes on. This is long enough as is.

    Thanks in advance!

  • @p4cm4n also, tried cmd and batch from sfx archives, specifically 7zip sfx maker which threw an error trying to run on my own machine and winrar sfx maker. Rar is crappier compression but oh well. One of those worked can’t remember which…but things like wifi configs using it didnt.