DHCP increase range



  • Hi guys, I run FOG server on UBUNTU 16 and it’s working fine but I have a limit of 4 clients. I modified /opt/fog/.fogsettings and I increase to 100 clients but after restart fog DHCP server seems to not providing IP address on PXE boot. What should be the problem?



  • @tom-elliott THANK YOU! No, I didn’t do that. I simply reinstall/refresh fog with those settings. After reinstall, fog keep settings and run ok!thank you again!


  • Senior Developer

    Usage: ./installfog.sh [-h?dEUuHSCKYXT] [-f <filename>]
                    [-D </directory/to/document/root/>] [-c <sslPath>]
                    [-W <webroot/to/fog/after/docroot/>] [-B </backup/path/>]
                    [-s <192.168.1.10>] [-e <192.168.1.254>] [-b <undionly.kpxe>]
            -h -? --help                    Display this info
            -o    --oldcopy                 Copy back old data
            -d    --no-defaults             Don't guess defaults
            -U    --no-upgrade              Don't attempt to upgrade
            -H    --no-htmldoc              No htmldoc, means no PDFs
            -S    --force-https             Force HTTPS for all comunication
            -C    --recreate-CA             Recreate the CA Keys
            -K    --recreate-keys           Recreate the SSL Keys
            -Y -y --autoaccept              Auto accept defaults and install
            -f    --file                    Use different update file
            -c    --ssl-file                Specify the ssl path
                                                    defaults to /opt/fog/snapins/ssl
            -D    --docroot                 Specify the Apache Docroot for fog
                                                    defaults to OS DocumentRoot
            -W    --webroot                 Specify the web root url want fog to use
                                                    (E.G. http://127.0.0.1/fog,
                                                          http://127.0.0.1/)
                                                    Defaults to /fog/
            -B    --backuppath              Specify the backup path
                  --uninstall               Uninstall FOG
            -s    --startrange              DHCP Start range
            -e    --endrange                DHCP End range
            -b    --bootfile                DHCP Boot file
            -E    --no-exportbuild          Skip building nfs file
            -X    --exitFail                Do not exit if item fails
            -T    --no-tftpbuild            Do not rebuild the tftpd config file
            -P    --no-pxedefault           Do not overwrite pxe default file
            -F    --no-vhost                Do not overwrite vhost file
    

    Maybe try:
    ./installfog.sh -s 10 -e 254 -y



  • @tom-elliott man I ONLY modified in opt/fog settings from .14 to .100!!! Subnet is 24. Please help me to start this goddamn’ server! I think I loosing my mind …



  • @tom-elliott guys help me please, I search everywere IP its ok, mask ok! Were should i look again?!???



  • @tom-elliott were should I look? Please!!! It’s a life and death situation!!! Thank you!



  • @tomelliot tell we’re should I look please


  • Senior Developer

    That sounds like a subnetting type issue, where the subnet is setup as 255.255.255.250 (possibly?)



  • PLEASE ANYONE, HELP!!!
    I m in a big hurry!
    Please!!!


Log in to reply
 

491
Online

6.2k
Users

13.6k
Topics

128.0k
Posts