Deploy image pointing to wrong storage node from both sites? If deploying near master node, it tries to pull from Storage Node. Then vice versa...



  • So this is pretty interesting. I don’t know if this was messed up since I captured a computer from the storage node…

    So PC1 is on the subnet A
    Master is on the subnet A

    Storage Node is on subnet B
    image was captured on subnet B and uploaded to fog. (when capturing it had the master node as the storage location.

    So right now, if I take a computer and try to deploy an image from Subnet A (master node area), it will try and download the image from the Storage Node on subnet B… very slow obv

    If I take a computer and try to deploy from Subnet B (Storage Node area), it will try and download from the master node on Subnet A… very slow again…

    What did I do wrong or how do I fix this?



  • @tom-elliott dumb question found how to enable plugins.



  • @tom-elliott this might be a dumb question… but where are plugins in the newest version of fog?


  • Senior Developer

    @vince-villarreal and the location plugin for the win? Does exactly what you’re talking about for the specific purpose you’re referring to.



  • @vince-villarreal I understand. I really think our issues are related. I say this because I initially experienced the same thing but updating fog and nodes worked for me for now. We haven’t had the need to image from other locations so i’m not 100% sure it’s actually fixed. I experience same issue only when uploading image and for some reason it was going to separate subnet lol. That’s resolved but not sure about actual imaging. We are getting ready to image for summer projects so I’m going to have some techs image from other locations on separate subnets to see if I’m having the same issue.



  • I just noticed also that when you uncheck the replicate option on the image, update, then make your changes in the image storage group it will not change the rest of the images location storage group. Then if you have multiple storage nodes in that storage group you could re-enable it in the image options to replicate and update. No issues to rest of images. Weird observation though.



  • @jgallo mine is a different problem though. Just leaving a single image on the default storage group with 1x storage node and 1x master node, it will not deploy images from the Storage Node within the same location as the storage node.

    The storage groups I really don’t care about, it’s the problem with imaging from different locations is not working. I can’t image a PC from the Storage Node only the master node… which is super super slow.



  • @tom-elliott reading through that post, and just having to create a new image on my fog server version 1.5.2.28 it does exactly what the post states. When I try to change the Storage Group from default to the Storage Group I want it will change all the images location to default except the one I just changed.



  • @tom-elliott

    So this is my problem though and I am not sure if its related or not.

    Main Fog Server - Subnet A - set to the default storage group as “MASTER”
    Storage Node - Subnet B - default storage group - set to non-master

    Still if I image from Subnet B, it should point to the Storage Node instead of the main fog server even though its not “master” correct?

    I saw the other guys post he had all his storage nodes set to master.

    Is there maybe an easy work around I can do to force Computers from Subnet B to forcefully image from Storage Node on Subnet B?


  • Senior Developer

    Is it a lot like:
    https://forums.fogproject.org/topic/11773/storage-group-association-again-upload-mode/13

    I’m aware of a problem that I’ve fixed partially, but haven’t gotten around to see why the node association keeps changing. According to the post, it is working when setup, but another change to an image association is changing all, or at least that’s what I’m gathering.

    Basically, things are working except when initially changing the image’s group associations.



  • @jgallo So now after upgrading it fixed computers trying to image on the master node network, but it still FAILS when I try and get my storage node working.

    Computers imaging from Master subnet = works
    Comupters imaging from Storage Node subnet = does NOT work. It still points to the master node which is 500 miles away lol

    Any other ideas? I am currently using the “working” branch.



  • I had similar problem except that instead of deploying I was trying to upload image but it was going to different Node on seperate subnet. I updated the master FOG server and it resolved itself. I was on 1.5.2 but then after switching over to working branch and updating to 1.5.2.28 it worked out. Really weird though.


Log in to reply
 

493
Online

6.2k
Users

13.6k
Topics

128.3k
Posts